Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Pin separate Windows 10 taskbar icons for separate simultaneous Firefox profiles

  • 2 uphendule
  • 2 zinale nkinga
  • 3640 views
  • Igcine ukuphendulwa ngu shedsan

more options

Until Firefox 62.0, I was able to pin separate taskbar icons for separate, simultaneously running Firefox profiles in Windows 10 by doing the following:

1) Add about:config boolean: "taskbar.grouping.useprofile" set to "true." (Described in this Mozilla bug-fix: https://bugzilla.mozilla.org/show_bug.cgi?id=577867)

2) Set target of each separate pinned icon to "C:\Program Files\Mozilla Firefox\firefox.exe" -p [user-profile-name] -no-remote

However, with the latest update these settings have no longer have the intended effect, and open instances of multiple profiles are grouped into one taskbar icon.

Is there a new way to pin separate taskbar icons for separate, simultaneously running profiles in Windows 10?

Isisombululo esikhethiwe

Could you try this workaround, which I don't understand but is the only thing I could find:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste start and pause while the list is filtered

(3) Double-click the browser.startup.blankWindow preference to switch the value from true to false

Source: https://www.reddit.com/r/firefox/comments/9dijms/firefox_62_messed_up_my_separate_taskbar_buttons/e5mh9nn/

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (2)

more options

Isisombululo Esikhethiwe

Could you try this workaround, which I don't understand but is the only thing I could find:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste start and pause while the list is filtered

(3) Double-click the browser.startup.blankWindow preference to switch the value from true to false

Source: https://www.reddit.com/r/firefox/comments/9dijms/firefox_62_messed_up_my_separate_taskbar_buttons/e5mh9nn/

more options

Thank you! That solved it!