Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

What do I do if I get the "your connection is insecure" for the Firefox start screen itself?

  • 9 uphendule
  • 3 zinale nkinga
  • 2348 views
  • Igcine ukuphendulwa ngu suzel

more options

All the solutions for "your connection is insecure" error message are for other websites, not the Firefox start screen itself. I started to get this message all of a sudden on 2 different computers. What is going on? And what can I do to go back to using Firefox?

Isisombululo esikhethiwe

Thank you for the URL. I didn't realize there was a page at that address. I get an error page, too.

When I click the "Advanced" button, Firefox informs me of three problems:

(1) The certificate is not trusted because it is self-signed.

(2) The certificate is only valid for 98942fff4d7c7e888e33e5092199e36d.06174e5377efe73ff81f35eea72068bf.traefik.default.

(3) The certificate expired on Tuesday, September 11, 2018, 3:56:13 PM. The current time is September 12, 2018, 10:01 AM.

Error code: MOZILLA_PKIX_ERROR_SELF_SIGNED_CERT

At least for now, you may want to use a different start page. You can modify it on the Preferences page, "Home" panel. See also: How to set the home page.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (9)

more options
more options

I’ve seen all this. The problem I’m having isn’t with a particular website, but with Firefox start URL itself. I can’t use the browser AT ALL. To my knowledge, I don’t have Symantec virus protection or any of the others. Instead I rely on resident Apple stuff. I can’t see how any of the actions on the referenced support page are relevant to this situation.

more options

suzel said

All the solutions for "your connection is insecure" error message are for other websites, not the Firefox start screen itself.

I'm not sure what you mean by "the Firefox start screen itself" (?)

At startup Firefox opens your homepage ......

more options

Firefox's built-in home page (the new tab page) doesn't use an HTTPS connection, so it can't trigger an HTTPS connection error. However, if a top site thumbnail image is missing, Firefox may attempt to connect to the site in the background and capture a thumbnail image, and that sometimes leads to strange things.

Anyway, after the error page loads, can to visit sites you want to visit using any of these methods:

  • submit a search through Firefox's address bar
  • type or paste an address in Firefox's address bar
  • use a bookmark to load a site

If you try one or more of those, how far do you get?

more options

Thanks, jscher2000! The page that opens as my start page is https://start.mozilla.org/en-US/ The error message I get is:

The owner of start.mozilla.org has configured their website improperly. To protect your information from being stolen, Firefox has not connected to this website.

This site uses HTTP Strict Transport Security (HSTS) to specify that Firefox may only connect to it securely. As a result, it is not possible to add an exception for this certificate.

This morning for the first time I got 2 pages on opening--the one above AND an additional page which allowed me to go to other websites.

Should I just ignore the error page in this case? And what should I do if I get only it again?

more options

Isisombululo Esikhethiwe

Thank you for the URL. I didn't realize there was a page at that address. I get an error page, too.

When I click the "Advanced" button, Firefox informs me of three problems:

(1) The certificate is not trusted because it is self-signed.

(2) The certificate is only valid for 98942fff4d7c7e888e33e5092199e36d.06174e5377efe73ff81f35eea72068bf.traefik.default.

(3) The certificate expired on Tuesday, September 11, 2018, 3:56:13 PM. The current time is September 12, 2018, 10:01 AM.

Error code: MOZILLA_PKIX_ERROR_SELF_SIGNED_CERT

At least for now, you may want to use a different start page. You can modify it on the Preferences page, "Home" panel. See also: How to set the home page.

more options

I wonder why I suddenly started getting this as my start page on both my computers??!! Will try this later, no more time now. Thanks so much! I'll let you know what happens.

more options

start.mozilla.org is no longer supported, it's been retired in favor of the new, built in, Firefox start screen.

I'd suggest either using another website, or Restore the default home page to use the new default home page.

more options

Tyler, thanks for seconding the solution jscher2000 suggested. It worked on both my computers. For some reason I didn't have the homepage set for the default. That must have happened many, many years ago... PROBLEM SOLVED! Thanks so much to both of you and to Firefox for this great support community!!