Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Why is it EVERY upgrade of FFox screws with website fonts?

  • 29 uphendule
  • 1 inale nkinga
  • 72 views
  • Igcine ukuphendulwa ngu cor-el

more options

Always have to waste time fixing this. With the power of technology today, why can this never be solved? Last time I finally found some source advising me to log into admin config or something. Then change a '1' to a '2'.

I tried it again this time. Does not remain resolved. Constant back & forth closing browser, restarting which fixes if for day or two, then back to same mess. WHY cannot this be resolved before sending out the upgrade?

After I fixed this last upgrade, it remained fixed.

Not THIS time. Fonts still reverting to skinny Hv light ital or similar. Not consistent. Could occur on some pages, others not.

All Replies (9)

more options

smithl said

Mozilla is like talking to a brick wall.

Did you file a bug report? https://bugzilla.mozilla.org/

more options

What font is Firefox trying to use as a replacement of what font?

You can check the font used for selected text in the Font tab in the right pane of the Inspector. Note that this is not about the font-family CSS rule, but about the font that Firefox actually uses as shown in the Font tab.


You can check for sandbox security issues when Firefox has a problem to access fonts installed locally.

You can set this pref to 2 or 1 on the about:config page to reduce the sandbox security level.

  • security.sandbox.content.level = 1
  • close and restart Firefox to make the change effective.

If '1' still doesn't have effect then try '0' to disable the sandbox.

If this didn't work then undo/reverse the change and reset the pref via the right-click context menu to the default value.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

See also:

more options

I just sent a report to Bugzilla. thanks.

Unlike previous FFox version, sandbox doesn't solve this same issue in v62.

Honestly, I do graphic design. I am not a programmer. I can't afford to be spending all this time doing Mozilla's job. I've already spent valuable time trying to resolve it.

It was the same with Safari & Chrome's forum Q&A's. It was only after the next upgrade that they never had that issue. Somebody figured it out on their side, not the consumer's side.

I posted page samples earlier in this post of what the replacement font looks like.

more options

page sample of font replacements by FFox...

more options

It is not about what is looks like, but about what font should be used and what Firefox has chosen to use as a replacement. That is why I posted above to check this in the Font tab in the right panel in the Inspector. You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected.

more options

Thanks. But this is what I saw on (image attached) the Inspector page. No help to me at all. Did not see "Inspect Element". I don't have a "right click" mouse. As I stated earlier. I am not a programmer.

Neither Safari nor Chrome pushed me into this microcosm of tech savvy. They fixed it. I'm doing Mozilla's job here. Another wasted hour.

The Inspector view doesn't even show me what the instructions indicate I'm suppose to see here. Version 62 doesn't have the Editor, whether I need that or not. https://developer.mozilla.org/en-US/Tools/Page_Inspector

more options

I know when I changed back from new to classic I left all my FF setting to mostly default and had not font issue. But I am on Windows 10 here. Only thing I can say is uninstall your FF and delete the Mozilla folder and reinstall again to see if there wasn't something that got corrupted in FF to cause the font issues. Usually fonts going blurry like what I see is result of corrupted files causing the problem and narrow it done is next to impossible since the file won't be consider corrupted by the system.

more options

Yahoo was already open which displayed normally meaning fonts were correct. I had checked mail etc. Went to other computer functions, jobs etc. In few minutes, came back to click Yahoo tab for email. That's ALL I did. Did not open any other web pages. Just out of clear blue decides to switch fonts. This is the page that appeared....

more options

You need to open the Inspector on a page that has issues with the font(s).

The above screenshot shows the Inspector with MDN article and apparently there aren't any font issues (shows that the Verdana font is used).

  1. 1
  2. 2