Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Why is it EVERY upgrade of FFox screws with website fonts?

  • 29 uphendule
  • 1 inale nkinga
  • Igcine ukuphendulwa ngu cor-el

more options

Always have to waste time fixing this. With the power of technology today, why can this never be solved? Last time I finally found some source advising me to log into admin config or something. Then change a '1' to a '2'.

I tried it again this time. Does not remain resolved. Constant back & forth closing browser, restarting which fixes if for day or two, then back to same mess. WHY cannot this be resolved before sending out the upgrade?

After I fixed this last upgrade, it remained fixed.

Not THIS time. Fonts still reverting to skinny Hv light ital or similar. Not consistent. Could occur on some pages, others not.

All Replies (20)

more options

Here's a sample from Yahoo mail page....

more options

Apparently Mozilla in no rush to resolve this ongoing issue from previous upgrades. Many others are suffering from this font issue as well according to forums. Which would imply that even Mozilla would have this problem. Yet they appear to tolerate it.

more options

Yes, that looks pretty terrible.

Do you recall what setting you were changing? Was it related to the security sandbox?

When you say restarting the browser fixes it for a day or two, do you mean without changing anything, just Quit Firefox, start it back up, and everything is fine until it stops working normally again?

more options

thanks for response. When same happened with last upgrade, I finally found a solution in a forum (Mozilla?). This person suggested signing into a site called something like admin.config. This opened a page of seemingly endless lines of text. I scrolled down to - I think it was sandbox perhaps.

Anyway, all he suggested was changing, in that line, a '1' to a '2' or vice-versa.

That's what I did again with current upgrade. Seemed to work. Then shortly afterwards, some instances of site pages reverted back to this super thin Hv like font. Totally unpredictable.

The solution did say to restart browser after making the numerical change.

more options

You might want to bookmark threads like that for future reference the next time. Maybe someone else will have a better guess than me.

more options

Here is a link to the solution which worked with last upgrade before 62.0

Not working as well with latest upgrade.

more options

Just for background, the sandbox restricts web pages from using font files and other resources outside of a particular set of folders. So once you change that, you shouldn't notice fonts changing in mid-session. So it's probably some other problem.

If you only notice the problem on particular sites, have you tried the typical things:

Double-check content blockers: Firefox's Tracking Protection feature and extensions that counter ads and tracking may break websites that weren't built to operate normally without the blocked components.

Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: What happened to Tracking Protection?.

Extensions such as Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site.

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "Clear Cookies and Site Data"
  • (menu bar) Tools > Page Info > Security > "Clear Cookies and Site Data"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "Clear Cookies and Site Data" button

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

Testing in Firefox's Safe Mode: In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement? It may be difficult to tell a Safe Mode restart apart from regular restart if the regular restart usually helps.

more options

Nothing I've tried has resolved this. The security sandbox digits, tried all '0' '1' '2' None worked unlike last upgrade before 62.0

If you get a new car from a dealer and something goes wrong with it, would the dealer tell you to fix it? They would soon be out of business.

For some apparent unknown reason, whoever writes the upgrade code can never resolve this font-changing problem. It's always left up to the user to figure it out.

Had similar font problem with Chrome & Safari couple years back. No one, not even on forums had a clue how to fix it. Finally with the next upgrade, it was fixed. Who knows how it was done.

Now that they figured it out, will probably go back to those browsers and be done with it.

I've been on same computer with same OS. Haven't changed anything including hardware, software, FFox add-ons or preferences.

Bug is in the new upgrade 62.0

more options

Did you switch yahoo mail back to classic to see what happens? From the looks of it - it looks like a resolution problem settings. So did you check that as well. I have my yahoo mail set at classic because I didn't like the looks of the newer version. And that might be part of the problem here as well.

more options

Thanks for suggestion. Not sure what you mean by 'resolution problem'. If it's screen resolution, I haven't changed that since I set up computer. Although I do like Yahoo Classic better, it did not solve the issue.

So still no word from Mozilla on this pervasive issue. I've seen vast entries in this forum about this font instability issue. They never resolve it from one upgrade to the next. I always have to waste time (which means losing money) going through this jungle every time.

If Chrome & Safari can fix it, this means it can be fixed. Someone knows how to fix it. Perhaps it's a trade secret?

They need to give users the option of upgrading rather than upgrading automatically. At least option of going back to last version which I finally managed to correct.

more options

I personally don't remember any other threads about fonts suddenly going wacky in the middle of a browsing session. However, I can't read every thread here.

Maybe you could file a bug report with the best known steps to reproduce the problem. If it can be triggered on a developer's machine, that gives you a better shot at getting it solved. Otherwise, it could remain in the category of "sh*t happens" until someone spots the pattern.

more options

thanks for the bug link. I was not aware of this. Here is one thread displaying numerous queries about font display issues. Others appear depending how you phrase the search question. This is result of <font> search... </font>

more options

It just gets worse. Bugzilla won't even allow me to establish an acct to enter bugs. Email entry is legitimate. Use it everyday. They did not send option to enter pword for new acct.

more options

Finally approved a different email.

I entered < fonts not displaying correctly on web pages > on Bugzilla

No results.

more options

You can get this error on Bugzilla if you are blocking JavaScript, so make sure to check content blocking extensions.

  • Bug 1486586 - Please make it easier to create an account / login without javascript

(please do not comment in bug reports

more options

The "WestEnd" entry above suggesting switching Yahoo back to Classic seems to have been the solution. Of ALL the other maneuvers I've tried, this one made a difference, strange as it may seem.

I would never have suspected this seemingly unrelated solution. I did switch sandbox back to '1' but I had already tried all the digits. Perhaps it was a combination of tweaks.

Regardless, the Classic switch is working so far. All site text appears as normal.

Gracias WestEnd !!!

more options

Retracting my above response to 'WestEnd'. Font issue remains. Not only in Yahoo but in Facebook and other pages. Page fonts change to very thin Hv italic.

Only closing ALL tabs and restarting FFox restores it. I'm going to another browser. This is unprofessional on part of FFox.

more options

I just dumped Yahoo cache & cookies as I do periodically or daily. Then restarted Yahoo and NOT FFox. Fonts restored to normal even on FBook.

So logically, this would indicate there IS something haywire with Yahoo, which then, for some unexplained reason, infects other sites like FBook.

Still why wouldn't the browser stop this behavior. Once fixed on last upgrade, I never had this issue again. Not possible with this upgrade.

This problem doesn't exist on Chrome or Safari.

more options

smithl said

This problem doesn't exist on Chrome or Safari.

The user in this thread used Chrome ......

more options

Check this thread. After all this, FFox still hasn't resolved the issue. Without even opening Yahoo, If I only have AOL open, then, say open FBook, thin italic text appears in vital places making reading virtually illegible.

Sometimes even appears in some AOL mail I open with only AOL the only tab open.

I have to close all tabs, browser then reopen everything which then displays proper fonts.

Mozilla is like talking to a brick wall.

It's nice others offer ideas, but none resolve it. As I have stated before, Safari & Chrome used to have similar issue only worse displaying gibberish unreadable period. They fixed it. It can be resolved. Perhaps Mozilla could call Chrome support.

Last FFox upgrade had same issue, then resetting digits in sandbox finally remedied it. Current upgrade not doing it. Nothing resolves the "replacement" font.

  1. 1
  2. 2