X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

localhost: SSL_ERROR_RX_RECORD_TOO_LONG

Kuphostiwe

Visual Studio 2017 and using FF Developer for debugging. As off some time this weekend I get this error message.

Worked fine last week.

My local webconfig has the redirect to HTTPS rule disabled. So I am going to localhost, at least not with FF Developer or regular FF has the same error.

Works fine on Chrome and Opera.

Visual Studio 2017 and using FF Developer for debugging. As off some time this weekend I get this error message. Worked fine last week. My local webconfig has the redirect to HTTPS rule disabled. So I am going to localhost, at least not with FF Developer or regular FF has the same error. Works fine on Chrome and Opera.

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/68.0.3440.106 Safari/537.36 OPR/55.0.2994.44

Eminye Imininingwane

cor-el
  • Top 10 Contributor
  • Moderator
17525 izisombululo 158458 izimpendulo
Kuphostiwe

Does this apply?

You can no longer use some domains like .dev locally because its owner (Google) has added this domain to the HSTS preload list and a secure connection is automatically enforced. The ".dev" domain landed on the HSTS preload list in Firefox 59.0b7 and this means that Firefox will automatically try a secure connection to these TLDs.

A possible workaround could be to disable the HSTS preload list, but this is not recommended.

  • network.stricttransportsecurity.preloadlist = false
Does this apply? You can no longer use some domains like .dev locally because its owner (Google) has added this domain to the HSTS preload list and a secure connection is automatically enforced. The ".dev" domain landed on the HSTS preload list in Firefox 59.0b7 and this means that Firefox will automatically try a secure connection to these TLDs. A possible workaround could be to disable the HSTS preload list, but this is not recommended. *network.stricttransportsecurity.preloadlist = false *[https://medium.engineering/use-a-dev-domain-not-anymore-95219778e6fd]