Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox does not open sites, only blank page, when clicking link

  • 9 uphendule
  • 3 zinale nkinga
  • 3454 views
  • Igcine ukuphendulwa ngu FredMcD

more options

After the latest upgrade to FF Developer edition 63.0b1 on Mac El Capitan, most of the time I get only a new blank page when clicking a link in an email or url-alias on the desktop. Oddly enough it is not always the case. I tried restarting FF and Mac to no avail. Any ideas?

Isisombululo esikhethiwe

Hi guys, guess what. Today I got a new update of Firefox to 63.0b2 and the problem is gone. Thanks anyway. Sometimes one has just to wait and problems solve themselves. ;-)

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (9)

more options

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}

more options

Thanks. But the problem is still there, also in Safe mode. :-( So that makes no difference.

But ... I did a lot of experiments and found out that when there is already a window open, it works. When no window is open, FF creates a new window which is blank, when clicking on a url link in mail or so.

more options

Please go to Options --> Home and check the Url that should be your homepage has no extra characters in the line and go to the page by bookmark or tyoing and Click on Use Current Page. Restart Firefox from 3 Bar Menu --> Exit

more options

The homepage url is and was always "empty page". Sorry, don't understand what you mean by: "Restart Firefox from 3 Bar Menu --> Exit" I restarted Firefox many times ...

more options

Piroo said

The homepage url is and was always "empty page".

That is not a valid address. For a blank page, it should be about:blank

more options

At preferences: "Homepage and new windows" we got these choices (translated): • Firefox homepage (standard) • Special URLs • Empty page I have always selected the third one which says Empty page. When I make a new page, there is nothing in the address bar. What am I missing here?

more options

It's not you, it was the translation.

more options

Isisombululo Esikhethiwe

Hi guys, guess what. Today I got a new update of Firefox to 63.0b2 and the problem is gone. Thanks anyway. Sometimes one has just to wait and problems solve themselves. ;-)

more options

Good to hear. Safe surfing.