Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Webpages load very slowly or not at all, only Firefox has this issue on my PC.

  • 4 uphendule
  • 1 inale nkinga
  • 10 views
  • Igcine ukuphendulwa ngu Zayphod

more options

Hi there. I've been using Firefox for many years, and have never come across this issue. Over the past 24-48 hours, I've noticed a problem with Firefox being able to load pages. The problem comes and goes, but is getting more frequent, despite my troubleshooting. Sometimes I have one tab open and can surf just fine, but other tabs get stuck in perpetual loading, or no tabs will load at all. My internet connection is fine: I've checked and rechecked all of my VPN settings, and tested other browsers (Chrome and Edge) and they have no issue at all with loading multiple pages on multiple tabs.

I have troubleshooted the settings in Firefox as laid out on the support pages here: changing settings, checking my firewall settings, resetting Firefox, restoring to default, uninstalling and reinstalling, and nothing seems to fix the issue. I do not wish to find a different browser, as I have been very pleased with this one over the years, but it's getting to the point where that may have to be an option if I cannot fix this problem. Please advise on where I should go from here. Thanks!

All Replies (4)

more options

Hi, sorry having issues. Please supply a list of add-ons, and what security program your using which would have been more helpful to have supplied.

SAFE MODE

In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected

TEST''''is issue still there ?

There is security software like Avast/AVG, Kaspersky, BitDefender, ESET sometimes McAfee that cause issues with there scanner or certificates.

more options

Note that a refresh can carry over problems by importing specific data.

You can create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

I'm really struggling with the same problem. ie

Webpages load very slowly or not at all, only Firefox has this issue on my PC.

a reply to the same problem here says its conncted to the 'archive' files in the profile. I've tried to delete the archive file - I think its called places.sqlite (about 5k) but this file and another 2 'places. files keep coming back - & webpages continue to load slowly

am I doing something wrong ?

more options

I'm really struggling with the same problem. ie

Webpages load very slowly or not at all, only Firefox has this issue on my PC.

a reply to the same problem here says its conncted to the 'archive' files in the profile. I've tried to delete the archive file - I think its called places.sqlite (about 5k) but this file and another 2 'places. files keep coming back - & webpages continue to load slowly

am I doing something wrong ?