X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Thunderbird shows wrong time in date column with correct date header

Kuphostiwe

Arch Linux, TB 60.0

In the date column of any folder in any mail account the date is shown incorrectly (-1h). The date and received headers are correct for all mails and the date is correctly shown in the preview pane. I would say that TB does not add the DST, because my timezone is CEST (+0200), but the date is shown for (+0100).

Settings: Regional settings locale for date and time formatting with: LANG=en_US.utf8 LC_TIME=de_DE.utf8

Things I have already tried: - Date() in the JavaScript console shows the correct time and date - Changing the display format to application locale does nothing except now I can see the wrong time in an am/pm format - Setting mailnews.customDBHeaders to 'Received' did not change anything

Arch Linux, TB 60.0 In the date column of any folder in any mail account the date is shown incorrectly (-1h). The date and received headers are correct for all mails and the date is correctly shown in the preview pane. I would say that TB does not add the DST, because my timezone is CEST (+0200), but the date is shown for (+0100). Settings: Regional settings locale for date and time formatting with: LANG=en_US.utf8 LC_TIME=de_DE.utf8 Things I have already tried: - Date() in the JavaScript console shows the correct time and date - Changing the display format to application locale does nothing except now I can see the wrong time in an am/pm format - Setting mailnews.customDBHeaders to 'Received' did not change anything

Isisombululo esikhethiwe

Try exporting your TZ variable in .pam_environment and do NOT include "/usr/share/zoneinfo", just the zone/subzone.

So, for your specific set up, try adding this to your ~/.pam_environment: TZ=:Europe/Berlin

Another option that should work is to add "export TZ=:Europe/Berlin" to your launcher for Thunderbird.

I assume the package maintainer for Arch Linux will probably find some way to not need this workaround at some point.

Edited to include colon when TZ is pointed to a zoneinfo file per https://www.gnu.org/software/libc/manual/html_node/TZ-Variable.html

Funda le mpendulo ngokuhambisana nalesi sihloko 0
Isicaphuno

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (X11; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0

Eminye Imininingwane

Matt
  • Top 10 Contributor
  • Moderator
2863 izisombululo 19374 izimpendulo

check the TZ environment variable.

check the TZ environment variable.
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

timedatectl status gives me:

Local time: So 2018-08-12 10:18:46 CEST
Universal time: So 2018-08-12 08:18:46 UTC
RTC time: So 2018-08-12 08:18:51
Time zone: Europe/Berlin (CEST, +0200)

and echo $TZ shows

/usr/share/zoneinfo/Europe/Berlin
timedatectl status gives me: Local time: So 2018-08-12 10:18:46 CEST Universal time: So 2018-08-12 08:18:46 UTC RTC time: So 2018-08-12 08:18:51 Time zone: Europe/Berlin (CEST, +0200) and echo $TZ shows /usr/share/zoneinfo/Europe/Berlin
Ingabe lokhu kube usizo kuwena?
Isicaphuno
ajdunevent 2 izisombululo 3 izimpendulo

I've posted about a similar issue that may be related: https://support.mozilla.org/en-US/questions/1230579

I've posted about a similar issue that may be related: https://support.mozilla.org/en-US/questions/1230579
Ingabe lokhu kube usizo kuwena?
Isicaphuno
ajdunevent 2 izisombululo 3 izimpendulo

Isisombululo Esikhethiwe

Try exporting your TZ variable in .pam_environment and do NOT include "/usr/share/zoneinfo", just the zone/subzone.

So, for your specific set up, try adding this to your ~/.pam_environment: TZ=:Europe/Berlin

Another option that should work is to add "export TZ=:Europe/Berlin" to your launcher for Thunderbird.

I assume the package maintainer for Arch Linux will probably find some way to not need this workaround at some point.

Edited to include colon when TZ is pointed to a zoneinfo file per https://www.gnu.org/software/libc/manual/html_node/TZ-Variable.html

Try exporting your TZ variable in .pam_environment and do '''NOT''' include "/usr/share/zoneinfo", just the zone/subzone. So, for your specific set up, try adding this to your ~/.pam_environment: TZ=:Europe/Berlin Another option that should work is to add "export TZ=:Europe/Berlin" to your launcher for Thunderbird. I assume the package maintainer for Arch Linux will probably find some way to not need this workaround at some point. Edited to include colon when TZ is pointed to a zoneinfo file per https://www.gnu.org/software/libc/manual/html_node/TZ-Variable.html

Okulungisiwe ngu ajdunevent

Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

That worked. Thanks a lot.

That worked. Thanks a lot.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.