Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How do I stop Google from starting up Mozilla instead of my assigned home page?

  • 10 uphendule
  • 1 inale nkinga
  • 69 views
  • Igcine ukuphendulwa ngu Buscador

more options

At startup Mozilla goes to Google search rather than my designated home page. Home page is properly established.

Isisombululo esikhethiwe

Buscador, any follow-up? Just fyi, the online privacy extension you had installed was malicious, so we blocked them. Did you run a Malwarebytes scan? Is Firefox working better now?

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (10)

more options

Hi, please Copy/Paste about:preferences#home to the Address Bar and Enter. Remove every single Check Mark on the page including Web Search.

Homepage and new windows Set to Custom URL

Put your URL in below that, if you multiple tabs to open can add more URL's but separate with a vertical line ( | )

New Tabs is set to Firefox Home (Default)

more options

Or it is because of this Search Extension by Ask, should be removed.

more options

Thanks Pkshadow, I tried your first suggestion but the problem persists. I am using Mozilla 61.0.2 (64-bit) in Windows 10.

I don't understand: "Or it is because of this Search Extension by Ask, should be removed."

more options

This could be the problem your getting Google though Search Extension by Ask usually goes to Ask.com and is not reputable for it's searches. If you want Ask results stick this in and get protection also : https://addons.mozilla.org/firefox/addon/norton-safe-web/

Ok, the 1st message is how I am setup other than the URL.

As to why your not.....

https://support.mozilla.org/en-US/kb/how-to-set-the-home-page

more options

Thanks again.

1) I don't think I have a Search Extension by Ask, At least i can't see it anywhere. Besides Google I have Bing, Amazon, Twitter, and a whole bunch but Ask. So I don't think that's the problem.

2) I have the home page properly set up, believe me.

This is what happens. At starting Mozilla the home page appears for a millisecond intermediately to be replaced by Google's search page. The same thing happens if Mozilla starts after clinking a URL link in a email, for example.

Okulungisiwe ngu Buscador

more options

You have these as showing as active : Dashlane 6.0.3 (jetpack-extension@dashlane.com) Online Privacy 1.5 (privacypro@mybestprivacy.com) Search Extension by Ask 50.100.12.64537 (_j5Members_@ext.ask.com)

Please check again and disable Online Privacy and Search Extension

Please use more than 1 scanner as each uses diff tech :

Save your Report and google each before deleting anything as do not want to delete something you need, If need help :

Post in only 1 forum, then wait.

Please let us know if this solved your issue or if need further assistance.

more options

The Online Privacy 1.5 (privacypro@mybestprivacy.com looks suspicious. I'm going to assume that extension is malicious. Please uninstall it, and run a scan with malwarebytes (www.malwarebytes.com)

more options

AudioToAudio 8.837.13.45905 (_8iMembers_@download.audiotoaudio.com) (Inactive) FromDocToPDF 8.837.13.46585 (_65Members_@download.fromdoctopdf.com) (Inactive) PDFConverterHQ 8.837.13.47884 (_fsMembers_@free.pdfconverterhq.com) (Inactive)

These also looks like virus related

more options

Isisombululo Esikhethiwe

Buscador, any follow-up? Just fyi, the online privacy extension you had installed was malicious, so we blocked them. Did you run a Malwarebytes scan? Is Firefox working better now?

more options

Yes, I followed instructions above and the problem seems to be gone. Thanks much for your help, I really could not have fixed it without it.

Okulungisiwe ngu Buscador