Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox won't open maximized

  • 2 uphendule
  • 2 zinale nkinga
  • 1614 views
  • Igcine ukuphendulwa ngu M W Sasser

more options

There are several support questions on this topic. However I can't get their recommendations to work.

I've deleted the possibly corrupt xulstore.json or Localstore.rdf file. Is there something else I can check? Maybe it's using a profile in a different location than %AppData%\Mozilla\Firefox\Profiles on Windows?

I am currently on version 62.0b14 64-bit.

Isisombululo esikhethiwe

I found my solution.

In about:config there is a setting privacy.resistFingerprinting.

If it's set to True, then my screen is small at launch. It's pretty darn frustrating.

It looks like you can add keys privacy.window.maxInnerWidth and privacy.window.maxInnerHeight with pixel sizes. However I did not test these as I wanted specifically want Firefox to be maximized.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (2)

more options

I think the xulstore.json is in the proper place.

If I close Firefox then edit the file to remove the main-window object, it replaces it again with bad settings.

"main-window":{"screenX":"3","screenY":"3","width":"1024","height":"823","sizemode":"maximized"}

Any suggestions?

more options

Isisombululo Esikhethiwe

I found my solution.

In about:config there is a setting privacy.resistFingerprinting.

If it's set to True, then my screen is small at launch. It's pretty darn frustrating.

It looks like you can add keys privacy.window.maxInnerWidth and privacy.window.maxInnerHeight with pixel sizes. However I did not test these as I wanted specifically want Firefox to be maximized.