Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Menu being cut in half.

  • 12 uphendule
  • 1 inale nkinga
  • 351 views
  • Igcine ukuphendulwa ngu Smokva

more options

Version 61.0.1 being used (64-bit). Win 7. Menu being cut in half. Can be reset by toggling menu on and off, but it comes back. Saw the reference to similar problem in 2017 question that was attributed to "Tab Groups" extension, but I do not have that ext. The only remotely related extension I have is Vertical Tabs. And although I love that extension, I actually had it disabled because I have been using Web Developer docked to the side for the last few days and the problem is still happening. So definitely not it.

Other than the super-duper Vertical Tabs, I have: Decentraleyes, Disconnect, Flag Fox, Font Finder, Google Search Link Fix, Nimbus, NoScript, Turn-off-the-lights, and U-Block Origin. Pretty basic add-ons. Theme is default, and no other ones loaded. (I'm very boring). Open264 and Widevine plugins only. Images attached.

As waiting for it to revert can take hours, it could take well over a week to test all of my extensions. So I figured I would check to see if anyone else had similar problems and figured something out.

It's not a huge deal. Like I said, you can get it back simply by turning the menu off and on. But it does revert and it gets annoying as I do use the menu quite a bit, and I usually end up clicking on the tab instead of the menu item. So I always have to get it to its normal size.

Anyone else having this problem?

Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

Does it make a difference if you enable the title bar via the checkbox on the customization page?

  • you can toggle the title bar on/off via the "Title Bar" button at the bottom left in the Customize palette window

Are you using code in userChrome.css?

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (12)

more options

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

Isisombululo Esikhethiwe

Does it make a difference if you enable the title bar via the checkbox on the customization page?

  • you can toggle the title bar on/off via the "Title Bar" button at the bottom left in the Customize palette window

Are you using code in userChrome.css?

Okulungisiwe ngu cor-el

more options

@FredMcD I've restarted in safe mode. The menu feature did not appear automatically so I had to activate it. As in all cases when I toggle it on/off, the menu bar is fine. So It will take some time to figure out whether the problem reappears. I knew that this is the process I should go through, but as I mentioned originally, I was hoping to avoid a long testing period in case someone else recently began experiencing a similar issue.

@cor-el

Are you using code in userChrome.css?

If you're asking if I modified it in any way, the answer is no. Was not really aware it existed actually. Other than adjusting security options, I really don't fiddle with the base program. Like I said, I'm boring. :)

Does it make a difference if you enable the title bar via the checkbox on the customization page?

Now this is interesting... the title bar may force the menu to display fully. Kind of reminds me of padding/margin hacks for divs.

I am currently testing the 'safe-mode', and want to give it enough time to determine whether the issue is associated with an add-on (highly probable). But before I start testing individual add-ons, I will try this. It would be interesting to see if the menu is forced to display fully, and if so, whether the effect will end up transferring to the title bar.

As I mentioned, I really have no time line on how long it takes the issue to reappear, so it may be a day or so before I can accurately report on both suggestions. But I will. And thank you.

more options

Is your FF standard layout no userChrome.css added?

more options

This may or may not be similar to your situation:

I don't show the menu bar, so I have tabs at the top. I notice that on rare occasions the top half of the tabs are cut off. I think this is caused by changing between an external monitor and the laptop panel, which have different resolutions, when Windows is asleep.

Using the buttons to "restore" and then "maximize" the window forces Firefox to redrawn it correctly when that occurs.

more options

OK. Update: @FredMcD: Problem just reappeared in safe mode. Evidently add-ons not the problem. I admit I am surprised; I figured an add-on was most likely the problem. FF bug maybe?

@cor-el: I will try your title-bar idea now to see if it makes a difference. I'm actually very intrigued with this possible 'hack'!

@WestEnd: Yes. Default is used. (see my previous answer)

@jscher2000: Interesting. It does sound related. However, in this latest instance, my monitor did not get a chance to 'sleep' although I was not using FF. (I was playing a mind-numbing game though that did change screen resolution before I decided it was time to get back to work. :)

Okulungisiwe ngu Smokva

more options

Update: So about 24 hours has passed, and my menu has not been cut-off nor has the title. Yay!! Although I do believe this is a bug in Firefox, this little "hack" suggested by @cor-el appears to be an effective interim solution. Therefore I will mark this as solved and leave it to the admins to decide whether or not this issue should be reported as a bug.

more options

I assume that you could use a style rule in userChrome.css to lower the menu bar text, but it is hard to tell what rule(s) you need if I can't replicate this. You do not show the full top line, so I don't know how the control buttons are postioned.

Add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#menubar-items { margin-top: 8px !important; }
more options

@cor-el cor-el said

.... You do not show the full top line, so I don't know how the control buttons are postioned.

Hmmm.... I tried really hard to understand what you mean by 'how control buttons are positioned' and am stumped. I'm more than happy to include an image of whatever you need. I'm kind of curious myself as to what the problem was especially considering that I have not done any customizing since the major transition update last year. It is obviously something that has occurred within the last few updates and I am somewhat surprised that I am the only one experiencing it particularly since my display is about as 'default' as you can get.

While I am perfectly happy with your hack as the title bar does not really bother me at all (thank you again for that), I admit I am also curious about this 'buggy' behaviour. So if you can describe for me what you need to see, I would be happy to provide it for you.

EDIT: Wait... I just thought of something. By control buttons, do you mean the max/min/close? Come to think of it, I don't remember how they displayed. While I wait for your answer, I will reset my page and wait for the issue to reappear. That way I can provide an image for whatever you want.

Okulungisiwe ngu Smokva

more options

The window control buttons are the three icons (minimize, maximize, close) that you see at the at the right end of the title bar and are moved to the menu bar or tab bar when you hide the title bar or menu bar.

more options

@cor-el

) You were quick.... but got it.

I've reset the browser without the title bar and will post an image of the full thing once the bug reappears.

more options

@cor-el

Well... that was fast. I guess the bug was just itching to come back! Here is the image. The control buttons are fine... which although weird, does explain why I couldn't recall anything strange happening with them ... nothing to notice. :)

I'll keep the bug active in case you want any other info.