Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Why is Firefox not displaying sites correctly?

  • 9 uphendule
  • 1 inale nkinga
  • 16 views
  • Igcine ukuphendulwa ngu jscher2000

more options

This is an ongoing issue that i am still to find a solution for. Certain website pages are not loading or working as they should when using the Firefox moxilla browser. Images dont load, links either don't work or wont load at all and so on. I know for a fact that firefox is the issue, because if i open the exact same sites using google chrome for instance then everything works as it should. So why has firefox becoming so usless when it comes to displaying websites. I still want to use firefox as i do prefer it above all others, but this is getting ridiculous now and i am about to ditch it for good.

attached are two screen shots of the same website. Opened with google chrome and firefox. The chrome image shows the prices and clickable links to the files, where as the firefox image shows these links missing.

Ama-screenshot ananyekiwe

All Replies (9)

more options

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}

more options

FredMcD said

Make sure you are not blocking content. Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}

O.K So i have restared in safe mode and the problem seems to disappear (at least for this website), although links are slow to work. So does this mean there is an add-on or something that is stopping this from working? I thought it may have been the ad-blocker pluggin i had installed before posting this question, so i disabled it for that site, and then even uninstalled it altogether, but the problem remained.

more options

FredMcD said

One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}

With reference to your tracking protection suggestion. I did look at the info pages about this. I then went back to view the site in normal mode (not in safe mode), and there does not appear to be anything being blocked by the tracking protection. No shield appears in the address bar.

more options

Can you provide a link the problem site so others can see if they get the same problem when going there?

more options

WestEnd said

Can you provide a link the problem site so others can see if they get the same problem when going there?

it is a membership based site, so you would need a members password to log in. However i asked other members to check for me and they do not have the same issue. But like i said, it cant be the website that is the issue. Also this has happened before with other websites (cant remember what sites these are of the top of my head)

more options

TKTrooper said

O.K So i have restared in safe mode and the problem seems to disappear (at least for this website), although links are slow to work. So does this mean there is an add-on or something that is stopping this from working? I thought it may have been the ad-blocker pluggin i had installed before posting this question, so i disabled it for that site, and then even uninstalled it altogether, but the problem remained.

How about Greasemonkey -- are any user scripts possibly modifying the site -- or other extensions?

Do you have a userContent.css customization file? Firefox doesn't come with one, so it's something you would have had to set up.

more options

jscher2000 said

How about Greasemonkey -- are any user scripts possibly modifying the site -- or other extensions? Do you have a userContent.css customization file? Firefox doesn't come with one, so it's something you would have had to set up.

I have removed greasemonkey all together along with the google translate addon and nothing has changed. But it might be worth noting that i never had these problem until a couple of months ago at most. So things were fine with addons installed.

As for the "userContent.css customization file", i have no clue as to what that means sorry. Im not the most tech savvy when it comes to computers as you can probably tell already.

Its basically like firefox just decided to not load websites properly no more. I have not made any changes (at least to my knowledge).

more options

What about turning off : AdBlocker Ultimate while on the site ?

more options

One other thing Safe Mode changes is that it disabled Firefox from using hardware acceleration for graphics. To turn that off in regular mode, check the steps in this article: Firefox's performance settings. I don't know whether that could be a factor here.