Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Cannot play two Twitch streams simultaneously with dual monitors?

  • 9 uphendule
  • 1 inale nkinga
  • 896 views
  • Igcine ukuphendulwa ngu Truttle

more options

When I attempt to load two Twitch streams in two different tabs, one in each monitor, only the currently "focused" tab will buffer and stream video. The other will have a perpetual "loading circle" as if it is trying to buffer.

Occasionally the suspended stream will SEEM to resume, and attempt to "catch up" by rapidly skipping any missed frames (usually minutes of content skipped over).

If I "click into" the problem tab and bring it into focus, it will immediately play the stream as normal, while the one that WAS playing properly will quickly begin to encounter the same issue.

If one tab is loaded, but not visible, then the audio from it will play without a problem while the other, fully visible tab will play both audio and video as normal.

This issue has only occurred during the past week. It does not occur while watching simultaneous YouTube videos (making me think it is specific to Twitch) and it does not occur when using Google Chrome (making me think it is specific to Firefox).

Isisombululo esikhethiwe

Try to set this pref to 1 on the about:config page.

  • network.http.throttle.version = 1

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

(thanks to philipp)

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 2

All Replies (9)

more options

Sounds like your hardware limits....Are you using GPU or onboard video? Also I think your pushing the hardware limits so the bandwidth must finish in one before the other starts.

more options

I am using my GPU, an NVIDIA GTX 970. It has never had problems playing many streams at source quality at the same time before this week. Also, the same problem does not occur with Chrome.

more options

Please : Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

more options

Restarting in Safe Mode seemed to alleviate the issue somewhat but also caused the browser to run extremely slowly.

Since Safe Mode seemed to help, I proceeded to follow troubleshooting steps: disabling all add-ons then resetting; switching to the Default theme and resetting, disabling hardware acceleration and resetting; and then even doing all three of those at once and resetting. The problem persisted in all those instances, which seems puzzling. Is there something else that Safe Mode disables or alters that would account for the difference?

more options

When in Safe Mode :

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected
more options

Searching for "javascript.options.*jit" in about:config, and disabling all four settings that came up, seems to have removed the original issue.

Unfortunately, this has resulted in a lot more slowness when using Twitch, and even though the out-of-focus tab will not experience perpetual "buffering" as before, any given stream I pull up is much more likely to hang and buffer for a couple seconds at a time at random, and have much more trouble "keeping up."

The slowness does not seem to occur on other sites, but then neither did the original issue. At this point it seems to be something specific to a relatively narrow set of circumstances: two monitors, each with a Firefox tab, each of those tabs attempting to display a Twitch stream.

more options

Ya Hardware Acceleration makes a difference also for your Video Card.

Most of the issues I understand is actually Twitch itself not playing nice by updating along with Firefox.

Hanging here as others know more than I. Now that have narrowed somethings down.

more options

Isisombululo Esikhethiwe

Try to set this pref to 1 on the about:config page.

  • network.http.throttle.version = 1

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

(thanks to philipp)

more options

That seems to have had more luck. It has only been a few minutes, so I can't say for 100% certain but I think this has corrected the issue.