Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox Sync Spins continuously and I have to force quit

  • 29 uphendule
  • 1 inale nkinga
  • Igcine ukuphendulwa ngu cor-el

more options

macos sierra 10.12.6 firefox 61.0 (probem has been ongoing for about 1.5 months though) about 3000 bookmarks

Almost every session, I come to do some task with bookmarks, usually just move a bookmark, and I find the bookmark won't move, I can't make any edits to Library e.g.: I can't save any open tabs as bookmarks

I found after investiagion that firefox has got stuck syncing. so: if I look at my sync wheel, its blue and will never stop spinning. If I close my browser, the firefox process doesn't quit and will hang indefinitely until Force Quit. When I restart, firefox has lost all browsing history and bookmarks changes i performed in the last session. Bear in mind here that, because I couldn't make any changes in Library and to get to the state where I can again means force quitting, that this means as soon as the problem hits, i've lost a way to retrieve any open tabs - they all have to be torn down and be lost! So its a serious problem. Its happening several times a day.

It isn't happening every time firefox sync though - firefox can sync without getting stuck, it seems to happen WHEN i'm doing work with bookmarks (not necessarily in Library, can be though the dropdowns)

I've been looking at but the guy there had more than 10 times the number of boomarks i do, and all in one folder. I do not have many bookmarks all in one folder, so I cannot use the fix there to help me

I've already tried exporting and then importing my bookmarks. I've tried deactiviating all my plugins. I've also totally refreshed my profile. Since refreshing my profile has recreated everything including my places.sql, I'm not sure what else locally I can do to troubleshoot?

All Replies (20)

more options

Do you have any Sync error-logs?

Type about:sync-log in the URL bar and hit Enter.

If so, you can open an error log in Firefox. highlight the contents, and then copy the entire contents of the error log text.

Then paste that log here:

Make sure you select a month at the bottom where it asks "How long should your post be retained?" before using Send. And after you use "Send" copy the resultant URL for your "Paste" and post that URL in this forum thread, so that we can view your error log. This forum software mangles the formatting of those logs and Sync error logs typically max out what this forum software is set up to handle.

more options

Yes I have a large number of sync-error-logs, however the timestamps of the logs don't seem to match up with the problems I have, for instance I already have had this problem once this morning, yet the latest line in the latest timestamp in that location is yesterday morning. I can't be certain I had this problem at that time yesterday morning, but these three entries are the last 3 of 8 recorded yesterday when the logs end

more options

The next sync-error log to be generated starts at timestamp 12:27:02 today, so about 4 hours after my last incident - here it is:

so I suppose when I do get this problem, generation of sync-error logs are also suspended along with Library events? I can still navigate websites without issue, however, when the sync hangs.

more options

I googled the error most often reported in those sync logs:

Exception calling anonymous function: LockException: Could not acquire lock. Label: "service.js: sync"

which led me to which led me to i've installed the about:sync plugin mentioned there, and I note services.sync.engine.bookmarks.buffer is disabled in my config, so i'm going to try enabling it and see what difference it makes. I'm quoting these urls here also because my sync has just crashed again and i don't want to lose the pages!

Okulungisiwe ngu tonywoode

more options

You can try to disconnect Sync temporarily when you want to make changes to the bookmarks if you have that many bookmarks that Firefox gets stuck trying to upload all changes you make immediately to the Sync server. If you disconnect then you can first make all changes and then connect Sync to upload changes to the server.

more options

from reading the first link i linked to above, Id presumed my number of bookmarks wasn't the problem (about:sync actually says theres almost exactly 6000), because the guy there had over 30,000 and he was advised to fix his problem by splitting up into folders each not having more than 3,000 boomarks. I have tens of folders for my 6,000 bookmarks.

Have I presumed wrong? Is simply my number of bookmarks the problem? any ideas what a safe number might be? Your workaround is perhaps easiest achieved by clicking my name in the burger menu, unticking bookmarks, making changes to bookmarks, and then ticking it again?

more options

It might have to do with any customization you made to tags which are now getting removed by Firefox for some strange reason as part of the update. During this conversation above you never mention Syncing to another device.

If this is not the case then ignore below : Firefox Sync as a back up service. This is not what Sync is designed to do. The Firefox Sync service takes a copy of the data you wish to include and transfers it to a second device (typically a mobile device such as a tablet or a telephone) running a copy of Firefox. The storage in between all attached devices is both temporary and fragile and is not stable enough to be (and is not designed as) a reliable backup service. Please have a read of these articles. As well Sync is not designed to do away with traditional backing up.

If you have a copy of your data on a mobile version of Firefox, please follow these instructions to connect it to Firefox Sync to copy your data.

more options

I don't think that the number of bookmarks that is the problem, but the problem is that Sync tries to upload changes you make to the Sync server too easily and that takes more time then is available and the result is pending operations that can't be completed.

more options

@Pkshadow - I don't really use tags, perhaps 50 of my bookmarks are simply tagged 'video', that's all. Yes I am syncing between 6 devices: 2 phones, 2 windows machines, and a linux box. My use of sync is indeed to keep these devices in sync. I haven't experienced these sync issues on any other device, and I do manage my bookmarks from the windows machines also, perhaps not as regularly as the macos machine, but without issue.

@cor-el - thanks, are you saying that if I only had 100 bookmarks, but I made a large number of quick changes to them, I would experience the same issue? Is it likely I could solve my issue rather than work around it by reducing my number of bookmarks?

Would a simpler way to achieve your workaround be to turn my wireless card off, and only turn it on when i've made my changes? Or would that likely still send the same number of individual edits and make it even more likely to cause the hang?

Okulungisiwe ngu tonywoode

more options

HI, have contacted a Supervisor, stay tuned.

more options

the about:sync plugin and `services.sync.engine.bookmarks.buffer` set to enabled seemed to work around my issue for a little while, instead of losing all of my history and bookmarks that were cached since the last save whenever the issue hit me, i instead got a sync-failiure popup, which was much more managable. But now for some reason the original behaviour has reappeared (i think perhaps i've been permanantly connected to fast internet for a number of days, perhaps having intermittent/slow connection for periods every day hid the issue). It doesn't seem to simply occur conncurrently as I add bookmarks per-se, i never can tell when it might happen (so the workaround to disconnect when i make bookmark changes isn't viable)

As a start, I'd like to know whether the number of my bookmarks is the issue, or if its something else. I'd also severely benefit from other ideas for valid workarounds while we investigate.

I keep all my bookmarks in the bookmarks toolbar and have it displayed as a toolbar. I also did some config originally when i setup firefox years ago that makes a folder in my boomarks toolbar called`UNSORTED` and `Other bookmarks` refer to the same collection.

Okulungisiwe ngu tonywoode

more options

or could the size of my history be the issue? I have pages since may 2014, would deleting my history help?

more options

You can check the number of history visits and bookmarks via the about:support page.

  • "Verify Integrity" on the "Help -> Troubleshooting Information" page

I do see some lines mentioning Offline. Sync.SyncScheduler DEBUG Network link status changed to "changed". Offline?: false Sync.SyncScheduler DEBUG Network link status changed to "up". Offline?: false Sync.SyncScheduler DEBUG Network link looks up. Syncing.

more options

The integity check always passes for me. Below is the latest output. Is this significant perhaps? "History can store a maximum of 140077 unique pages ...Table moz_historyvisits has 291659 records"

> Task: checkIntegrity + The database is sane > Task: invalidateCaches + The caches have been invalidated > Task: checkCoherence + The database is coherent > Task: expire + Database cleaned up > Task: vacuum + Initial database size is 71680KiB + The database has been vacuumed + Final database size is 66560KiB > Task: stats + Places.sqlite size is 66560KiB + Favicons.sqlite size is 36928KiB + pragma_user_version is 47 + pragma_page_size is 32768 + pragma_cache_size is -2048 + pragma_journal_mode is wal + pragma_synchronous is 1 + History can store a maximum of 140077 unique pages + Table moz_places has 133124 records + Table moz_historyvisits has 291659 records + Table moz_inputhistory has 278 records + Table moz_hosts has 10914 records + Table moz_bookmarks has 6511 records + Table moz_keywords has 0 records + Table sqlite_sequence has 1 records + Table moz_anno_attributes has 7 records + Table moz_annos has 391 records + Table moz_items_annos has 4 records + Table sqlite_stat1 has 19 records + Table moz_bookmarks_deleted has 0 records + Table moz_meta has 4 records + Index sqlite_autoindex_moz_inputhistory_1 + Index sqlite_autoindex_moz_hosts_1 + Index sqlite_autoindex_moz_keywords_1 + Index sqlite_autoindex_moz_anno_attributes_1 + Index sqlite_autoindex_moz_bookmarks_deleted_1 + Index moz_places_hostindex + Index moz_places_visitcount + Index moz_places_frecencyindex + Index moz_places_lastvisitdateindex + Index moz_historyvisits_placedateindex + Index moz_historyvisits_fromindex + Index moz_historyvisits_dateindex + Index moz_bookmarks_itemindex + Index moz_bookmarks_parentindex + Index moz_bookmarks_itemlastmodifiedindex + Index moz_places_url_hashindex + Index moz_places_guid_uniqueindex + Index moz_bookmarks_guid_uniqueindex + Index moz_annos_placeattributeindex + Index moz_items_annos_itemattributeindex + Index moz_keywords_placepostdata_uniqueindex + Index moz_bookmarks_dateaddedindex > Task: _refreshUI

Okulungisiwe ngu tonywoode

more options

I tried deleting 1.5 years worth of history. It seemed to speed up firefox a little (deleting a month's history at a time (my only real option) went from giving me 7/8 javascript blocking warning dialogs at the beginning months, to only 1/2 warnings at the end), but hasn't fixed the sync issue. There were a couple of history items that wouldn't delete, I 'ignored' them instead.

cor-el: I think the offline errors are incidental, since my issues are repeatable during prolonged periods of stable connection

Weeks ago, I already tried exporting my bookmarks, deleting them all and then re-importing. That did nothing but lose me all of my notes and tags i'd collected under my bookmarks.

I've already tried refreshing firefox and recreating my profile from sync, i assume that a complete uninstall/reinistall would be the same as doing this process plus receiving at least one firefox version upgrade, so I suppose i've effectively done that already. I've already tried running without extensions and it doesn't affect the issue.

I was happy for a while with the behaviour under the new sync engine, where instead of instantly losing all my history/bookmarks since last open, I instead got multiple sync error dialogs, but the old behaviour has now returned, for no apparent reason (ie: I still have the new sync engine option enabled - so perhaps a new firefox version altered the behaviour?)

Okulungisiwe ngu tonywoode

more options

Hi tony, Sorry for the delay in response. I have asked for help from the Firefox Sync team and would like to invite you to create a new bug for further investigation. This may require a different account login at

However I can provide the component and the information that is needed to further investigate the logs that have been requested

  1. Are there any other devices connected to the account when this happens? (we are looking for the about:config pref with `.buffer` pref flipped between devices)
  2. Are there any errors you can see (a zip file of all their error logs, which they can get from about:sync, )

Please create a account and use this link to create a request.

The other option if you don't want to create a bug, though it is helpful to help track the requests we get - is to upload the zip file to with a password, and PMing the password to myself and I can forward it on to the engineer :D

more options

Hi tonywoode, have you fixed your issue as you have not responded to guigs

more options

Thanks for this. I was trying to recreate the error before posting my sync logs. But haven't been able: A new version of FF was installed the day after I deleted those 1.5 years of history, and since then, the sync error popup has reappeared! Just once, but with new text. The new FF version coincided with me returning from holiday also: So the only thing i've done since is save individual bookmarks to my unsorted folder. I've had two small free periods to try and recreate the bug by doing other things, but didn't manage to in the time I had. It also coincided with me turning sync-logging from debug (i had switched it from 'actively looking' for a few days to asses what difference it made) to 'just poking around' (to see if the logging itself was making the problem worse). Somewhere in those things, behaviour seems to have changed, to what extent i'm not sure yet.

I've opened the bug from the link above ( ), I've PM-ed my sync logs as they are (so the 9th and before should show the issue at its worst)

Okulungisiwe ngu tonywoode

more options


Can you please verify the devices that you have connected to the sync account when the error occurred?

Please also check the about:config field from my previous post :) Thank you, looking forward to your reply.

more options

> Are there any other devices connected to the account when this happens?

Whenever this happens it will generally always be when one iphone and one android phone are also on and set to sync

> (we are looking for the about:config pref with `.buffer` pref flipped between devices)

sorry I'm failing to parse what you're saying. Do you want to know the current state of all about:config settings on my macos machine ,that include '.buffer' in their key? None of those keys seem to relate to the number of devices, but they are:

devtools.performance.profiler.buffer-size;10000000 layers.bufferrotation.enabled;true network.buffer.cache.count;24 network.buffer.cache.size;32768 services.sync.engine.bookmarks.buffer;true

it sounds like you actually want to know something else though?

  1. 1
  2. 2