Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Wrong user specified in path for profile

  • 31 uphendule
  • 1 inale nkinga
  • 148 views
  • Igcine ukuphendulwa ngu pedsto

more options

W10 When I start TB, screen is for new user. I am not and I found the correct profile in AppData. Entered Help-TS and discovered that wrong user is specified for location of profile. How do I change? Any idea how it got changed?

All Replies (20)

more options
more options

Thanks for the reference. I would disagree with some of the contents. If I double click on prefs.js I get a script error, Line 1, character 1. If I try to open same with Notepad only part of the profile appears. I had to use Word Perfect to see the whole file, which incidentally looks normal. I seem to have a User problem. There are two users in this account. I think I am in User1 but when I start TB and close changes are being made to appdata in User2. The troubleshooting help shows the profile in User1. I'm really confused. It appears that TB is always looking to User2 when it starts. Can you assist?

more options

Do you mean each user has their own 'User Account' which you logon to when computer boots up?? This would be the standard security method practised when there is more than one user on a computer.

Do you mean both users use the same 'User Account', but each person has a different 'Profile name', so both 'profile names' are in the same 'User Account' ? If this latter is the case, then it sounds like the 'Profile Manager' is always opening on the last used profile and is not asking what to open when program is started.

Assuming you have a shortcut icon on your desktop: You need is to alter the 'Target' information in the shortcut icon.

  • Right click on shortcut icon on desktop and select 'Properties'.
  • Select the 'Shortcut' tab

'Target' :

  • click in the 'Target' text box and use the right arrow ket to move all the way to the far right where it ends with ...\thunderbird.exe".
  • Position cursor after the ", then add a space followed by a capital P.

See image below.

  • click on 'Apply' and 'Ok'

When you use that icon it will open up the 'Profile Manager' window.

  • select the profile which is yours.
  • uncheck the checkbox 'Use the selected profile without asking at startup'
  • click on 'Start Thunderbird'

In the future this window should open so both users can choose their own 'profile name' and then Thunderbird will start using that selected profile.

more options

Thanks, I believe you meant to say (dash) P, not just P to review: in my User folder I have three users besides Default and Public. After applying the -P it took six or seven tries before the profile manager appeared (really strange) When it did open only one profile was listed: default. Looking at the three users I see only one has a "default" profile. This is not what I want. The other two users profiles are named default user and restoration profile. The latter is the one I am after. Going to trouble shooting, about:profile shows the root and local directory corresponding to user 2. I can't figure out how to change the root and local directory. Can you head me in the right direction?

more options

re : I believe you meant to say (dash) P, not just P You are correct.

Post image showing contents of the 'Profiles' folder....

  • C:\Users\<Windows user name>\AppData\Roaming\Thunderbird\Profiles folder.

In this location:

  • C:\Users\<Windows user name>\AppData\Roaming\Thunderbird folder.
  • You will see a file called 'profiles.ini'.
  • Open the 'profiles.ini' file using eg: Notepad and post an image of the contents.
more options

Per your request

more options

I don't much like the spaces in some of your pathnames. Note that the native folder and file names put in place by Thunderbird are constructed without spaces, generally using hyphens instead.

Try adjusting your folder names, (and of course the corresponding contents of profiles.ini) so as not to use spaces. I use underscores in mine, like_this.

The profiles.ini file may (or may not) parse your pathnames correctly, but when passed to your command processor, these really need to be encapsulated within quotation marks, "like this" to ensure the spaces are recognized as part of the file or folder name. Again, this encapsulation may actually be done for you, but I'd want to avoid any doubt by removing the spaces altogether.

Okulungisiwe ngu Zenos

more options

interesting observation however I had nothing to do with how those path names were generated; profile manager accepts the extension with the spaces. Your comment should be addressed to Mozilla/TB. The basic problem still remains: The wrong user is called up when starting FF or TB.

more options

You put the spaces in. You can take them out.

There are other places in Thunderbird where improper file names are accepted but cause problems. If you were to create a subfolder in an account named "finance/savings", Thunderbird would accept this without comment, but your filesystem would parse it as a folder named finance with a subfolder named savings.

Is really quite demotivating to make suggestions and have them turned down without any attempt to try them out. Over and out.

more options

Actually I had tried the underline in the profiles entries and it made no difference. What you say is true when you include a slash in an entry; however, in my case it is not relevant. My problem is up stream.

more options

Whilst I can see the obvious lines you have entered as text to explain which is which, the rest of the 'profiles.ini' files does not conform to expected layout.

There are two instances of [General] StartWithLastProfile where one uses a value of '0' and the other uses '1'

I would expect only one instance at the top, so it would seem the Profile Manager is only using the second instance to show available profiles to choose. In which case there is only one, the Default User. I would expect only the 'Default User' to be visible via Profile Manager. This I believe is the case. I'm suprised the 'profile.ini' files looks the way it does. Are you sure no one has edited that file before?

  • Exit Thunderbird.
  • Access the 'Thunderbird' folder to see 'profiles.ini' file.
  • Make a backup copy of the 'profiles.ini' file and put on desktop for temporary safe keeping. Just in case :)
  • In Thunderbird folder, Open the 'profiles.ini' file using Notepad.
  • Please carefully edit the 'profiles.ini' file so it contains only the information as written between the two lines below and looks exactly like the image below.
  • Then save the 'profiles.ini' file.
  • Then start Thunderbird.

[General] StartWithLastProfile=0

[Profile0] Name=Default User IsRelative=1 Path=Profiles/4ebtre70.Default User Default=1

[Profile1] Name=restoration profile IsRelative=1 Path=Profiles/1ypt9j39.restoration profile


General info on the 'profiles.ini' file:

more options

Thanks. noted, however, you have made two profiles into one and I don't care about profiles right now. My problem is upstream when selecting FF or TB the OS is selecting a User whose profile is not what I want. I desire another User and the matching profile and I can't figure out how to change the OS default.

more options

re : , you have made two profiles into one

No. There are two distinct and separate profiles.

When you boot up computer, I am presuming you do not conform to basic security standards, in other words both of you use the same computer User Account or have never set up any computer User Accounts.

When you start Thunderbird it will launch and both of you have your own profile which you should be able to select by using the 'Profile Manager'.

I have instructed you in how that should be set up.

Have you followed the instruction or and tested it or not?

more options

re :My problem is upstream when selecting FF or TB the OS is selecting a User whose profile is not what I want.

I've already explained why and I'm not going to repeat myself.

Can you confirm: Do You have your own computer 'User Account' which only you logon using your chosen password in order to see your User Account desktop.

You did not post image showing contents of the Roaming\Thunderbird\Profiles folder - please do this.

more options

"re : , you have made two profiles into one

No. There are two distinct and separate profiles." I apologize, I meant to say you put two profile in the same .ini. There are two .ini's with one profile each.

I am the sole user of the computer and have a 'User Account'. The Users folder contains five "users": Default, Corbian, PDRoof, Peter and Public

I posted the requested ....\Profiles folder on 7/3 @8:30 and it shows up in this thread.

more options

re :I posted the requested ....\Profiles folder on 7/3 @8:30 and it shows up in this thread.

I can only see one image posted and it is the text file you created which showed an amalgamated bunch of information gleaned from several files. Initially, I though it was one 'profiles.ini' file which was badly formed perhaps even previously manually edited. Then later edited by yourself explaining which part was not working.

In future, it would be helpful if you posted images of specific files showing actual contents of that file and not edited and stating the location of that file if it is in a completely different User Account or storage location.

re :The Users folder contains five "users": Default, Corbian, PDRoof, Peter and Public

The Default and Public ones are auto created. 'Corbian', 'PDRoof' and 'Peter' would be 'User Accounts' created manually.

You say ' I am the sole user of the computer and have a 'User Account'. '

When computer boots up, The first screen you see would be small icons of those User Accounts - Corbian, PDRoof and Peter. Did you create the additional user accounts or perhaps they were created by previous users of that computer ?

Do you see those three User Account icons; Corbian, PDRoof and Peter Or do you see only the one 'Peter' ?

Q: Do you logon using User Account 'Peter' ? Assuming the answer is 'yes', but please tell us if anything is different as this in important. This would show the desktop for user 'Peter' and should offer you the 'Thunderbird' short cut icon.

First we need to know what is actually stored in the 'Peter' User Account Appdata folder. Please post an image showing the contents of this specific location: Post image showing contents of the 'Profiles' folder....

  • C:\Users\Peter\AppData\Roaming\Thunderbird\Profiles folder.

Post an image showing the contents of this specific location:

  • C:\Users\Peter\AppData\Roaming\Thunderbird\ 'profiles.ini' folder.
more options

Good morning. I have never edited any of the profile files. They are just as generated by the programs. No one else has used my computer.

Up to today I have considered my MS User Account to be pedsto@compuserve.com. When I booted this morning the normal pedsto@compuserve.com was changed to "Peter Stogis". Also present on the opening screen were three small icons: "Peter Stogis", "Corbian" and "Peter-Local". (Corbian is a back up program I used some time ago and have no idea how it became a user account) There is no PDRoof in sight although I think I had generated a local account with that name some time ago. HOWEVER, even though I logged on as Peter Stogis, profile manager tells me that when I open FF or TB the path will be "Users/PDRoof.........

As an aside when I go to settings-account manager I see "Peter Stogis" and a sub title "pedsto@compuserve.com", "Administrator" so the pedsto is still around.

Confusing? I'm baffled. I'm tempted to delete the Users Corbian and PDRoof and see what happens.

more options

three small icons: "Peter Stogis", "Corbian" and "Peter-Local".

Thunderbird has all the correct info relating to User 'Peter'. But I'm wondering whether you are really logging on as 'Peter'.

"Peter Stogis" seems to be 'PDRoof'

Please logon using 'Peter-Local' and report back on results when you then try Thunderbird. If this fails - report back on what acount is opened.

Then check to see if User 'Peter' really is enabled and visible in the initial logon screen, so you can logon to the real 'Peter'.

more options

You are exactly correct. At Peter -local the default user is Peter. Peter Stogis of course defaults to user PDRoof and that is the situation I am trying to change. I want the MS User account to default to user Peter.

User Peter is not a visible option in the initial logon because it is not a User Account.

more options

re :User Peter is not a visible option in the initial logon because it is not a User Account.

It is listed in the 'Users' folder as an account and it has all the 'Appdata' etc folders, so it must have been created as a User Account. 'Peter - Local' now seems to point to that set of folders.

It's that use of the word 'Local' which sounds like you've linked Windows 10 Account with Microsoft Account (MSA) as you say ' MS User Account' and this has left you with a local account aka 'Peter' which was visually renamed by Windows OS to 'Peter-Local' so you can tell the difference - it is not part of MSA - it is local on your computer, but it is in fact the User Account 'Peter'.

Apparently when you signed up to use the MSA, there would have been an option to link up a local account and it would seem you linked up the PDRoof User Account.

At the end of day, there is nothing wrong with Thunderbird and you now know how to access everything - currently via logon using the 'Peter -Local' which is 'Peter'. This is the account you were using all along.

Discussing MSA accounts is beyond this Forum and off topic, but perhaps you can find a means of either removing the MSA and go back to normal local computer use or try removing and recreating the MSA account again and this time carefully check to see which local User account you are linking in.

Perhaps there is a means of leaving the MSA as it is, but choosing a different User Account to link up.

Hope I've helped to resolve how to see all your emails via 'Peter -Local' and also offered info on why you see PDRoof - it is the currently selected linked User Account to MSA account. This should help to point you in the right direction.

  1. 1
  2. 2