X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox insists on running in German - How can I fix this?

Kuphostiwe

So, I downloaded the English Firefox version, installed it on my System (win7), which has the standard language English (and German as a secondary) and Firefox insists on giving me the interface in German?? Why? I tried the about:config tips I read somewhere here, but I guess they were out of date since there was zero effect (I created intl.locale.requested and general.useragent.locale as string-variables and set them to en-UK) so, can someone please tell me the current, correct name of the variable to use, or whatever is currently the go-to solution? One of the articles claimed when no value is set Firefox uses the system language as default, but that is obviously not working.. I am currently in Germany, but seriously, that is no excuse since the browser should really not care about where I currently am when I install it??

So, I downloaded the English Firefox version, installed it on my System (win7), which has the standard language English (and German as a secondary) and Firefox insists on giving me the interface in German?? Why? I tried the about:config tips I read somewhere here, but I guess they were out of date since there was zero effect (I created intl.locale.requested and general.useragent.locale as string-variables and set them to en-UK) so, can someone please tell me the current, correct name of the variable to use, or whatever is currently the go-to solution? One of the articles claimed when no value is set Firefox uses the system language as default, but that is obviously not working.. I am currently in Germany, but seriously, that is no excuse since the browser should really not care about where I currently am when I install it??

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0

Eminye Imininingwane

philipp
  • Top 25 Contributor
  • Moderator
5292 izisombululo 23384 izimpendulo
Kuphostiwe

hi, you can pick the language version you want to download firefox in at https://www.mozilla.org/firefox/all/ - just install it on top of your german installation - all other settings like bookmarks, passwords, addons etc will be kept.

hi, you can pick the language version you want to download firefox in at https://www.mozilla.org/firefox/all/ - just install it on top of your german installation - all other settings like bookmarks, passwords, addons etc will be kept.

Umnikazi wombuzo

Hey, thank you for the quick reply. I just downloaded the new English (brit) version, installed it over the old one - to exactly no change. The Firefox interface remains German =(

Hey, thank you for the quick reply. I just downloaded the new English (brit) version, installed it over the old one - to exactly no change. The Firefox interface remains German =(
philipp
  • Top 25 Contributor
  • Moderator
5292 izisombululo 23384 izimpendulo
Kuphostiwe

is firefox showing up twice now as installed application in the system's control panel?

is firefox showing up twice now as installed application in the system's control panel?

Umnikazi wombuzo

nope, only one firefox..

nope, only one firefox..
philipp
  • Top 25 Contributor
  • Moderator
5292 izisombululo 23384 izimpendulo
Kuphostiwe

ok, so just to be sure: with the firefox interface you're referring to the strings within the menu/options etc & not the web content (since sites like google might serve you a particular language version according to their own logic).

could you go to the firefox menu ≡ > help ? > troubleshooting information, copy the contents of that page and paste them into a site like https://pastebin.mozilla.org/ and link that here in a reply on the forum? this might give us a clue what is going wrong...

ok, so just to be sure: with the firefox interface you're referring to the strings within the menu/options etc & not the web content (since sites like google might serve you a particular language version according to their own logic). could you go to the firefox ''menu ≡ > help ? > troubleshooting information'', copy the contents of that page and paste them into a site like https://pastebin.mozilla.org/ and link that here in a reply on the forum? this might give us a clue what is going wrong...

Umnikazi wombuzo

I will, but in a fairly weird turn of events the problem already solved itself. Mind you, I rebooted after I installed yesterday, to be sure, and after the reboot then AND after the shutdown over night, when I started my PC this morning it was still in German (yes, the interface, not the website contents).. and then I shut down the PC again and when I started it up this evening it was in English?! I don´t get it, but I am happy, let me tell you! I´d love to hear the possible reasons, if anyone has a theory, but as is I am happy it´s working as intended now =) https://pastebin.mozilla.org/9088510

I will, but in a fairly weird turn of events the problem already solved itself. Mind you, I rebooted after I installed yesterday, to be sure, and after the reboot then AND after the shutdown over night, when I started my PC this morning it was still in German (yes, the interface, not the website contents).. and then I shut down the PC again and when I started it up this evening it was in English?! I don´t get it, but I am happy, let me tell you! I´d love to hear the possible reasons, if anyone has a theory, but as is I am happy it´s working as intended now =) https://pastebin.mozilla.org/9088510
cor-el
  • Top 10 Contributor
  • Moderator
17425 izisombululo 157456 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Note that the language code needs to be en-GB and not en-UK.

Note that the language code needs to be en-GB and not en-UK.

Umnikazi wombuzo

OK, thanks for the info! Is general.useragent.locale the right variable then? or is there another one I need to fix with en-GB?

OK, thanks for the info! Is general.useragent.locale the right variable then? or is there another one I need to fix with en-GB?
cor-el
  • Top 10 Contributor
  • Moderator
17425 izisombululo 157456 izimpendulo
Kuphostiwe

Impendulo Ewusizo

The general.useragent.locale pref is no longer used and has been replaced by intl.locale.requested.

See:

See also the "Internationalization & Localization" section on the about:suport page (Help -> Troubleshooting Information).

The general.useragent.locale pref is no longer used and has been replaced by intl.locale.requested. See: *https://support.mozilla.org/en-US/kb/use-firefox-interface-other-languages-language-pack See also the "Internationalization & Localization" section on the about:suport page (Help -> Troubleshooting Information).