Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Will one finger touch scrolling be a feature in a future update of firefox for linux?

  • 9 uphendule
  • 1 inale nkinga
  • 5142 views
  • Igcine ukuphendulwa ngu spacemanultra

more options

I just installed mint 18.3 and I'm still pretty green. I know there's a solution but I can't understand it.

_______________________ Enable touchscreen gestures

Make sure dom.w3c_touch_events.enabled is either set to 1 (enabled) or 2 (default, auto-detect).

Add MOZ_USE_XINPUT2 DEFAULT=1 to /etc/security/pam_env.conf and then logout or reboot your system for the changes to take effect.


_______________________

I'd like to know what this means (sorry for being dum), otherwise I wouldn't mind waiting if there's plans to add scrolling in future updates.

Isisombululo esikhethiwe

Did you verify that is Firefox installed in this directory?

Firefox is probably installed in "/usr/lib/firefox", so if this is the file to start Firefox then try:

#!/bin/sh

export MOZ_USE_XINPUT2 DEFAULT=1
/usr/bin/firefox
Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (9)

more options

You can use a bash script to start Firefox and add the line to use XINPUT2 to this file.


#!/bin/sh

export MOZ_USE_XINPUT2 DEFAULT=1
cd <path to firefox srcipt>
./firefox
more options

I wish I knew what that meant, haha. Don't worry about helping me, it'd take too long for me to learn.

more options

cor-el said

You can use a bash script to start Firefox and add the line to use XINPUT2 to this file.
#!/bin/sh

export MOZ_USE_XINPUT2 DEFAULT=1
cd <path to firefox srcipt>
./firefox

Sorry to bother you, but I've been trying to do the bash script, this is what I've done, I know it's not correct, but I would appreciate it if you could guide me in the right direction from here.

Okulungisiwe ngu spacemanultra

more options

The code I posted needs to be in a text file (e.g. firefox-touch), so you can open a (plain) text editor and paste these lines in the file. You need to use the chmod command or a file manager (properties) to set the execute (x) flag for the file.

When you start Firefox by using this file then the environment variable will be set.


#!/bin/sh

export MOZ_USE_XINPUT2 DEFAULT=1
cd /usr/bin/firefox
./firefox

Okulungisiwe ngu cor-el

more options

cor-el said

The code I posted needs to be in a text file (e.g. firefox-touch), so you can open a (plain) text editor and paste these lines in the file. You need to use the chmod command or a file manager (properties) to set the execute (x) flag for the file. When you start Firefox by using this file then the environment variable will be set.
#!/bin/sh

export MOZ_USE_XINPUT2 DEFAULT=1
cd /usr/bin/firefox
./firefox

I set it to execute and when I ran it in terminal this is the error that popped up

more options

Isisombululo Esikhethiwe

Did you verify that is Firefox installed in this directory?

Firefox is probably installed in "/usr/lib/firefox", so if this is the file to start Firefox then try:

#!/bin/sh

export MOZ_USE_XINPUT2 DEFAULT=1
/usr/bin/firefox
more options

cor-el said

Did you verify that is Firefox installed in this directory? Firefox is probably installed in "/usr/lib/firefox", so if this is the file to start Firefox then try:
#!/bin/sh

export MOZ_USE_XINPUT2 DEFAULT=1
/usr/bin/firefox

So I did this, and it opened firefox no problem, however, the touchscreen gestures still didn't work. It just behaved normally. __________________

  1. !/bin/sh

export MOZ_USE_XINPUT2 DEFAULT=1

cd /usr/lib/firefox ./firefox __________________

That's what the textfile looks like as of right now

Okulungisiwe ngu spacemanultra

more options

Sorry about the confusion. This line should of course be:

  • export MOZ_USE_XINPUT2=1
more options

cor-el said

Sorry about the confusion. This line should of course be:
  • export MOZ_USE_XINPUT2=1

Awesome! It worked great!