Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

I keep getting this message in my twitter feed "We cannot play the video in this browser. Please try a different web browser."

  • 5 uphendule
  • 3 zinale nkinga
  • 4351 views
  • Igcine ukuphendulwa ngu James

more options

I recently installed Ubuntu 18.04 LTS OS on my computer. it came with firefox installed and ive updated all software and packages. Everything seems to work fine except for this one persistent problem. my twitter feed won't display gif's and videos. I keep getting this message:"We cannot play the video in this browser. Please try a different web browser."

Isisombululo esikhethiwe

The videos may be playing in a HTML5 player.

One type of package Linux users may not install after OS install is FFmpeg which nay vary in package name depending on Linux distro. Firefox has not used Gstreamer for a long time now.

You can test at https://www.youtube.com/html5 where if a couple certain checks are red then you maybe missing the FFmpeg

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (5)

more options

Isisombululo Esikhethiwe

The videos may be playing in a HTML5 player.

One type of package Linux users may not install after OS install is FFmpeg which nay vary in package name depending on Linux distro. Firefox has not used Gstreamer for a long time now.

You can test at https://www.youtube.com/html5 where if a couple certain checks are red then you maybe missing the FFmpeg

more options

Hi, I'm using ubuntu 18.04.1 and I have the same problem. I wen to https://www.youtube.com/html5 and found H.264 and MSE & H.264 both with red marks. I tried with 'sudo apt install ffmpeg' but I get the same issue. Any idea how to solve it?

more options

opensas said

Hi, I'm using ubuntu 18.04.1 and I have the same problem. I wen to https://www.youtube.com/html5 and found H.264 and MSE & H.264 both with red marks. I tried with 'sudo apt install ffmpeg' but I get the same issue. Any idea how to solve it?

With the flavors of Ubuntu you may find the FFmpeg in Ubuntu Restricted Extras.

https://help.ubuntu.com/community/RestrictedFormats

Okulungisiwe ngu James

more options

Unfortunately the solution was this:

sudo apt-get install ubuntu-restricted-extras

more options

Which I mentioned in above reply.