Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Twitch/Youtube html5 videos stuttering

  • 15 uphendule
  • 1 inale nkinga
  • 5417 views
  • Igcine ukuphendulwa ngu N3kom4re

more options

Hello I have searched this forum already and the best description for this isssue is

"Since quiet some time(~3/4 Year) videos playback on youtube (and twitch) is choppy/stuttering (it looks like the playbock is not in the right order, if A-B-C-D-E-F-G-... is the right order for the frames it looks like A-D-E-B-F-C-G-H-... and then normal again for few seconds, and then again)." from this case https://support.mozilla.org/en-US/questions/1195382

And the very example is even shown in this video https://vimeo.com/271932549 captured by another user with same issue from https://support.mozilla.org/en-US/questions/1217350#answer-1112431

neither of those were answered anyway. I am bumping this issue as I have the same problem. I already tried to disable all addons, disable webgl, disable or throttle HW acceleration, refresh firefox, even tried to swithc to ESR version but none of these helped. I installed chrome, got the identical/functionally similiar addons and tried to watch youtube/twitch - it was going smooth even after longer period of time. Other players not based on html5 are playing just fine though, it is just that html5 player...and on twitch and yt...

Isisombululo esikhethiwe

So very well

disabled that DXVA thing - that solved problem for the Youtube at elast

Twitch was still bit stuttery, but that was different issue which I solved by getting Twithc 5 addon and now both YT and Twitch are going without problems.

My HW acc is still on, just disabled in about:config media.vmf.dxva.enabled

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (15)

more options

What video formats have warnings when you go to YouTube's HTML5 tester?

more options

All are checked https://i.imgur.com/prQuhvu.png

that is whys I am confused by the performance solely on YouTube and Twitch

more options

Does it only occur on videos playing in 60fps or all videos from these sites?

more options

On the twitch 720p60 (source) and non source it causes stuttering. Tried to switch to regular 720p and so far it SEEMS it causes no problems, the fps are decreased though.

However, that is not the solution for me, sadly. In the older versions of firefox even with those settings, it was going smoothly without any stuttering even at 60fps.

also my monitor can handle 60fps, just additional information if it is relevant.

Also running constantly on the 720p when the internet connection is not stable enough and the 'auto' settings adjusts it just right is no use as well as it would try to keep connect on desired quality.

more options

What does http://www.speedtest.net/ give for your ISP speed?

Okulungisiwe ngu WestEnd

more options

ok, can you give a link to the sites listed that is causing the problem so others can see if they get the same problem.

more options

As I said above, it kind of happens on ALL twitch streams with the 720p60 option (if chose or given auto-change according to connection.) and on ALL youtube videos - if it is not static picture with music of course. Again with the same settings as above or "better"

more options

It happened here for example https://www.youtube.com/watch?v=17UIzNou_8s right at the start...I clicked on pause and start in instant ant it got fixed but it is annoying and it happened few times during the video itself.

for the stream...you can get any stream doing that...doesn't really matter which I link, example https://www.twitch.tv/elajjaz

more options

N3kom4re said

It happened here for example https://www.youtube.com/watch?v=17UIzNou_8s right at the start...I clicked on pause and start in instant ant it got fixed but it is annoying and it happened few times during the video itself.

Tried the link and it loaded just fine and paused and play and paused and play no stuttering or lags. And I can click at different time line and play those starting where I click with no lags/stuttering. So It seems more like a Hardware problem then a internet or Browser problem and possibly you have way to much stuff loaded that is causing the bottleneck.

more options

Well, yes. That might be good...however I like to browse or play something during listening or partially watchin the stream or video. I tried the same "weight test" on both firefox and chrome and chrome never showed the issue like that.

more options

So I did a bit more searching abotu this issue and found https://bugzilla.mozilla.org/show_bug.cgi?id=1122904

Reporter sent also good example of what is happening https://www.youtube.com/watch?v=hKqraFBt0Ww Just set it on 1080p60 and either click on random time or let it go. At least for me, it started stuttering.

read through and then went to about:config and put false value on "media.vmf.dxva.enabled"

I will test it disabled and let know here. However, does disabling that thing influence something badly?

more options

N3kom4re said

So I did a bit more searching abotu this issue and found https://bugzilla.mozilla.org/show_bug.cgi?id=1122904 Reporter sent also good example of what is happening https://www.youtube.com/watch?v=hKqraFBt0Ww Just set it on 1080p60 and either click on random time or let it go. At least for me, it started stuttering. read through and then went to about:config and put false value on "media.vmf.dxva.enabled" I will test it disabled and let know here. However, does disabling that thing influence something badly?

Went the problem links and set at 1080 60fps and no stutter even moved to different time. I left my hardware acc at defualt and using GTX1060 6G. I think it comes down to hardware issues. Also no sounds issues when sliding the video back and fort once it starts.

Okulungisiwe ngu WestEnd

more options

I don't have any audio issues at all, just the video stutter. I have GTX 1060gb as well and my HW acc is on. Not sure what is up though really

So far that dxva somehow works.

any idea what could cause the issue then?

and waht does the dxva change?
more options

Isisombululo Esikhethiwe

So very well

disabled that DXVA thing - that solved problem for the Youtube at elast

Twitch was still bit stuttery, but that was different issue which I solved by getting Twithc 5 addon and now both YT and Twitch are going without problems.

My HW acc is still on, just disabled in about:config media.vmf.dxva.enabled