X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

In the "Date" field, only a time is displayed, but no date?

Kuphostiwe

I am only seeing a time received in the Date field for each email.

How do I configure this column to show the DATE (Month/day/year) an email is received.

Thanks.

I am only seeing a time received in the Date field for each email. How do I configure this column to show the DATE (Month/day/year) an email is received. Thanks.

Isisombululo esikhethiwe

Thanks Matt.

OK, what I decided to try was to click on "Restore Defaults" in the Advanced Date window. All the settings changed (see first screenshot).

Then I restarted my Mac and Thunderbird. Bingo -- dates now appear as they should (see second screenshot). You were correct as to the source of the problem.

Apparently Thunderbird is designed to work only with Apple's DEFAULT Date settings.

Funda le mpendulo ngokuhambisana nalesi sihloko 0
Isicaphuno

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:60.0) Gecko/20100101 Firefox/60.0

Eminye Imininingwane

christ1
  • Top 25 Contributor
2011 izisombululo 14560 izimpendulo

Today's date is not shown. Look at the same message tomorrow, and you'll see the date.

Today's date is not shown. Look at the same message tomorrow, and you'll see the date.
Ingabe lokhu kube usizo kuwena? 0
Isicaphuno

Umnikazi wombuzo

Hello,

Every email I have received over the last month (since I installed Thunderbird) has only shown a time in the Date field -- no dates.

I tried expanding the column width to see if a date would show, as I do in Apple Mail, but no luck.

Any suggestions?

Thanks Rich

Hello, Every email I have received over the last month (since I installed Thunderbird) has only shown a time in the Date field -- no dates. I tried expanding the column width to see if a date would show, as I do in Apple Mail, but no luck. Any suggestions? Thanks Rich

Okulungisiwe ngu Rich

Ingabe lokhu kube usizo kuwena?
Isicaphuno
christ1
  • Top 25 Contributor
2011 izisombululo 14560 izimpendulo
Please post a screenshot. https://support.mozilla.org/kb/how-do-i-create-screenshot-my-problem
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

OK, here is a screen shot of my inbox window. Note the Date field with only times listed, no dates.

These emails are one to ten days old.

Thanks, Rich

OK, here is a screen shot of my inbox window. Note the Date field with only times listed, no dates. These emails are one to ten days old. Thanks, Rich
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Matt
  • Top 10 Contributor
  • Moderator
2895 izisombululo 19562 izimpendulo

it looks to me like there is a corruption in the date information in your emails.

press Ctrl+U. in an email. In the window that opens,

In the gibberish of the header will be a line that looks like this

Date: Mon, 21 May 2018 16:57:00 +0000

What does yours look like.

it looks to me like there is a corruption in the date information in your emails. press Ctrl+U. in an email. In the window that opens, In the gibberish of the header will be a line that looks like this Date: Mon, 21 May 2018 16:57:00 +0000 What does yours look like.
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Hello Matt,

Not sure what you mean about pressing control U "in an email"?

I highlight an email in the listing, press control U, but nothing happens. I'm on a Mac running OS 10.11.6. Thanks.

Hello Matt, Not sure what you mean about pressing control U "in an email"? I highlight an email in the listing, press control U, but nothing happens. I'm on a Mac running OS 10.11.6. Thanks.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Matt
  • Top 10 Contributor
  • Moderator
2895 izisombululo 19562 izimpendulo

open the email to read it. View menu > message source

open the email to read it. View menu > message source
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

OK, thanks Matt. Here is what I see in the top lines:

Return-Path: <richpate@us7.tmd.cloud> Delivered-To: rich@richpate.com Received: from us7.tmd.cloud by us7.tmd.cloud with LMTP id IClKDdSS81pDOCQAw3vygg for <rich@richpate.com>; Thu, 10 May 2018 00:31:16 +0000

How does that look? Rich

OK, thanks Matt. Here is what I see in the top lines: Return-Path: <richpate@us7.tmd.cloud> Delivered-To: rich@richpate.com Received: from us7.tmd.cloud by us7.tmd.cloud with LMTP id IClKDdSS81pDOCQAw3vygg for <rich@richpate.com>; Thu, 10 May 2018 00:31:16 +0000 How does that look? Rich
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Matt,

In case you need to see more lines:

Return-path: <richpate@us7.tmd.cloud> Envelope-to: rich@richpate.com Delivery-date: Thu, 10 May 2018 00:31:16 +0000 Received: from richpate by us7.tmd.cloud with local (Exim 4.89_1) (envelope-from <richpate@us7.tmd.cloud>) id 1fGZUK-009xoY-3l for rich@richpate.com; Thu, 10 May 2018 00:31:16 +0000 To: rich@richpate.com Subject: Rich Pate Photographic Art "Another inquiry" X-PHP-Script: richpate.com/index.php for 73.26.183.49 X-PHP-Filename: /home/richpate/public_html/index.php REMOTE_ADDR: 73.26.183.49 Date: Thu, 10 May 2018 00:31:15 +0000

Rich

Matt, In case you need to see more lines: Return-path: <richpate@us7.tmd.cloud> Envelope-to: rich@richpate.com Delivery-date: Thu, 10 May 2018 00:31:16 +0000 Received: from richpate by us7.tmd.cloud with local (Exim 4.89_1) (envelope-from <richpate@us7.tmd.cloud>) id 1fGZUK-009xoY-3l for rich@richpate.com; Thu, 10 May 2018 00:31:16 +0000 To: rich@richpate.com Subject: Rich Pate Photographic Art "Another inquiry" X-PHP-Script: richpate.com/index.php for 73.26.183.49 X-PHP-Filename: /home/richpate/public_html/index.php REMOTE_ADDR: 73.26.183.49 Date: Thu, 10 May 2018 00:31:15 +0000 Rich
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Matt
  • Top 10 Contributor
  • Moderator
2895 izisombululo 19562 izimpendulo

Well you finally got to Date: which was the only line I was really interested in.

Just out of interest. The very first line looks like this. From - Tue May 22 09:23:06 2018

Can you check it shows the date and time correctly? Next check your operating system is displaying the date and time correctly. As I do not and never have used a mac, this might help if you have difficulty. https://support.apple.com/kb/PH25636?locale=en_US

I would also ask you to restart Thunderbird with add-ons disabled from the help menu and report if it changes the date format that is shown.

Click the widget on the end of the message list menu bar and add received to the columns displayed. Does it also suffer from the same unfortunate date format.

Best to get the simple and common possibilities out of the way first.

Back to you.

Well you finally got to Date: which was the only line I was really interested in. Just out of interest. The very first line looks like this. From - Tue May 22 09:23:06 2018 Can you check it shows the date and time correctly? Next check your operating system is displaying the date and time correctly. As I do not and never have used a mac, this might help if you have difficulty. https://support.apple.com/kb/PH25636?locale=en_US I would also ask you to restart Thunderbird with add-ons disabled from the help menu and report if it changes the date format that is shown. Click the widget on the end of the message list menu bar and add received to the columns displayed. Does it also suffer from the same unfortunate date format. Best to get the simple and common possibilities out of the way first. Back to you.

Okulungisiwe ngu Matt

Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Hello Matt,

Not sure which "first line" you are referring to. The first line in the message source is: Return-Path: <richpate@us7.tmd.cloud <="" p=""></richpate@us7.tmd.cloud>

My OS is displaying date and time correctly.

I restarted Thunderbird in Safe Mode. No change in date column, just times are listed as before with a coma as first character.

The added "Received" column also just shows times, no dates.

Hello Matt, Not sure which "first line" you are referring to. The first line in the message source is: Return-Path: <richpate@us7.tmd.cloud My OS is displaying date and time correctly. I restarted Thunderbird in Safe Mode. No change in date column, just times are listed as before with a coma as first character. The added "Received" column also just shows times, no dates.
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Opps. The first line didn't print properly in the message I just sent you.

Should be: Return-Path: <richpate@us7.tmd.cloud>

Opps. The first line didn't print properly in the message I just sent you. Should be: Return-Path: <richpate@us7.tmd.cloud>
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Onno Ekker 111 izisombululo 415 izimpendulo

Thunderbird has three formats to show the date columns in the tread pane: one for messages today, on for last week and one for older messages. It is controlled by three prefs:

  • mail.ui.display.dateformat.today (default 0)
  • mail.ui.display.dateformat.thisweek (default 2)
  • mail.ui.display.dateformat.default (default 2)

If the prefs aren't set, a default value is used. Possible values are:

  • 0 - None: do not include the date
  • 1 - Long: show the date in the locale long date format
  • 2 - Short: show the date in the locale short date format
  • 3 - Year/month: show the year and month
  • 4 - Weekday: weekday, e.g. Mon, Tue

After changing one of these prefs, you have to restart Thunderbird before it takes effect. You can set the preferences via the menu Tools > Options > Advanced > General > Config Editor…

Since the default for older messages is to use your system locales long date format, it is best to go to your system settings and check the format there. For Windows it is under Control Panel > Region.

Thunderbird has three formats to show the date columns in the tread pane: one for messages today, on for last week and one for older messages. It is controlled by three prefs: * mail.ui.display.dateformat.today (default 0) * mail.ui.display.dateformat.thisweek (default 2) * mail.ui.display.dateformat.default (default 2) If the prefs aren't set, a default value is used. Possible values are: * 0 - None: do not include the date * 1 - Long: show the date in the locale long date format * 2 - Short: show the date in the locale short date format * 3 - Year/month: show the year and month * 4 - Weekday: weekday, e.g. Mon, Tue After changing one of these prefs, you have to restart Thunderbird before it takes effect. You can set the preferences via the menu Tools > Options > Advanced > General > Config Editor… Since the default for older messages is to use your system locales long date format, it is best to go to your system settings and check the format there. For Windows it is under Control Panel > Region.

Okulungisiwe ngu Onno Ekker

Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Thanks Onno.

I use a Mac running OS 10.11.6.

I checked the prefs section (which I found in Preferences > Advanced > General > Config Editor...). I did not find the "mail.ui..." prefs you listed.

I included a screen shot of what I found for the mail.ui... prefs.

Any suggestions?

Rich

Thanks Onno. I use a Mac running OS 10.11.6. I checked the prefs section (which I found in Preferences > Advanced > General > Config Editor...). I did not find the "mail.ui..." prefs you listed. I included a screen shot of what I found for the mail.ui... prefs. Any suggestions? Rich

Okulungisiwe ngu Rich

Ingabe lokhu kube usizo kuwena?
Isicaphuno
Onno Ekker 111 izisombululo 415 izimpendulo

There's one more pref that might make a difference. Check under Tools > Options > Advanced > General > Date and Time Formatting. There you have the choice between Application locale and Regional Settings locale. Try flipping the choice and see if that helps.

There's one more pref that might make a difference. Check under Tools > Options > Advanced > General > Date and Time Formatting. There you have the choice between Application locale and Regional Settings locale. Try flipping the choice and see if that helps.
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Thanks Onno,

I can not find these settings on my Mac version of Thunderbird.

Please see the screen shots of my Tool menu and my Advanced Prefs window below.

Thanks Onno, I can not find these settings on my Mac version of Thunderbird. Please see the screen shots of my Tool menu and my Advanced Prefs window below.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Onno Ekker 111 izisombululo 415 izimpendulo

I'm sorry. That preference is new to version 60, which isn't released yet.

I'm sorry. That preference is new to version 60, which isn't released yet.
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

I checked my version, 52.7.0.

I just updated to version 52.8.0 and restarted. It did not help with my date problem.

Looks like version 60 is a long ways off. Is there any hope for getting a fix before then? Thanks.

Rich

I checked my version, 52.7.0. I just updated to version 52.8.0 and restarted. It did not help with my date problem. Looks like version 60 is a long ways off. Is there any hope for getting a fix before then? Thanks. Rich
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Onno Ekker 111 izisombululo 415 izimpendulo

You can try adding the three preferences mentioned before as integer preference with value 1. This should give you your system's long date format for all dates. It looks like something's wrong with the short date format. You could also check your date settings in your Mac System Preferences as described here: https://www.wikihow.com/Change-the-Date-Format-on-a-Mac

You can try adding the three preferences mentioned before as integer preference with value 1. This should give you your system's long date format for all dates. It looks like something's wrong with the short date format. You could also check your date settings in your Mac System Preferences as described here: https://www.wikihow.com/Change-the-Date-Format-on-a-Mac

Okulungisiwe ngu Onno Ekker

Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Do I just copy and paste these into the preferences listing and change their values to "1"?

    mail.ui.display.dateformat.today (default 0)
   mail.ui.display.dateformat.thisweek (default 2)
   mail.ui.display.dateformat.default (default 2) 

Thanks.

Do I just copy and paste these into the preferences listing and change their values to "1"? mail.ui.display.dateformat.today (default 0) mail.ui.display.dateformat.thisweek (default 2) mail.ui.display.dateformat.default (default 2) Thanks.

Okulungisiwe ngu Rich

Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.