Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How to hide firefox scroll bar ?

  • 3 uphendule
  • 8 zinale nkinga
  • 37761 views
  • Igcine ukuphendulwa ngu as3mbus

more options

as the title says, i would like to hide scroll bar in firefox. I've searched the internet and found the following solution https://support.mozilla.org/en-US/questions/957337 but it seems not working anymore Firefox version that i use is (Nightly 61.0a1 (2018-05-04) (64-bit))

Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

Try this code in userChrome.css (you may have to adjust the margin values):

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

:-moz-any(#content,#appcontent) browser{
 margin-right:-14px!important;
 overflow-y:scroll;
 margin-bottom:-14px!important;
 overflow-x:scroll;
}
Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (3)

more options

Here, I found one answer from the internet for you:

Open Firefox Access about:support (or click on Menu > Help > Troubleshooting Information) See the “Profile Folder” there, under “Application Basics”? You can open that path on Explorer/Finder/GFiles, or just click on ‘Open Folder’. Read more about profile folders here if you’re so inclined.

Create your userChrome.css Now that you’re in the profile folder, create a new folder named “chrome” . Just chrome, lowercase.

Inside that folder, create a new file named “userChrome.css“, with the following content:

#content browser{
  margin-right:-17px!important;
  margin-bottom:-17px!important;
  overflow-y:scroll;
  overflow-x:hidden;
}

Let’s check: this file should be at [wherever your profile folder is]/chrome/userChrome.css .

Save it, and restart Firefox. You’re done! The scrollbars are gone.

I hope this answer helpful to you.I tried in my computer and it worked

Okulungisiwe ngu cor-el

more options

Isisombululo Esikhethiwe

Try this code in userChrome.css (you may have to adjust the margin values):

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

:-moz-any(#content,#appcontent) browser{
 margin-right:-14px!important;
 overflow-y:scroll;
 margin-bottom:-14px!important;
 overflow-x:scroll;
}

Okulungisiwe ngu cor-el

more options

@Trupesh thank you for your resourceful information it give me much more insight about profile folder. but unfortunately your code snippet doesn't work.

@cor-el thank you the code works like a charm.

thank you everyone for your fast answer