Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

how to change the region settings / format for currency, dates and times?

more options

Hello Community,

i am currently using Firefox with the english and german language pack enabled. This way it displays the user-interface in german. I think that this eventually comes somehow from the system preferences..

if i deactivate the german language pack the user interface is in english - that is what i really want. but with a slight twist.. i don't like the currency, date and time formats. (it switches to the PM/AM and Month/Day/Year and so on..)

So i would like to combine the German currency, date and time formats with the english user-interface language. is this possible?

in my Operating System (Kubuntu 17.10) i have done this mix successfully. - so in theory the system already knows what i want...

any ideas on this are greatly appreciated.

sunny greetings stefan

Isisombululo esikhethiwe

Hi cor-el,

i have made a some test: i changed only the 'region settings' to something unique: 'en_DK' at the OS-Level.

  • logout and login (so these settings are really used by the system)
  • start Firefox -
  • get the same information from the about:support page

"intl": {

   "localeService": {
     "requested": [
       "en-DK",
       "en-US"
     ],
     "available": [
       "en-GB",
       "en-US"
     ],
     "supported": [
       "en-US",
       "en-GB"
     ],
     "regionalPrefs": [
       "en-US",
       "en-GB"
     ],
     "defaultLocale": "en-US"
   },
   "osPrefs": {
     "systemLocales": [
       "en-DK"
     ],
     "regionalPrefsLocales": [
       "de-DE"
     ]
   }

so seems it is really the system that brings this in... i tried and set the system settings another way - this time splitting the 'region' and the formats (like in the second screenshot i attached) this gives

"intl": {
   "localeService": {
     "requested": [
       "en-GB",
       "en-US"
     ],
     "available": [
       "en-GB",
       "en-US"
     ],
     "supported": [
       "en-GB",
       "en-US"
     ],
     "regionalPrefs": [
       "en-GB",
       "en-US"
     ],
     "defaultLocale": "en-US"
   },
   "osPrefs": {
     "systemLocales": [
       "en-GB"
     ],
     "regionalPrefsLocales": [
       "de-DE"
     ]
   }
 },

so its better than before - i now have 24Hours format :-)

then i research on regarding your mentioned config

and found a similar question at mozillaZine this lead me to a [bug report https://bugzilla.mozilla.org/show_bug.cgi?id=1379910] where this is discussed.

so i changed my system configuration back to de_DE as Region settings without detailed settings. than changed the preference intl.regional_prefs.use_os_locales: true to true and restarted the system.

this leads to "intl": {

   "localeService": {
     "requested": [
       "de-DE",
       "en-US"
     ],
     "available": [
       "en-GB",
       "de",
       "en-US"
     ],
     "supported": [
       "de",
       "en-US",
       "en-GB"
     ],
     "regionalPrefs": [
       "de-DE"
     ],
     "defaultLocale": "en-US"
   },
   "osPrefs": {
     "systemLocales": [
       "de-DE"
     ],
     "regionalPrefsLocales": [
       "de-DE"
     ]
   }
 },

this time the format was fine but the user interface language switched back to German too :-(

next i tried again to split - set region to United Kingdom and all Detailed Settings to German. after an restart i got "intl": {

   "localeService": {
     "requested": [
       "en-GB",
       "en-US"
     ],
     "available": [
       "en-GB",
       "de",
       "en-US"
     ],
     "supported": [
       "en-GB",
       "en-US"
     ],
     "regionalPrefs": [
       "de-DE"
     ],
     "defaultLocale": "en-US"
   },
   "osPrefs": {
     "systemLocales": [
       "en-GB"
     ],
     "regionalPrefsLocales": [
       "de-DE"
     ]
   }
 },

and this time it worked!!

thanks for pointing me in the right direction to fix this :-)

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (6)

more options

Hi, none as that is all controlled by your OS and you should check a forum of your flavour of Linux for help/info.

As to the Language pack changing things, please see the Developers site for support/info.

Please let us know if this solved your issue or if need further assistance.

more options

What if you switch from the en-US (U.S. English) build to the en-GB (British English) build? I think that might switch the dates and times to the European style.

I don't know the best way to try that since Linux users have various installation options and configuration issues. If you are installing manually, you can get en-GB from this page:

https://www.mozilla.org/en-GB/firefox/all/

And see: Install Firefox on Linux

more options

Pkshadow said

As to the Language pack changing things, please see the Developers site for support/info.

The Language Pack being those on https://addons.mozilla.org/firefox/language-tools/ and not something else.

more options

thanks for your replies!

i have tried and installed the English (GB) Language Pack and deactivated all others. i have attached a screenshot of this screen.. and also a screenshot of the library window - here you can see that the date format is the MM/DD/YYYY... then i only enabled the german language pack and reopend the Library. again of both screens i have attached a screenshot. in the library window the changes are instantly visible (after reopen it) i also tested the javascript behavior in the developer console: event = new Date(); console.log(event.toLocaleString()); if only the English (GB) Language Pack is active i get " 4/25/2018, 5:47:23 PM" if i activate the German Pack (the English one is also active) i get " 25.4.2018, 17:48:11"

so it seems to me that the system settings are not controlling this directly - its more the language packs.. but somehow if both packs are active German wins - this could come from some system setting...

as Firefox itself is installed via the package management tool (for me that is apt) i don't want to mess with this.... but i searched there and both the english and german language packages are installed there too... (there is no GB one in the available packages - its only on with 'English')

if there is a better place to discuss this pleas let me know.

more options

The attached troubleshooting information shows:

osPrefs: regionalPrefsLocales:["de-DE"]; systemLocales:["de-DE"]; 
localeService: available:["en-GB","en-US"]; requested:["de-DE","en-US"]; regionalPrefs:["en-US","en-GB"]; supported:["en-US","en-GB"]; defaultLocale:"en-US";

See also this pref:

  • intl.regional_prefs.use_os_locales
more options

Isisombululo Esikhethiwe

Hi cor-el,

i have made a some test: i changed only the 'region settings' to something unique: 'en_DK' at the OS-Level.

  • logout and login (so these settings are really used by the system)
  • start Firefox -
  • get the same information from the about:support page

"intl": {

   "localeService": {
     "requested": [
       "en-DK",
       "en-US"
     ],
     "available": [
       "en-GB",
       "en-US"
     ],
     "supported": [
       "en-US",
       "en-GB"
     ],
     "regionalPrefs": [
       "en-US",
       "en-GB"
     ],
     "defaultLocale": "en-US"
   },
   "osPrefs": {
     "systemLocales": [
       "en-DK"
     ],
     "regionalPrefsLocales": [
       "de-DE"
     ]
   }

so seems it is really the system that brings this in... i tried and set the system settings another way - this time splitting the 'region' and the formats (like in the second screenshot i attached) this gives

"intl": {
   "localeService": {
     "requested": [
       "en-GB",
       "en-US"
     ],
     "available": [
       "en-GB",
       "en-US"
     ],
     "supported": [
       "en-GB",
       "en-US"
     ],
     "regionalPrefs": [
       "en-GB",
       "en-US"
     ],
     "defaultLocale": "en-US"
   },
   "osPrefs": {
     "systemLocales": [
       "en-GB"
     ],
     "regionalPrefsLocales": [
       "de-DE"
     ]
   }
 },

so its better than before - i now have 24Hours format :-)

then i research on regarding your mentioned config

and found a similar question at mozillaZine this lead me to a [bug report https://bugzilla.mozilla.org/show_bug.cgi?id=1379910] where this is discussed.

so i changed my system configuration back to de_DE as Region settings without detailed settings. than changed the preference intl.regional_prefs.use_os_locales: true to true and restarted the system.

this leads to "intl": {

   "localeService": {
     "requested": [
       "de-DE",
       "en-US"
     ],
     "available": [
       "en-GB",
       "de",
       "en-US"
     ],
     "supported": [
       "de",
       "en-US",
       "en-GB"
     ],
     "regionalPrefs": [
       "de-DE"
     ],
     "defaultLocale": "en-US"
   },
   "osPrefs": {
     "systemLocales": [
       "de-DE"
     ],
     "regionalPrefsLocales": [
       "de-DE"
     ]
   }
 },

this time the format was fine but the user interface language switched back to German too :-(

next i tried again to split - set region to United Kingdom and all Detailed Settings to German. after an restart i got "intl": {

   "localeService": {
     "requested": [
       "en-GB",
       "en-US"
     ],
     "available": [
       "en-GB",
       "de",
       "en-US"
     ],
     "supported": [
       "en-GB",
       "en-US"
     ],
     "regionalPrefs": [
       "de-DE"
     ],
     "defaultLocale": "en-US"
   },
   "osPrefs": {
     "systemLocales": [
       "en-GB"
     ],
     "regionalPrefsLocales": [
       "de-DE"
     ]
   }
 },

and this time it worked!!

thanks for pointing me in the right direction to fix this :-)