X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

I get an error in firefox but not in other browsers.

Kuphostiwe

I have a page that does not respond in firefox but does in google. It time out with the following error:

chrome://global/content/bindings/text.xml:36

I have no themes installed. The only plug-ins that are installed are: OpenH264 by Cisco Widevine Content Decryption Module by Google Shockwave Flash

Thanks Glenn

I have a page that does not respond in firefox but does in google. It time out with the following error: chrome://global/content/bindings/text.xml:36 I have no themes installed. The only plug-ins that are installed are: OpenH264 by Cisco Widevine Content Decryption Module by Google Shockwave Flash Thanks Glenn

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/65.0.3325.181 Safari/537.36

Eminye Imininingwane

Shadow110 1072 izisombululo 14836 izimpendulo
Kuphostiwe

Hi, Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Hi, '''Try Firefox Safe Mode''' to see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). '''If Firefox is open,''' you can restart in Firefox Safe Mode from the Help menu: * Click the menu button [[Image:New Fx Menu]], click Help [[Image:Help-29]] and select ''Restart with Add-ons Disabled''. '''If Firefox is not running,''' you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) When the Firefox Safe Mode window appears, select "Start in Safe Mode". ;[[Image:SafeMode-Fx35]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' When you figure out what's causing your issues, please let us know. It might help others with the same problem.
FredMcD
  • Top 10 Contributor
4269 izisombululo 59843 izimpendulo
Kuphostiwe

Please provide public link(s) (no password) that we can check out. No Personal Information Please !

Please provide public link(s) (no password) that we can check out. '''No Personal Information Please ! '''

Umnikazi wombuzo

Fred:

I have to give you a login and password. I'm not worried because this is all test

the Url is http://mrbreeze.net/test/ Login: cbre Password: sales

Click on "Excluives" When the page display click on the radio button for "Company Name".

At this point Firefox reports "not responding". When it does come back you can get to the drop down. If you keep playing with the page sooner or later you'll get the error that I reported.

As I said in my original message, this works in Chrome.

Fred: I have to give you a login and password. I'm not worried because this is all test the Url is http://mrbreeze.net/test/ Login: cbre Password: sales Click on "Excluives" When the page display click on the radio button for "Company Name". At this point Firefox reports "not responding". When it does come back you can get to the drop down. If you keep playing with the page sooner or later you'll get the error that I reported. As I said in my original message, this works in Chrome.
FredMcD
  • Top 10 Contributor
4269 izisombululo 59843 izimpendulo
Kuphostiwe

I got as far as; click on the radio button for "Company Name".

I got as far as; click on the radio button for "Company Name".

Umnikazi wombuzo

That's as far as I can get. If you wait long enough you'll get the error. Firefox just freezes. Try it in chrome.

That's as far as I can get. If you wait long enough you'll get the error. Firefox just freezes. Try it in chrome.
cor-el
  • Top 10 Contributor
  • Moderator
17571 izisombululo 158915 izimpendulo
Kuphostiwe

What Firefox locale (user interface language) do you use?

It is possible that your locale is broken.

What Firefox locale (user interface language) do you use? It is possible that your locale is broken.

Umnikazi wombuzo

How do I find that? The language is english.

How do I find that? The language is english.
cor-el
  • Top 10 Contributor
  • Moderator
17571 izisombululo 158915 izimpendulo
Kuphostiwe

I see error messages in the Web Console.

  • "3-bar" menu button or Tools -> Web Developer
<script> source URI is not allowed in this document: “file:///rollover.js”.
Exclusives.php:36
ReferenceError: jQuery is not defined[Learn More]

You can't access local files via the file protocol, so you need to upload this file Also the jQuery library file is missing.

I see error messages in the Web Console. *"3-bar" menu button or Tools -> Web Developer <pre><nowiki><script> source URI is not allowed in this document: “file:///rollover.js”. Exclusives.php:36 ReferenceError: jQuery is not defined[Learn More]</nowiki></pre> You can't access local files via the file protocol, so you need to upload this file Also the jQuery library file is missing.

Umnikazi wombuzo

I'm a little confused. I googled "jquery library" and I'm not sure what to download. After I download whatever, just upload the file to root of the page?

I'm a little confused. I googled "jquery library" and I'm not sure what to download. After I download whatever, just upload the file to root of the page?
cor-el
  • Top 10 Contributor
  • Moderator
17571 izisombululo 158915 izimpendulo
Kuphostiwe

There is this code in the page source that uses jQuery:

       <script type="text/javascript">
      jQuery(function($) {
        $('#Listing_From').mask('99/99/9999',{placeholder:"mm/dd/yyyy"});
		$('#Listing_To').mask('99/99/9999',{placeholder:"mm/dd/yyyy"});
		$('#Update_From').mask('99/99/9999',{placeholder:"mm/dd/yyyy"});
		$('#Update_To').mask('99/99/9999',{placeholder:"mm/dd/yyyy"});
      });
    </script>

If you do not need this code then remove it.

If you check the page source (right-click context menu: View Page Source) then you will also notice HTML code at the top of the page in the <head> section that should actually be in the <body> tag. Firefox will automatically open a <body> tag as you can see in the Inspector So the code on this page needs some cleanup.

There is this code in the page source that uses jQuery: <pre><nowiki> <script type="text/javascript"> jQuery(function($) { $('#Listing_From').mask('99/99/9999',{placeholder:"mm/dd/yyyy"}); $('#Listing_To').mask('99/99/9999',{placeholder:"mm/dd/yyyy"}); $('#Update_From').mask('99/99/9999',{placeholder:"mm/dd/yyyy"}); $('#Update_To').mask('99/99/9999',{placeholder:"mm/dd/yyyy"}); }); </script></nowiki></pre> If you do not need this code then remove it. If you check the page source (right-click context menu: View Page Source) then you will also notice HTML code at the top of the page in the &lt;head&gt; section that should actually be in the &lt;body&gt; tag. Firefox will automatically open a &lt;body&gt; tag as you can see in the Inspector So the code on this page needs some cleanup. *http://validator.w3.org/

Umnikazi wombuzo

I ripped the code apart. The following page passes W3C as well as not showing any errors in the source code view in FireFox.

Check it out. Go to "Mrbreeze.net/test". Login as before. Change the url to read "http://mrbreeze.net/test/Ex.php"

The same thing happens. Once you click radio button for companies and then try the drop down, "FireFox" stops responding.

Any more ideas? Thanks Glenn

I ripped the code apart. The following page passes W3C as well as not showing any errors in the source code view in FireFox. Check it out. Go to "Mrbreeze.net/test". Login as before. Change the url to read "http://mrbreeze.net/test/Ex.php" The same thing happens. Once you click radio button for companies and then try the drop down, "FireFox" stops responding. Any more ideas? Thanks Glenn
cor-el
  • Top 10 Contributor
  • Moderator
17571 izisombululo 158915 izimpendulo
Kuphostiwe

Works for me. It takes a few seconds to open the selection list, but it shows without problems.

Works for me. It takes a few seconds to open the selection list, but it shows without problems.

Umnikazi wombuzo

Yes, I get the same thing but why the delay. Sometimes is says that "firefox is not responding" before it comes back. This isn't code, what could it be. Try it in Chrome. The drop down pops right up. WTF

Yes, I get the same thing but why the delay. Sometimes is says that "firefox is not responding" before it comes back. This isn't code, what could it be. Try it in Chrome. The drop down pops right up. WTF
cor-el
  • Top 10 Contributor
  • Moderator
17571 izisombululo 158915 izimpendulo
Kuphostiwe

The Web Console shows that there are 5529 nodes (option values) in that drop-down list (Show all 5529 nodes message at the bottom). So it sounds that Firefox has a problem with such a long list, possibly because this is done in JavaScript and not in C++ (don't know if this is the case).

The Web Console shows that there are 5529 nodes (option values) in that drop-down list (Show all 5529 nodes message at the bottom). So it sounds that Firefox has a problem with such a long list, possibly because this is done in JavaScript and not in C++ (don't know if this is the case).

Umnikazi wombuzo

"Whoa Trigger" (Lone Ranger) Let me get this straight. There is no Java or C++ in the code. The query is being done with PHP and you are telling me that Firefox can't handle it. I've tested in Chrome, Opera and IE. No problems. What do I do, tell a customer that we don't support Firefox?

"Whoa Trigger" (Lone Ranger) Let me get this straight. There is no Java or C++ in the code. The query is being done with PHP and you are telling me that Firefox can't handle it. I've tested in Chrome, Opera and IE. No problems. What do I do, tell a customer that we don't support Firefox?
cor-el
  • Top 10 Contributor
  • Moderator
17571 izisombululo 158915 izimpendulo
Kuphostiwe

I wasn't talking about your code, but about the way Firefox is handling this element internally. Firefox needs to read and process a lot of data on that page when you open the drop-down list. Apparently it takes Firefox longer then is acceptable to show this list.

I wasn't talking about your code, but about the way Firefox is handling this element internally. Firefox needs to read and process a lot of data on that page when you open the drop-down list. Apparently it takes Firefox longer then is acceptable to show this list.

Umnikazi wombuzo

What do I do about this. By the way "Trigger" was Roy Rogers. ;)

What do I do about this. By the way "Trigger" was Roy Rogers. ;)
cor-el
  • Top 10 Contributor
  • Moderator
17571 izisombululo 158915 izimpendulo
Kuphostiwe

You can consider to file a bug report and attach a minimal HTML test file.

You can consider to file a bug report and attach a minimal HTML test file. *https://bugzilla.mozilla.org/describecomponents.cgi?product=Core#DOM:%20Core%20%26%20HTML
jscher2000
  • Top 10 Contributor
8788 izisombululo 71874 izimpendulo
Kuphostiwe

I get the script error in my standard Firefox 59 profile (Windows).

I do not get a script error in a quick test in Nightly (future Firefox 61), but there is about a five second delay opening the list.

That could be a function of not having used Nightly for anything else this session. Rendering of select controls involve coordination between the page (content) process and the browser process, and the interprocess communication could be affected by everything else happening in the session.

I get the script error in my standard Firefox 59 profile (Windows). I do not get a script error in a quick test in Nightly (future Firefox 61), but there is about a five second delay opening the list. That could be a function of not having used Nightly for anything else this session. Rendering of select controls involve coordination between the page (content) process and the browser process, and the interprocess communication could be affected by everything else happening in the session.

Umnikazi wombuzo

So what you;re telling me is that in "(future Firefox61)" the problem is fixed?!?!?

So what you;re telling me is that in "(future Firefox61)" the problem is fixed?!?!?