Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox loads up some page and runs it separately in the background, it continues to run even when I close firefox. Today it loaded by itself before I opened f

  • 19 uphendule
  • 2 zinale nkinga
  • 1421 views
  • Igcine ukuphendulwa ngu Mylosmiles

more options

Using Windows 7 64bit. Firefox opens and runs a separate page in the background. The extra page does not open and the only way to see it is to open ctrl/alt/delete and that is the only way to close it but I have to go to processes to close it, it will not close in applications. Today Firefox a page loaded in the background before I opened my FF browser. I have uninstalled and reinstalled Firefox twice to no avail. I have removed all themes - nothing. Please help me fix this, I have used Firefox for years and love it but this latest mess is causing my computer to overload its ram and loading too many temp files.

Isisombululo esikhethiwe

I found what was causing this problem, it has to do with something called cloudctl, (attached a screen shot) I do not use clouds have never signed up for any. So this was quite enlightening. I stop the scheduled task and then went and killed the process tree on that program you suggested above. So far so good. Thanks for all the info and insights.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (19)

more options

Firefox does load additional instances in the Task Manager when using Firefox as that is part of the multi-processor role of Quantum.

It should not load before.

Please do this : use more than 1 scanner as each uses diff tech :

Save your Report and google each before deleting anything as do not want to delete something you need, If need help :

Post in only 1 forum, then wait.

Please let us know if this solved your issue or if need further assistance.

more options

Could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. (This does not affect the number of firefox.exe processes Firefox uses.)

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

more options

this did not solve my problem, but I had one more suggestion to run a malware check program so I did and it found some malware that it removed. The problem seems gone so far. Thank you so much for your suggestions, appreciate it.

more options

Apparently it was malware...thanks so much for your help

more options

Well, I thought it solved the problem but it is back now. Have run 2 different malware programs twice now. The problem is that when FF is running in the background, I can only shut the background one off in ctrl/alt/delete processes tab. And when it is running it is using a huge amount of ram. Sometimes the title is just Mozilla Firefox, other times it is a long name of some sports ad page (these pages never open). I use opera once in a while only but have never had the background running with it so I know it is Firefox that is doing it. I am sending you 2 screen shots from windows task manager so you can see it running, the one that says facebook is the one I have open,, do not know what "sportsinsider"is and on the processes page it is the one using all the cpu. Any help would be greatly appreciated

more options

A post was flagged as Solved Problem. If the problem is not solved, please remove that flag. If you don’t, others that can help may not read this post.

Go to that message, and use the Undo link to its right.


Go to the Mozilla Add-ons Web Page {web Link} (There’s a lot of good stuff here) and search for a good ad / pop-up blocker.


More than one process is normal for the current Firefox. http://www.ghacks.net/2016/07/22/multi-process-firefox/

Multi-process Firefox is codenamed "e10s". https://wiki.mozilla.org/Firefox/multiprocess


Try to disable multi-process tabs in Firefox. You can disable multi-process tabs in Firefox by setting the related prefs to false on the about:config page.

browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

Type about:config<enter> in the address bar. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar.

more options

Is the second window listed if you hover the Firefox icon on the Windows 7 Task bar? If so, can you hover its thumbnail or title and close it using the little "x" there?


If you are not loading the page yourself, and you don't think it's generated by an ad on one of the sites you visit that does it, it may be one of your extensions.

You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything suspicious or that you just do not remember installing or why? If in doubt, disable (or remove).

Any improvement?

more options

so far I am working on disabling (one by one) the few addons I have and letting firefox run to see it that helps. Will let you know, appreciate all your help and time..

more options

HI, please start in : SAFE MODE as then they are all disabled and see if the issue is there when they are disabled in safe mode.

In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected

TEST''''is issue still there ?

You can also do this and start from scratch : please try a Refresh but Note that this does more than uninstalling and re-installing does. Normal uninstalling does not remove some preferences which may have become corrupt. Please Refresh but do this 1st: Delete your Cookies and Cache and TEST.

then

TEST....... If no issues then Extensions which need to be added back in 1 at a time and tested ..... Or it is your Profile : Make a new one and test ...:

If is your Profile :

Note: Any customization will revert back to default, you will also need to reinstall Extensions.

Please let us know if this solved your issue or if need further assistance.

more options

ok, so far nothing helps, I have uninstalled and reinstalled firefox per instructions, removed all addons, checked all options, etc. Run 3 different malware programs - Not one thing I do helps. If I go into task manager and stop the second Firefox running (which does not show up when hovering over the Firefox icon) then Firefox hangs and slows. This did not happen in the older versions of Firefox so I must assume it is something that has been done to the newer versions. This mess is running my ram and leaving large amounts of temp files. There has to be a cure, if not I will have to switch away from Firefox until the problem is solved. Appreciate your help in advance.

more options

In the Task Manager, on the Processes tab, could you add the "Command Line" column? The normal instances of Firefox (if mine is normal, a big assumption) have command lines like this:

  • "C:\Program Files\Mozilla Firefox\firefox.exe"
  • "C:\Program Files\Mozilla Firefox\firefox.exe" -contentproc --channel="..." -childID 1 -isForBrowser ...
  • "C:\Program Files\Mozilla Firefox\firefox.exe" -contentproc --channel="..." -childID 2 -isForBrowser ...
  • [more childID processes]
  • "C:\Program Files\Mozilla Firefox\firefox.exe" -contentproc --channel="..." -greomni ...

Do you have any that follow a different pattern?

more options

Ok, I put the Command Line on the processes tab. There are 2 FF running. I have attached a screen shot of both of them. The short one is exactly the same as yours (the one I am using), however the long one looks nothing like your others. The long one is the one running in the background. Your thoughts?

more options

That's really strange. The "-start-debugger-server" command-line switch is intended for developers to connect to another instance of Firefox. Since you obviously are not doing that, who is, and why??

Could you look into the Windows Task Scheduler and see whether you can find anything unknown that might be launching Firefox that way? These are the steps:

  1. Click the Start button.

  2. Click Control Panel.

  3. Use the search box in the upper right corner to look for schedule or tasks as a shortcut to clicking through the categories. (Otherwise, it's under Administrative Tools.)

  4. Click "Schedule tasks" or if you're in the folder full of shortcuts, double-click Task Scheduler.

Now the hard part... finding anything in here. You will see a laundry list of tasks Windows is scheduled to run at various times. Here's a sample screenshot from Windows 7 showing where the schedule information appears: https://prod-cdn.sumo.mozilla.net/uploads/images/2018-01-31-17-47-34-9797e7.png

more options

I got there but what am I looking for?

more options

Can we turn it off? Once we find it..have no idea how this came about

more options

I don't know why that process is running or what starts it. I can only guess it it started either by a live program running in the background or by a scheduled task. If you find a task, you can delete it.

Microsoft has another program similar to Task Manager that more clearly shows when a program is running as a "child" of another program. Not sure if that will be useful, but maybe:

https://docs.microsoft.com/en-us/sysinternals/downloads/process-explorer

more options

Isisombululo Esikhethiwe

I found what was causing this problem, it has to do with something called cloudctl, (attached a screen shot) I do not use clouds have never signed up for any. So this was quite enlightening. I stop the scheduled task and then went and killed the process tree on that program you suggested above. So far so good. Thanks for all the info and insights.

more options

Good work tracking that down.

Does the "cloudctl.exe" file seem to be associated with any program you (intentionally) installed? You might submit it here for a quick check:

https://www.virustotal.com/

more options

no nothing I installed, I checked online and there is a company in Australia that uses the same name. It is supposedly a controller for cloud use. But like I said I never use clouds - don't trust them thankfully. I use an anti virus program that scans every file but it did not find that, also the malware did not find it. I have deleted it now and seem to be free of the background programs - but I will definitely keep an eye out.. what a headache, now I have to fight scripts running in the background of FF...ugh! thanks again