X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

cant delete history, keep getting java no enable

Kuphostiwe

Java application This function has been disable

That's the message I'm getting. running Firefox 52.7.3 on Windows XP sp3

How can I fix this from Firefox or do I need another Browser.

Java application This function has been disable That's the message I'm getting. running Firefox 52.7.3 on Windows XP sp3 How can I fix this from Firefox or do I need another Browser.

Isisombululo esikhethiwe

Thanks, finally got it working

Went into about:addons in safe-mode in FF and disable "Disable browsing plus", you can only do it in safe-mode. All the other extensions worked fine.

appreciate the help.


Problem Solved

Funda le mpendulo ngokuhambisana nalesi sihloko 0

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.8
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.151.2 for Mozilla browsers
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Shockwave Flash 29.0 r0
  • 5.1.50905.0
  • VLC media player Web Plugin
  • Npdsplay dll
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • npIPcam DLL - 2.0.2.11

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 Firefox/52.0

Eminye Imininingwane

FredMcD
  • Top 10 Contributor
4248 izisombululo 59425 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Let's start with this;

Places Maintenance by MaK77

https://addons.mozilla.org/en-US/firefox/addon/places-maintenance/ Places Maintenance

Allows to run Maintenance tasks on the database that drives Places, the bookmarks, and history module behind Firefox.

Open the Add-ons Manager. Locate the add-on and press the Options button. Then press Next on the bottom.

Let's start with this; Places Maintenance by MaK77 https://addons.mozilla.org/en-US/firefox/addon/places-maintenance/ Places Maintenance Allows to run Maintenance tasks on the database that drives Places, the bookmarks, and history module behind Firefox. Open the Add-ons Manager. Locate the add-on and press the '''Options''' button. Then press '''Next''' on the bottom.

Umnikazi wombuzo

I dont see an option button or Next

Still getting Java application This function has been disable

When i try to clear my history file

I dont see an option button or Next Still getting Java application This function has been disable When i try to clear my history file
FredMcD
  • Top 10 Contributor
4248 izisombululo 59425 izimpendulo
Kuphostiwe

Java is no longer in Firefox. Please take a screenshot of the message.


In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

Java is no longer in Firefox. Please take a screenshot of the message. In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see [[How do I create a screenshot of my problem?]] Once you've done this, attach the saved screenshot file to your forum post by clicking the '''Browse...''' button below the ''Post your reply'' box. This will help us to visualize the problem. Thank you!
FredMcD
  • Top 10 Contributor
4248 izisombululo 59425 izimpendulo
Kuphostiwe

oops, sorry, java is used by ESR

oops, sorry, java is used by ESR

Umnikazi wombuzo

This is what I get when trying ti clear history files.

How do I clear out my files, firefox is no help, not even a tech support number for their browser.

Windows xp sp3 Firefox 52

This is what I get when trying ti clear history files. How do I clear out my files, firefox is no help, not even a tech support number for their browser. Windows xp sp3 Firefox 52
James
  • Moderator
1596 izisombululo 11250 izimpendulo
Kuphostiwe

The wording is "JavaScript application This function has been disabled"

http://kb.mozillazine.org/JavaScript_is_not_Java

If only JavaScript kept the original name of LiveScript to reduce the confusion with Java over the years.

What Extensions do you have installed as perhaps one of them is triggering this error.

The wording is "Java'''Script''' application This function has been disabled" http://kb.mozillazine.org/JavaScript_is_not_Java If only JavaScript kept the original name of LiveScript to reduce the confusion with Java over the years. What Extensions do you have installed as perhaps one of them is triggering this error.

Umnikazi wombuzo

Same extension i had last month and it was working. I have no idea why it pops up if is wasn't JavA, do i need to add an extension of some kind?

Same extension i had last month and it was working. I have no idea why it pops up if is wasn't JavA, do i need to add an extension of some kind?
Murphy 20 izisombululo 264 izimpendulo
Kuphostiwe

mistyone said

Same extension i had last month and it was working. I have no idea why it pops up if is wasn't JavA, do i need to add an extension of some kind?

In Firefox JavaScript is enabled by default.

To make sure, please type in the address bar about:config and press Enter. (promise to be careful, if asked)

Type in the search bar and look for the preference javascript.enabled and make sure that its value is set to true (= default)

''mistyone [[#answer-1100708|said]]'' <blockquote> Same extension i had last month and it was working. I have no idea why it pops up if is wasn't JavA, do i need to add an extension of some kind? </blockquote> In Firefox Java'''Script''' is enabled by default. To make sure, please type in the address bar '''about:config''' and press Enter. (promise to be careful, if asked) Type in the search bar and look for the preference '''javascript.enabled''' and make sure that its value is set to '''true''' (= default)
FredMcD
  • Top 10 Contributor
4248 izisombululo 59425 izimpendulo
Kuphostiwe

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?
cor-el
  • Top 10 Contributor
  • Moderator
17482 izisombululo 157978 izimpendulo
Kuphostiwe

Can you attach a screenshot?

Can you attach a screenshot? *https://support.mozilla.org/en-US/kb/how-do-i-create-screenshot-my-problem *use a compressed image type like PNG or JPG to save the screenshot

Umnikazi wombuzo

cor-el said

Can you attach a screenshot?
''cor-el [[#answer-1100905|said]]'' <blockquote> Can you attach a screenshot? *https://support.mozilla.org/en-US/kb/how-do-i-create-screenshot-my-problem *use a compressed image type like PNG or JPG to save the screenshot </blockquote>

Umnikazi wombuzo

I posted a screen shot already

I posted a screen shot already

Umnikazi wombuzo

FredMcD said

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?
''FredMcD [[#answer-1100773|said]]'' <blockquote> [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? </blockquote>

Umnikazi wombuzo

Got rid of the history in Safe mode, tried again in regular mode and still getting the same problems, think ill delete firefox and reinstall to see if that works.

Got rid of the history in Safe mode, tried again in regular mode and still getting the same problems, think ill delete firefox and reinstall to see if that works.
FredMcD
  • Top 10 Contributor
4248 izisombululo 59425 izimpendulo
Kuphostiwe

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

It could be the work of one of your add-ons, or it could be '''Hardware Acceleration. ''' ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link} Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control> ''(Mac=<Command>)'' <Shift> A) ''' In the Add-ons Manager, on the left, select '''Extensions. ''' Disable a few add-ons, then '''Restart Firefox. ''' Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All Of them. ''' If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group '''ONE AT A TIME''' (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

Umnikazi wombuzo

FredMcD said

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link} Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A) In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox. Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them. If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.
''FredMcD [[#answer-1100927|said]]'' <blockquote> It could be the work of one of your add-ons, or it could be '''Hardware Acceleration. ''' ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link} Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control> ''(Mac=<Command>)'' <Shift> A) ''' In the Add-ons Manager, on the left, select '''Extensions. ''' Disable a few add-ons, then '''Restart Firefox. ''' Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All Of them. ''' If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group '''ONE AT A TIME''' (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective. </blockquote>

Isisombululo Esikhethiwe

Thanks, finally got it working

Went into about:addons in safe-mode in FF and disable "Disable browsing plus", you can only do it in safe-mode. All the other extensions worked fine.

appreciate the help.


Problem Solved

Thanks, finally got it working Went into about:addons in safe-mode in FF and disable "Disable browsing plus", you can only do it in safe-mode. All the other extensions worked fine. appreciate the help. Problem Solved

Okulungisiwe ngu mistyone

FredMcD
  • Top 10 Contributor
4248 izisombululo 59425 izimpendulo
Kuphostiwe

That was very good work. Well done. Please flag your last post as Solved Problem so others will know.

That was very good work. Well done. Please flag your last post as '''Solved Problem''' so others will know.