Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Email address links open endless multiple tabs

  • 7 uphendule
  • 2 zinale nkinga
  • 735 views
  • Igcine ukuphendulwa ngu Matt

more options

When I click on any mailto: link in Firefox Quantum 59.0.2 (64-bit) it opens endless blank tabs and there is no way out but to force quit the app itself. This has been going on for awhile and no update has fixed the problem yet.

Isisombululo esikhethiwe

You get tabs opening endlessly if you select the Firefox program to handle a file when you get an "Open with" dialog.

Check the Mailto application in Firefox > Preferences > Applications Make sure it isn't set to the Firefox application because Firefox can't handle the mailto protocol internally and you will get tabs opening endlessly.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (7)

more options

Hi, please check if you are clean from any influences that could start that : https://www.malwarebytes.com/mac/

more options

Wouldn't ESET be just as good as malwarebytes?

more options

Also, my research indicates that Firefox has had this exact problem before, and a fix was issued in an update from Mozilla back then.

more options

Isisombululo Esikhethiwe

You get tabs opening endlessly if you select the Firefox program to handle a file when you get an "Open with" dialog.

Check the Mailto application in Firefox > Preferences > Applications Make sure it isn't set to the Firefox application because Firefox can't handle the mailto protocol internally and you will get tabs opening endlessly.

more options

That fixed it! You have to manually select a mail client other than "Firefox" in Firefox > Preferences > Applications (as described above) to make this problem stop. I just tested it on some mailto: links and the problem is gone-- thanks, cor-el!

more options

Is there a resolve for those of us that use Gmail (pinned tab)?

EDIT: Never mind. Seems this is already an option.

Firefox > Preferences > Applications > Mailto: > Use Gmail

Works like a charm! :)

Okulungisiwe ngu Matt

more options

Matt said

Is there a resolve for those of us that use Gmail (pinned tab)?

Ah! Never mind. Seems this is already an option in Firefox > Preferences > Applications > Mailto: > Use Gmail

Works like a charm! :)