X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Why wont firefox detect that I have the newest version of flash?

Kuphostiwe

For years firefox has just periodically broken. By this I mean that random sites and features just die and never come back until I delete firefox and reinstall. This is always frustrating because I can open chrome right up and copy/paste the url and it will work fine EVERY TIME. Now, I have always put int he effort to fix it because I like firefox more than chrome and I'm used to it and I dont want to get used to a different browser. That being said I'm done messing around with these issues.

The current one is regarding adobe flash, a truly crap program through and through. I am trying to use the webcam feature on google hangouts, but whenever I try it says I need to update to flash 10.1 or greater and that I should go get that. Well one problem, I have it.

Your Flash Version 29.0.0.113 Your browser name Firefox (NPAPI) Your Operating System (OS) Windows (Window 10)

I have installed the current version of flash so many times. I've restarted the browser, I've rebooted the computer, nothing helps. I'm so sick of firefox just randomly breaking every time it pushes an update. If there isnt a simple fix for this issue I think I'm going to move to chrome from now on.

For years firefox has just periodically broken. By this I mean that random sites and features just die and never come back until I delete firefox and reinstall. This is always frustrating because I can open chrome right up and copy/paste the url and it will work fine EVERY TIME. Now, I have always put int he effort to fix it because I like firefox more than chrome and I'm used to it and I dont want to get used to a different browser. That being said I'm done messing around with these issues. The current one is regarding adobe flash, a truly crap program through and through. I am trying to use the webcam feature on google hangouts, but whenever I try it says I need to update to flash 10.1 or greater and that I should go get that. Well one problem, I have it. Your Flash Version 29.0.0.113 Your browser name Firefox (NPAPI) Your Operating System (OS) Windows (Window 10) I have installed the current version of flash so many times. I've restarted the browser, I've rebooted the computer, nothing helps. I'm so sick of firefox just randomly breaking every time it pushes an update. If there isnt a simple fix for this issue I think I'm going to move to chrome from now on.

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 29.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0

Eminye Imininingwane

Shadow110 1072 izisombululo 14836 izimpendulo
Kuphostiwe

Hi, sorry you are having such difficulties with Google and Flash. I really can not say what the issue is you are having as I have not heard of it before. I suggest though that instead of just install and reinstall that you use :

To completely remove it.

As for install and install Firefox : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do :

Reinstall with Current Release Firefox 59.0.2 with a Full Version Installer

Would be the best way to do that.

Though this would be useful to check out next time : Refresh but do this 1st: Delete your Cookies and Cache and TEST.

then

TEST....... If no issues then Extensions which need to be added back in 1 at a time and tested ..... Or it is your Profile : Make a new one and test ...:

If is your Profile :

Note: Any customization will revert back to default, you will also need to reinstall Extensions.

Also Copy/Paste about:support to the Address Bar and check out your Video Card Drivers for errors. It might be worth updating or reinstalling.

Please let us know if this solved your issue or if need further assistance.

Hi, sorry you are having such difficulties with Google and Flash. I really can not say what the issue is you are having as I have not heard of it before. I suggest though that instead of just install and reinstall that you use : *https://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html To completely remove it. As for install and install Firefox : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do : *https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles *https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer Reinstall with Current Release Firefox 59.0.2 with a Full Version Installer *https://www.mozilla.org/firefox/all/ Would be the best way to do that. Though this would be useful to check out next time : Refresh but do this 1st: Delete your Cookies and Cache and TEST. *https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer *https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles then *https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings TEST....... If no issues then Extensions which need to be added back in 1 at a time and tested ..... Or it is your Profile : Make a new one and test ...: *https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles If is your Profile : *https://support.mozilla.org/en-US/kb/recovering-important-data-from-an-old-profile *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox Note: Any customization will revert back to default, you will also need to reinstall Extensions. Also Copy/Paste about:support to the Address Bar and check out your Video Card Drivers for errors. It might be worth updating or reinstalling. Please let us know if this solved your issue or if need further assistance.

Umnikazi wombuzo

I solved it myself. If you go into addons/plugins and select the options for shockwave flash you can uncheck the box the lets firefox block "dangerous and intrusive flash content" which apparently is gmail hangouts webcam...? Stupid solve to a Stupid problem that apparently mozilla has never heard of before.... Better fix: Switch to Chrome.

I solved it myself. If you go into addons/plugins and select the options for shockwave flash you can uncheck the box the lets firefox block "dangerous and intrusive flash content" which apparently is gmail hangouts webcam...? Stupid solve to a Stupid problem that apparently mozilla has never heard of before.... Better fix: Switch to Chrome.
Shadow110 1072 izisombululo 14836 izimpendulo
Kuphostiwe

martin.sean624 said

I solved it myself. If you go into addons/plugins and select the options for shockwave flash you can uncheck the box the lets firefox block "dangerous and intrusive flash content" which apparently is gmail hangouts webcam...? Stupid solve to a Stupid problem that apparently mozilla has never heard of before.... Better fix: Switch to Chrome.

Hi, do what you gotta do. Glad found the issue.

Please Mark this as solved with your answer. Thank You.

''martin.sean624 [[#answer-1095583|said]]'' <blockquote> I solved it myself. If you go into addons/plugins and select the options for shockwave flash you can uncheck the box the lets firefox block "dangerous and intrusive flash content" which apparently is gmail hangouts webcam...? Stupid solve to a Stupid problem that apparently mozilla has never heard of before.... Better fix: Switch to Chrome. </blockquote> Hi, do what you gotta do. Glad found the issue. Please Mark this as solved with your answer. Thank You.

Umnikazi wombuzo

I think I did that when I answered my own question despite your unhelpful yet extremely long suggestion of things to do that dont work.

Thanks

I think I did that when I answered my own question despite your unhelpful yet extremely long suggestion of things to do that dont work. Thanks
Shadow110 1072 izisombululo 14836 izimpendulo
Kuphostiwe

You are completely welcome. But no you did not Mark the Question as Solved. Us Firefox Support Volunteers enjoy helping people out.

You are completely welcome. But no you did not Mark the Question as Solved. Us Firefox Support Volunteers enjoy helping people out.
James
  • Top 25 Contributor
  • Moderator
1603 izisombululo 11348 izimpendulo
Kuphostiwe

martin.sean624 said

I solved it myself. If you go into addons/plugins and select the options for shockwave flash you can uncheck the box the lets firefox block "dangerous and intrusive flash content" which apparently is gmail hangouts webcam...? Stupid solve to a Stupid problem that apparently mozilla has never heard of before.... Better fix: Switch to Chrome.

https://support.mozilla.org/en-US/kb/flash-blocklists

Mozilla would not do this without a good valid reason to have the Flash Player Plugin blocked on gmail hangouts webcam by default.

https://developer.mozilla.org/en-US/docs/Plugins/Roadmap

''martin.sean624 [[#answer-1095583|said]]'' <blockquote> I solved it myself. If you go into addons/plugins and select the options for shockwave flash you can uncheck the box the lets firefox block "dangerous and intrusive flash content" which apparently is gmail hangouts webcam...? Stupid solve to a Stupid problem that apparently mozilla has never heard of before.... Better fix: Switch to Chrome. </blockquote> https://support.mozilla.org/en-US/kb/flash-blocklists Mozilla would not do this without a good valid reason to have the Flash Player Plugin blocked on gmail hangouts webcam by default. https://developer.mozilla.org/en-US/docs/Plugins/Roadmap
jscher2000
  • Top 10 Contributor
8838 izisombululo 72242 izimpendulo
Kuphostiwe

A little while back, Hangouts switched to HTML5 media, so I'm puzzled to hear that it would use the Flash plugin.

Do you recall ever disabling the built-in camera features in Firefox? For example:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste getuser and pause while the list is filtered

Are any of these preferences modified from their default values?

(3) In the search box above the list, type or paste camera and pause while the list is filtered

Is the new permission setting modified from its default value?

If those have their default values, perhaps the problem that Firefox is unable to find your webcam so Hangouts has to "fall back" to Flash.

A little while back, Hangouts switched to HTML5 media, so I'm puzzled to hear that it would use the Flash plugin. Do you recall ever disabling the built-in camera features in Firefox? For example: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''getuser''' and pause while the list is filtered ''Are any of these preferences modified from their default values?'' (3) In the search box above the list, type or paste '''camera''' and pause while the list is filtered ''Is the new permission setting modified from its default value?'' If those have their default values, perhaps the problem that Firefox is unable to find your webcam so Hangouts has to "fall back" to Flash.