Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Can't see any video on facebook, It shows only weird colours!

  • 15 uphendule
  • 2 zinale nkinga
  • 84 views
  • Igcine ukuphendulwa ngu Dave-H

more options

Hi, As you see In the picture, this what I see most of times when I play any video or even A gif picture on facebook 85% shows like that, and only 15% works normally.. But on Youtube, Almost all videos work 98% without problems!!, this problem shows more on Facebook.. I have the latest version of my video card *Nvidia GT610 2G * And also Firefox Quantum.. And also the latest version of Adobe Flash Player.. *Windows 10, 8G Ram, Processor Intel Core I5 3470T* Although when I play any video from any other Browser, It works so normally without any problems at all!, but I love Firefox the most, I used to open from this great browser, I'm suffering from this problem for almost a year! please, I need a solution to this problem, HELP ME!

Ama-screenshot ananyekiwe

Okulungisiwe ngu DM_22

Isisombululo esikhethiwe

Hi DM_22,

Maybe you could try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 55 and above:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the General panel.
  3. Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
    Fx55Performance-disableHWA
  4. Uncheck Use hardware acceleration when available.
  5. Close Firefox completely and then restart Firefox to see if the problem persists.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (15)

more options

See if this helps;

Type in the address bar about:config (press Enter) (promise to be careful if asked) Type in the search bar and look for the preference : media.wmf.dxva.d3d11.enabled And set its value to false. After, restart Firefox.

more options

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

First of all, Thank u guys soo much for your help!..

  • FredMcD* : I did what u said but unfortunately still the same problem..

And *cor-el* : I did the steps that u said and I'm running Firefox in safe mode right now, but even If it worked, how can I get used from the addons, this would be useless :/

more options

Isisombululo Esikhethiwe

Hi DM_22,

Maybe you could try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 55 and above:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the General panel.
  3. Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
    Fx55Performance-disableHWA
  4. Uncheck Use hardware acceleration when available.
  5. Close Firefox completely and then restart Firefox to see if the problem persists.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

more options

DM_22 said

I'm running Firefox in safe mode right now, but even If it worked, how can I get used from the addons, this would be useless :/

https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If the problem goes away, that tells us one thing. If it does not, that tells us something else.

more options

I have exactly the same problem! Firefox 59.0.2 x64 on Windows 10. It doesn't happen on all Facebook videos all the time, and sometimes doesn't happen in a session at all, but once it does happen, many (but not all) Facebook videos fail for the rest of the session. Disabling hardware acceleration in Firefox does fix it, but I'm surprised I have to do that when I have a powerful system with the latest software versions and a good professional Nvidia Quadro graphics card, with its latest driver. If it is just a Firefox problem, it needs fixing!

Okulungisiwe ngu Dave-H

more options

Type in the address bar about:config (press Enter) (promise to be careful if asked) Type in the search bar and look for the preference : media.wmf.dxva.d3d11.enabled And set its value to false. After, restart Firefox.

more options

Thanks, but sorry, same result as @DM_22 - no difference. The videos are still failing with that setting.

more options

Happy112 said

Hi DM_22, Maybe you could try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps: In Firefox 55 and above:
  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the General panel.
  3. Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
    Fx55Performance-disableHWA
  4. Uncheck Use hardware acceleration when available.
  5. Close Firefox completely and then restart Firefox to see if the problem persists.
Did this fix your problems? Please report back to us! If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

This really helped! 'till now everything works so well without problems, Thank U sooo much!

more options

And thank u all for your help I really appreciate that

more options

DM_22 said

This really helped! 'till now everything works so well without problems, Thank U sooo much!

My pleasure - I'm glad that everything's back to normal  !

more options

Turning hardware acceleration off isn't exactly a fix though is it? It's more a workaround to disable something that isn't working right. If I have a powerful machine with a high end graphics card using its current driver, on the latest operating system, I shouldn't have to turn hardware acceleration off to get videos displaying properly!

more options

Just bumping this to add that it's still happening in Firefox 61! Turning hardware acceleration off is a workaround, not a fix. I shouldn't have to do that on my high-end system. Will this ever be fixed? Strange that it only seems to happen on Facebook videos, I've never seen it happen anywhere else, like Instagram and YouTube. Cheers, Dave.

more options

Note that problems with hardware acceleration are usually incompatibility issues between Firefox and the graphics display driver and can happen with any setup. Using multiple monitors can also cause issues.

more options

True of course, but you still don't expect it to happen with a professional Nvidia Quadro card with the latest drivers! I'm not using multiple monitors. Also, why is it only happening on Facebook? What's different about their videos? I've never seen the effect anywhere else.