X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwavalwa lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

how to fix Captcha on version 59

Kuphostiwe

After updating to v59, Google captcha no longer displays on the page. An example of the code not displaying is below:

<script src='https://www.google.com/recaptcha/api.js?render=explicit' async defer></script>

Any suggestions on how to resolve this?

Thanks!

After updating to v59, Google captcha no longer displays on the page. An example of the code not displaying is below: <script src='https://www.google.com/recaptcha/api.js?render=explicit' async defer></script> Any suggestions on how to resolve this? Thanks!

Isisombululo esikhethiwe

Thanks for your help. Firefox updated when I restarted in Safe mode today, and the issue is resolved in both safe and standard mode. It is also working on other systems at the office.

Funda le mpendulo ngokuhambisana nalesi sihloko 0
Shadow110 1072 izisombululo 14836 izimpendulo
Kuphostiwe

uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do :

Reinstall with Current Release Firefox 59.0.2 with a Full Version Installer

Please let us know if this solved your issue or if need further assistance.

uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do : *https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles *https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer Reinstall with Current Release Firefox 59.0.2 with a Full Version Installer *https://www.mozilla.org/firefox/all/ Please let us know if this solved your issue or if need further assistance.
FredMcD
  • Top 10 Contributor
4306 izisombululo 60471 izimpendulo
Kuphostiwe

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Make sure you are not blocking content. [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?
cor-el
  • Top 10 Contributor
  • Moderator
17680 izisombululo 159944 izimpendulo
Kuphostiwe

Firefox 42+ has a Tracking Protection feature that is enabled by default in Private Browsing mode. Firefox shows a shield icon at the left end of the location/address bar in case content is blocked by Tracking Protection, click the shield icon for more information.

You can disable this feature in "Options/Preferences -> Privacy & Security" or via the about:privatebrowsing page that get when you open a New Private Window.

  • Options/Preferences -> Privacy & Security: "Use Tracking Protection in Private Windows"

See the Web Console for more detail about what content is blocked.

Firefox 42+ has a Tracking Protection feature that is enabled by default in Private Browsing mode. Firefox shows a shield icon at the left end of the location/address bar in case content is blocked by Tracking Protection, click the shield icon for more information. You can disable this feature in "Options/Preferences -> Privacy & Security" or via the <b>about:privatebrowsing</b> page that get when you open a New Private Window. *Options/Preferences -> Privacy & Security: "Use Tracking Protection in Private Windows" *https://support.mozilla.org/en-US/kb/tracking-protection-firefox *https://support.mozilla.org/en-US/kb/control-center-site-privacy-and-security-firefox See the Web Console for more detail about what content is blocked. *"3-bar" menu button or Tools -> Web Developer *https://developer.mozilla.org/en/Tools/Web_Console

Umnikazi wombuzo

Pkshadow said

uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do : Reinstall with Current Release Firefox 59.0.2 with a Full Version Installer Please let us know if this solved your issue or if need further assistance.

This did not resolve the issue. No change in behavior.

''Pkshadow [[#answer-1094164|said]]'' <blockquote> uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do : *https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles *https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer Reinstall with Current Release Firefox 59.0.2 with a Full Version Installer *https://www.mozilla.org/firefox/all/ Please let us know if this solved your issue or if need further assistance. </blockquote> This did not resolve the issue. No change in behavior.
Shadow110 1072 izisombululo 14836 izimpendulo
Kuphostiwe

What happens when you run in Safe Mode as per Fred's instructions ??

What happens when you run in Safe Mode as per Fred's instructions ??

Isisombululo Esikhethiwe

Thanks for your help. Firefox updated when I restarted in Safe mode today, and the issue is resolved in both safe and standard mode. It is also working on other systems at the office.

Thanks for your help. Firefox updated when I restarted in Safe mode today, and the issue is resolved in both safe and standard mode. It is also working on other systems at the office.
westi2002 1 izisombululo 3 izimpendulo
Kuphostiwe

Tried both solutions. With Fred's solution it works in safe mode, but when switching to normal mode I still don't see the captcha box

Tried both solutions. With Fred's solution it works in safe mode, but when switching to normal mode I still don't see the captcha box
FredMcD
  • Top 10 Contributor
4306 izisombululo 60471 izimpendulo
Kuphostiwe

westi2002 It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

'''westi2002''' It could be the work of one of your add-ons, or it could be '''Hardware Acceleration. ''' ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link} Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control> ''(Mac=<Command>)'' <Shift> A) ''' In the Add-ons Manager, on the left, select '''Extensions. ''' Disable a few add-ons, then '''Restart Firefox. ''' Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All Of them. ''' If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group '''ONE AT A TIME''' (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.
cor-el
  • Top 10 Contributor
  • Moderator
17680 izisombululo 159944 izimpendulo
Kuphostiwe

Hi TechieJim

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (Adblock Plus, NoScript, , Discard, #Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block (wanted) content.

  • make sure your extensions and filters are updated to the latest version

You see the shield icon at the left end of the location/address bar in case content is blocked by Tracking Protection.

  • click the shield icon for more detail and possibly disable the protection
  • check the Web Console for more detail about what content is blocked by Tracking Protection
  • "3-bar" menu button or Tools -> Web Developer
Hi TechieJim If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (Adblock Plus, NoScript, , Discard, #Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block (wanted) content. *make sure your extensions and filters are updated to the latest version You see the shield icon at the left end of the location/address bar in case content is blocked by Tracking Protection. *click the shield icon for more detail and possibly disable the protection *check the Web Console for more detail about what content is blocked by Tracking Protection *"3-bar" menu button or Tools -> Web Developer *https://support.mozilla.org/en-US/kb/tracking-protection-firefox

Okulungisiwe ngu cor-el

westi2002 1 izisombululo 3 izimpendulo
Kuphostiwe

The problem maker was Ghostery. Added as trusted site, problem solved. Thanks for your help

The problem maker was Ghostery. Added as trusted site, problem solved. Thanks for your help
FredMcD
  • Top 10 Contributor
4306 izisombululo 60471 izimpendulo
Kuphostiwe

That was very good work. Well done.

That was very good work. Well done.
schaloule 2 izisombululo 7 izimpendulo
Kuphostiwe

I am on FF ESR 52.9 and since a few days I had problems with aliexpress logins and google captchas. Digging into my extensions I found that ghostery and randomagentspoofer cause the problem. Disabling either one of them did not help but disabling both and then restarting the browser brought things back to normal. Thus I think it is not mozilla to blame but possibly the extension providers. Ghostery was updated July 3rd but Randomagentspoofer is the same since 2016. So it could also be that the captcha programmers did change something in the background. In any case it is a constant struggle between users keeping their privacy and the advertising/tracking industry.

I am on FF ESR 52.9 and since a few days I had problems with aliexpress logins and google captchas. Digging into my extensions I found that ghostery and randomagentspoofer cause the problem. Disabling either one of them did not help but disabling both and then restarting the browser brought things back to normal. Thus I think it is not mozilla to blame but possibly the extension providers. Ghostery was updated July 3rd but Randomagentspoofer is the same since 2016. So it could also be that the captcha programmers did change something in the background. In any case it is a constant struggle between users keeping their privacy and the advertising/tracking industry.

Okulungisiwe ngu schaloule