X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Google voice not work with new update

Kuphostiwe

Google voice not opening with the new update, still spinning and don't work !!!

Google voice not opening with the new update, still spinning and don't work !!!

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.94 Safari/537.36

Eminye Imininingwane

simrick 1 izisombululo 14 izimpendulo
Kuphostiwe

jscher2000 said

Interesting! The Firefox equivalent of that "policy" is: (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste peer and pause while the list is filtered (3) Double-click the media.peerconnection.ice.proxy_only preference to switch the value from false to true If you make only that change (leave the media.peerconnection.enabled preference on true), does Firefox pass a WebRTC leak test and does Google Voice work?

Changing media.peerconnection.ice.proxy_only preference value from false to true allows Google Voice to load in the browser. How/wherefrom to run a WebRTC leak check for you?

''jscher2000 [[#answer-1095312|said]]'' <blockquote> Interesting! The Firefox equivalent of that "policy" is: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''peer''' and pause while the list is filtered (3) Double-click the '''media.peerconnection.ice.<u>proxy_only</u>''' preference to switch the value from false to true If you make only that change (leave the '''media.peerconnection.enabled''' preference on true), does Firefox pass a WebRTC leak test and does Google Voice work? </blockquote> Changing '''media.peerconnection.ice.<u>proxy_only</u>''' preference value from false to true allows Google Voice to load in the browser. How/wherefrom to run a WebRTC leak check for you?
jscher2000
  • Top 10 Contributor
8786 izisombululo 71864 izimpendulo
Kuphostiwe

simrick said

Changing media.peerconnection.ice.proxy_only preference value from false to true allows Google Voice to load in the browser. How/wherefrom to run a WebRTC leak check for you?

I think some VPN software makers offer a leak test page to demonstrate that their product is working. :-) But if not, there probably are many other test pages.

''simrick [[#answer-1096067|said]]'' <blockquote> Changing '''media.peerconnection.ice.<u>proxy_only</u>''' preference value from false to true allows Google Voice to load in the browser. How/wherefrom to run a WebRTC leak check for you? </blockquote> I think some VPN software makers offer a leak test page to demonstrate that their product is working. :-) But if not, there probably are many other test pages.
KenP1 0 izisombululo 9 izimpendulo
Kuphostiwe

Use ipleak.net to check webrtc leak

Use ipleak.net to check webrtc leak
simrick 1 izisombululo 14 izimpendulo
Kuphostiwe

ipleak.net says I'm good.

ipleak.net says I'm good.
simrick 1 izisombululo 14 izimpendulo
Kuphostiwe

I have submitted feedback through the GVoice page, and I suggest others do it as well.

I have submitted feedback through the GVoice page, and I suggest others do it as well.
jscher2000
  • Top 10 Contributor
8786 izisombululo 71864 izimpendulo
Kuphostiwe

So for now, for Firefox users, the guidance seems to be to adjust the settings as follows --

If you use a VPN and want to use Google Voice with minimum leak exposure:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste peer and pause while the list is filtered

(3) If the media.peerconnection.enabled preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true to allow WebRTC -- you'll restrict it in the next step

(4) Double-click the media.peerconnection.ice.proxy_only preference to switch the value from false to true -- this is equivalent to "disable_non_proxied_udp" which is the strictest setting, blocking WebRTC that does not come through your proxy (your VPN)

It is not guaranteed that GV will work with these settings; it may depend on your VPN.

So for now, for Firefox users, the guidance seems to be to adjust the settings as follows -- '''If you use a VPN and want to use Google Voice with minimum leak exposure:''' (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''peer''' and pause while the list is filtered (3) If the '''media.peerconnection.enabled''' preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true to allow WebRTC -- you'll restrict it in the next step (4) Double-click the '''media.peerconnection.ice.<u>proxy_only</u>''' preference to switch the value from false to true -- this is equivalent to "disable_non_proxied_udp" which is the strictest setting, blocking WebRTC that does not come through your proxy (your VPN) ''It is not guaranteed that GV will work with these settings; it may depend on your VPN.''
simrick 1 izisombululo 14 izimpendulo
Kuphostiwe

jscher2000 said

So for now, for Firefox users, the guidance seems to be to adjust the settings as follows -- If you use a VPN and want to use Google Voice with minimum leak exposure: (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste peer and pause while the list is filtered (3) If the media.peerconnection.enabled preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true to allow WebRTC -- you'll restrict it in the next step (4) Double-click the media.peerconnection.ice.proxy_only preference to switch the value from false to true -- this is equivalent to "disable_non_proxied_udp" which is the strictest setting, blocking WebRTC that does not come through your proxy (your VPN) It is not guaranteed that GV will work with these settings; it may depend on your VPN.

Cheers and thanks for the help.

''jscher2000 [[#answer-1096514|said]]'' <blockquote> So for now, for Firefox users, the guidance seems to be to adjust the settings as follows -- '''If you use a VPN and want to use Google Voice with minimum leak exposure:''' (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''peer''' and pause while the list is filtered (3) If the '''media.peerconnection.enabled''' preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true to allow WebRTC -- you'll restrict it in the next step (4) Double-click the '''media.peerconnection.ice.<u>proxy_only</u>''' preference to switch the value from false to true -- this is equivalent to "disable_non_proxied_udp" which is the strictest setting, blocking WebRTC that does not come through your proxy (your VPN) ''It is not guaranteed that GV will work with these settings; it may depend on your VPN.'' </blockquote> Cheers and thanks for the help.
KenP1 0 izisombululo 9 izimpendulo
Kuphostiwe

Great team work here. This is awesome. Ice proxy setting indeed is more stringent against leaking internal ip compared to media.peerconnection.enabled = false. Some of the geo restricted sites that could expose my location and didn't work, now do. Not to mention GV is working as well. That's why opera was working with geo restricted sites, but not FF. Now both do. Awesome.

Thank you all.

Great team work here. This is awesome. Ice proxy setting indeed is more stringent against leaking internal ip compared to media.peerconnection.enabled = false. Some of the geo restricted sites that could expose my location and didn't work, now do. Not to mention GV is working as well. That's why opera was working with geo restricted sites, but not FF. Now both do. Awesome. Thank you all.
ruggb 1 izisombululo 21 izimpendulo
Kuphostiwe

I have this issue also. FF 60.0.1 64bit disabling the Disable WebRTC extension fixes it - which enables WebRTC, right? any of my computers-desktop, Asus laptop, Dell Laptop, HP laptop FF in safe mode, delete PREFS.JS file, clean install FF -- nothing changes it. Chrome works fine but then it appears WebRTC is enabled and there is no way to disable it.

OK, so since my desktop doesn't use VPN, it isn't an issue. But I have a VPN on my laptops so the Disable WebRTC extension is useless there and if I use Chrome on the laptop the VPN is useless.

Sounds like a great plan Jason.

I have this issue also. FF 60.0.1 64bit disabling the '''Disable WebRTC''' extension fixes it - which enables WebRTC, right? any of my computers-desktop, Asus laptop, Dell Laptop, HP laptop FF in safe mode, delete PREFS.JS file, clean install FF -- nothing changes it. Chrome works fine but then it appears WebRTC is enabled and there is no way to disable it. OK, so since my desktop doesn't use VPN, it isn't an issue. But I have a VPN on my laptops so the Disable WebRTC extension is useless there and if I use Chrome on the laptop the VPN is useless. Sounds like a great plan Jason.
jscher2000
  • Top 10 Contributor
8786 izisombululo 71864 izimpendulo
Kuphostiwe

Hi ruggb, did you try this to minimize leakage while using your VPN:

https://support.mozilla.org/questions/1211377?page=2#answer-1096514

Repeating here:

So for now, for Firefox users, the guidance seems to be to adjust the settings as follows --

If you use a VPN and want to use Google Voice with minimum leak exposure:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste peer and pause while the list is filtered

(3) If the media.peerconnection.enabled preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true to allow WebRTC -- you'll restrict it in the next step

(4) Double-click the media.peerconnection.ice.proxy_only preference to switch the value from false to true -- this is equivalent to "disable_non_proxied_udp" which is the strictest setting, blocking WebRTC that does not come through your proxy (your VPN)

It is not guaranteed that GV will work with these settings; it may depend on your VPN.

Hi ruggb, did you try this to minimize leakage while using your VPN: https://support.mozilla.org/questions/1211377?page=2#answer-1096514 ''Repeating here:'' So for now, for Firefox users, the guidance seems to be to adjust the settings as follows -- '''If you use a VPN and want to use Google Voice with minimum leak exposure:''' (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''peer''' and pause while the list is filtered (3) If the '''media.peerconnection.enabled''' preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true to allow WebRTC -- you'll restrict it in the next step (4) Double-click the '''media.peerconnection.ice.<u>proxy_only</u>''' preference to switch the value from false to true -- this is equivalent to "disable_non_proxied_udp" which is the strictest setting, blocking WebRTC that does not come through your proxy (your VPN) ''It is not guaranteed that GV will work with these settings; it may depend on your VPN.''
ruggb 1 izisombululo 21 izimpendulo
Kuphostiwe

thanks J I don't have VPN on my desktop and it is not on on my laptops at home. Since WebRTC seems like such an issue, I disabled it with the FF extension. So by using the extension, I guess that changes the first item (3). But if I am not using a VPN, then I don't have a proxy so 4 will probably break something, right/wrong?

The issue is all the other Google app pages will open except GV. (at least the ones I tried). So why isn't it a Google problem?

thanks J I don't have VPN on my desktop and it is not on on my laptops at home. Since WebRTC seems like such an issue, I disabled it with the FF extension. So by using the extension, I guess that changes the first item (3). But if I am not using a VPN, then I don't have a proxy so 4 will probably break something, right/wrong? The issue is all the other Google app pages will open except GV. (at least the ones I tried). So why isn't it a Google problem?
jscher2000
  • Top 10 Contributor
8786 izisombululo 71864 izimpendulo
Kuphostiwe

Impendulo Ewusizo

ruggb said

The issue is all the other Google app pages will open except GV. (at least the ones I tried). So why isn't it a Google problem?

Google Voice uses WebRTC now, instead of a plugin. I'm sure there are other ways to implement it, but that is the current situation.

Since WebRTC seems like such an issue, I disabled it with the FF extension.

Well, it's an issue if you are using VPN to disguise your IP address for privacy reasons and you want to avoid any methods of bypassing the VPN that could blow your cover. If you aren't using a VPN, I'm not aware of an issue because you're already revealing your IP address to the site with every request.

''ruggb [[#answer-1119152|said]]'' <blockquote> The issue is all the other Google app pages will open except GV. (at least the ones I tried). So why isn't it a Google problem? </blockquote> Google Voice uses WebRTC now, instead of a plugin. I'm sure there are other ways to implement it, but that is the current situation. <blockquote> Since WebRTC seems like such an issue, I disabled it with the FF extension. </blockquote> Well, it's an issue if you are using VPN to disguise your IP address for privacy reasons and you want to avoid any methods of bypassing the VPN that could blow your cover. If you aren't using a VPN, I'm not aware of an issue because you're already revealing your IP address to the site with every request.
Upgeya 0 izisombululo 1 izimpendulo
Kuphostiwe

"Double-click the media.peerconnection.ice.proxy_only preference to switch the value from false to true. If you make only that change (leave the media.peerconnection.enabled preference on true), does Firefox pass a WebRTC leak test and does Google Voice work?"

I can confirm that this works!

I used two services to test: https://www.privacytools.io/webrtc.html https://diafygi.github.io/webrtc-ips/

"Double-click the media.peerconnection.ice.proxy_only preference to switch the value from false to true. If you make only that change (leave the media.peerconnection.enabled preference on true), does Firefox pass a WebRTC leak test and does Google Voice work?" I can confirm that this works! I used two services to test: https://www.privacytools.io/webrtc.html https://diafygi.github.io/webrtc-ips/