X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Google voice not work with new update

Kuphostiwe

Google voice not opening with the new update, still spinning and don't work !!!

Google voice not opening with the new update, still spinning and don't work !!!

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.94 Safari/537.36

Eminye Imininingwane

ikefer 1 izisombululo 4 izimpendulo
Kuphostiwe

I have the same problem. Running Win 10 fully updated and FF 59.0.2. Google Voice worked with FF 58. It works with Edge on the same machine.

I have the same problem. Running Win 10 fully updated and FF 59.0.2. Google Voice worked with FF 58. It works with Edge on the same machine.
KenP1 0 izisombululo 9 izimpendulo
Kuphostiwe

I have the same problem. Can't access google voice URL listed below

https://voice.google.com/u/0

I have tried 3 different machines and same outcome. 2 Win 7 Pro and 1 Win 10 Home. FireFox version 59.0.2. I also tried safe mode, but no luck. So not any add-on or extension issue.

I can access all other google pages.

I can access google voice via google chrome or opera browser.

Quite shocking that this has been addressed yet.

I have the same problem. Can't access google voice URL listed below https://voice.google.com/u/0 I have tried 3 different machines and same outcome. 2 Win 7 Pro and 1 Win 10 Home. FireFox version 59.0.2. I also tried safe mode, but no luck. So not any add-on or extension issue. I can access all other google pages. I can access google voice via google chrome or opera browser. Quite shocking that this has been addressed yet.
simrick 1 izisombululo 14 izimpendulo
Kuphostiwe

Same problem here. All others work except Voice. Just spins and spins and won't load.

Same problem here. All others work except Voice. Just spins and spins and won't load.
jscher2000
  • Top 10 Contributor
8695 izisombululo 71066 izimpendulo
Kuphostiwe

Hi All, I don't have a Google Voice number, as I was informed when accessing that link.

There are two recent threads (unsolved) on Google's forums. Would you mind chiming in there, or starting a new thread? Google's scripts are notoriously complex, so it's difficult for outsiders to solve browser compatibility issues:


If you did want to dig deeper, you could look for error messages in the Web Console. It's a panel you open in the lower part of the tab, and as you load pages, it accumulates messages. Many are unimportant, but some could provide useful information.

You can open the Web Console using either:

  • "3-bar" menu button > Web Developer > Web Console
  • (menu bar) Tools > Web Developer > Web Console
  • (Windows) Ctrl+Shift+k

Then return to the main Google Voice page (or reload the page) in the top part of the tab and see whether any messages appear.

Hi All, I don't have a Google Voice number, as I was informed when accessing that link. There are two recent threads (unsolved) on Google's forums. Would you mind chiming in there, or starting a new thread? Google's scripts are notoriously complex, so it's difficult for outsiders to solve browser compatibility issues: * [https://productforums.google.com/forum/#!topic/voice/6pAlxoo_83o Google Voice Page will not load in Firefox 59.0.1 on Mac OS] (March 27) * [https://productforums.google.com/forum/#!topic/voice/ZRZ41z2ydmk Firefox desktop stopped loading GV] (March 24) ---- If you did want to dig deeper, you could look for error messages in the Web Console. It's a panel you open in the lower part of the tab, and as you load pages, it accumulates messages. Many are unimportant, but some could provide useful information. You can open the Web Console using either: * "3-bar" menu button > Web Developer > Web Console * (menu bar) Tools > Web Developer > Web Console * (Windows) Ctrl+Shift+k Then return to the main Google Voice page (or reload the page) in the top part of the tab and see whether any messages appear.
simrick 1 izisombululo 14 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Here's what I get:

Content Security Policy: Ignoring “'unsafe-inline'” within script-src: ‘strict-dynamic’ specified Content Security Policy: Ignoring “https:” within script-src: ‘strict-dynamic’ specified Content Security Policy: Ignoring “http:” within script-src: ‘strict-dynamic’ specified Loading failed for the <script> with source “https://www.google-analytics.com/analytics.js”. signup:1 CSI/tbsd_ cb=gapi.loaded_0:336:127 CSI/_tbnd cb=gapi.loaded_0:336:127 TypeError: e.RTCPeerConnection is undefined[Learn More] rs=AJAOlGlVMPSvoUIMmdUMHS2uU9W5H1_N1w%20line%2072%20%3E%20eval:38:296502 Error: [$injector:modulerr] http://errors.angularjs.org/1.6.1/$injector/modulerr?p0=voice.App&p1=%5B%24injector%3Anomod%5D%20http%3A%2F%2Ferrors.angularjs.org%2F1.6.1%2F%24injector%2Fnomod%3Fp0%3Dvoice.App%0AM%2F%3C%40https%3A%2F%2Fajax.googleapis.com%2Fajax%2Flibs%2Fangularjs%2F1.6.1%2Fangular.min.js%3A6%3A425%0Ave%2F%3C%2F%3C%2F%3C%40https%3A%2F%2Fajax.googleapis.com%2Fajax%2Flibs%2Fangularjs%2F1.6.1%2Fangular.min.js%3A25%3A399%0Ab%40https%3A%2F%2Fajax.googleapis.com%2Fajax%2Flibs%2Fangularjs%2F1.6.1%2Fangular.min.js%3A24%3A439%0Ave%2F%3C%2F%3C%40https%3A%2F%2Fajax.googleapis.com%2Fajax%2Flibs%2Fangularjs%2F1.6.1%2Fangular.min.js%3A25%3A173%0Ag%2F%3C%40https%3A%2F%2Fajax.googleapis.com%2Fajax%2Flibs%2Fangularjs%2F1.6.1%2Fangular.min.js%3A41%3A117%0Aq%40https%3A%2F%2Fajax.googleapis.com%2Fajax%2Flibs%2Fangularjs%2F1.6.1%2Fangular.min.js%3A7%3A349%0Ag%40https%3A%2F%2Fajax.googleapis.com%2Fajax%2Flibs%2Fangularjs%2F1.6.1%2Fangular.min.js%3A40%3A488%0Aeb%40https%3A%2F%2Fajax.googleapis.com%2Fajax%2Flibs%2Fangularjs%2F1.6.1%2Fangular.min.js%3A45%3A56%0Ac%40https%3A%2F%2Fajax.googleapis.com%2Fajax%2Flibs%2Fangularjs%2F1.6.1%2Fangular.min.js%3A21%3A19%0AMc%40https%3A%2F%2Fajax.googleapis.com%2Fajax%2Flibs%2Fangularjs%2F1.6.1%2Fangular.min.js%3A21%3A332%0Ape%40https%3A%2F%2Fajax.googleapis.com%2Fajax%2Flibs%2Fangularjs%2F1.6.1%2Fangular.min.js%3A20%3A1%0A%40https%3A%2F%2Fajax.googleapis.com%2Fajax%2Flibs%2Fangularjs%2F1.6.1%2Fangular.min.js%3A329%3A117%0Ab%40https%3A%2F%2Fajax.googleapis.com%2Fajax%2Flibs%2Fangularjs%2F1.6.1%2Fangular.min.js%3A37%3A36%0A angular.js:38 Content Security Policy: Ignoring “'unsafe-inline'” within script-src: ‘strict-dynamic’ specified Content Security Policy: Ignoring “https:” within script-src: ‘strict-dynamic’ specified Content Security Policy: Ignoring “http:” within script-src: ‘strict-dynamic’ specified Error: Cannot set user agent for iframe with location different to this page content.js:150:17 Content Security Policy: Ignoring ‘x-frame-options’ because of ‘frame-ancestors’ directive. Content Security Policy: Ignoring “'unsafe-inline'” within script-src: ‘strict-dynamic’ specified Content Security Policy: Ignoring “https:” within script-src: ‘strict-dynamic’ specified Content Security Policy: Ignoring “http:” within script-src: ‘strict-dynamic’ specified Content Security Policy: The page’s settings blocked the loading of a resource at self (“script-src”). Source: ;!function(){var t=0,e=function(t,e){ret....

Here's what I get: Content Security Policy: Ignoring “'unsafe-inline'” within script-src: ‘strict-dynamic’ specified Content Security Policy: Ignoring “https:” within script-src: ‘strict-dynamic’ specified Content Security Policy: Ignoring “http:” within script-src: ‘strict-dynamic’ specified Loading failed for the <script> with source “https://www.google-analytics.com/analytics.js”. signup:1 CSI/tbsd_ cb=gapi.loaded_0:336:127 CSI/_tbnd cb=gapi.loaded_0:336:127 TypeError: e.RTCPeerConnection is undefined[Learn More] rs=AJAOlGlVMPSvoUIMmdUMHS2uU9W5H1_N1w%20line%2072%20%3E%20eval:38:296502 Error: [$injector:modulerr] http://errors.angularjs.org/1.6.1/$injector/modulerr?p0=voice.App&p1=%5B%24injector%3Anomod%5D%20http%3A%2F%2Ferrors.angularjs.org%2F1.6.1%2F%24injector%2Fnomod%3Fp0%3Dvoice.App%0AM%2F%3C%40https%3A%2F%2Fajax.googleapis.com%2Fajax%2Flibs%2Fangularjs%2F1.6.1%2Fangular.min.js%3A6%3A425%0Ave%2F%3C%2F%3C%2F%3C%40https%3A%2F%2Fajax.googleapis.com%2Fajax%2Flibs%2Fangularjs%2F1.6.1%2Fangular.min.js%3A25%3A399%0Ab%40https%3A%2F%2Fajax.googleapis.com%2Fajax%2Flibs%2Fangularjs%2F1.6.1%2Fangular.min.js%3A24%3A439%0Ave%2F%3C%2F%3C%40https%3A%2F%2Fajax.googleapis.com%2Fajax%2Flibs%2Fangularjs%2F1.6.1%2Fangular.min.js%3A25%3A173%0Ag%2F%3C%40https%3A%2F%2Fajax.googleapis.com%2Fajax%2Flibs%2Fangularjs%2F1.6.1%2Fangular.min.js%3A41%3A117%0Aq%40https%3A%2F%2Fajax.googleapis.com%2Fajax%2Flibs%2Fangularjs%2F1.6.1%2Fangular.min.js%3A7%3A349%0Ag%40https%3A%2F%2Fajax.googleapis.com%2Fajax%2Flibs%2Fangularjs%2F1.6.1%2Fangular.min.js%3A40%3A488%0Aeb%40https%3A%2F%2Fajax.googleapis.com%2Fajax%2Flibs%2Fangularjs%2F1.6.1%2Fangular.min.js%3A45%3A56%0Ac%40https%3A%2F%2Fajax.googleapis.com%2Fajax%2Flibs%2Fangularjs%2F1.6.1%2Fangular.min.js%3A21%3A19%0AMc%40https%3A%2F%2Fajax.googleapis.com%2Fajax%2Flibs%2Fangularjs%2F1.6.1%2Fangular.min.js%3A21%3A332%0Ape%40https%3A%2F%2Fajax.googleapis.com%2Fajax%2Flibs%2Fangularjs%2F1.6.1%2Fangular.min.js%3A20%3A1%0A%40https%3A%2F%2Fajax.googleapis.com%2Fajax%2Flibs%2Fangularjs%2F1.6.1%2Fangular.min.js%3A329%3A117%0Ab%40https%3A%2F%2Fajax.googleapis.com%2Fajax%2Flibs%2Fangularjs%2F1.6.1%2Fangular.min.js%3A37%3A36%0A angular.js:38 Content Security Policy: Ignoring “'unsafe-inline'” within script-src: ‘strict-dynamic’ specified Content Security Policy: Ignoring “https:” within script-src: ‘strict-dynamic’ specified Content Security Policy: Ignoring “http:” within script-src: ‘strict-dynamic’ specified Error: Cannot set user agent for iframe with location different to this page content.js:150:17 Content Security Policy: Ignoring ‘x-frame-options’ because of ‘frame-ancestors’ directive. Content Security Policy: Ignoring “'unsafe-inline'” within script-src: ‘strict-dynamic’ specified Content Security Policy: Ignoring “https:” within script-src: ‘strict-dynamic’ specified Content Security Policy: Ignoring “http:” within script-src: ‘strict-dynamic’ specified Content Security Policy: The page’s settings blocked the loading of a resource at self (“script-src”). Source: ;!function(){var t=0,e=function(t,e){ret....
jscher2000
  • Top 10 Contributor
8695 izisombululo 71066 izimpendulo
Kuphostiwe

Let's start here:

simrick said

TypeError: e.RTCPeerConnection is undefined[Learn More] rs=AJAOlGlVMPSvoUIMmdUMHS2uU9W5H1_N1w%20line%2072%20%3E%20eval:38:296502

Could you check your preferences to see if anything has been changes from its default value:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste peer and pause while the list is filtered

Firefox should display a long list of preferences starting with media.peerconnection which are related to "RTC" connections.

I know that media.peerconnection.enabled needs to be set to true, but I don't know about the others.

Anything modified there?


Regarding the CSP (Content Security Policy) errors, these could be associated with an extension that is blocking some content. If you are not running any content blocking extensions, then it could be a coding issue in the page itself. However, that probably would affect other browsers, too.

If you want to temporarily set Firefox not to enforce CSP rules -- meaning that even though the page instructed Firefox not to allow certain kind of foreign content, Firefox will allow it -- here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste csp and pause while the list is filtered

(3) Double-click the security.csp.enable preference to switch the value from true to false

I suggest switching back ASAP once you determine whether that makes any difference in using Google Voice.

Let's start here: ''simrick [[#answer-1094710|said]]'' <blockquote> TypeError: e.RTCPeerConnection is undefined[Learn More] rs=AJAOlGlVMPSvoUIMmdUMHS2uU9W5H1_N1w%20line%2072%20%3E%20eval:38:296502</blockquote> Could you check your preferences to see if anything has been changes from its default value: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''peer''' and pause while the list is filtered Firefox should display a long list of preferences starting with '''media.peerconnection''' which are related to "RTC" connections. I know that '''media.peerconnection.enabled''' needs to be set to true, but I don't know about the others. Anything modified there? ---- Regarding the CSP (Content Security Policy) errors, these could be associated with an extension that is blocking some content. If you are not running any content blocking extensions, then it could be a coding issue in the page itself. However, that probably would affect other browsers, too. If you want to temporarily set Firefox not to enforce CSP rules -- meaning that even though the page instructed Firefox not to allow certain kind of foreign content, Firefox will allow it -- here's how: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''csp''' and pause while the list is filtered (3) Double-click the '''security.csp.enable''' preference to switch the value from true to false I suggest switching back ASAP once you determine whether that makes any difference in using Google Voice.
simrick 1 izisombululo 14 izimpendulo
Kuphostiwe

Media.peerconnection.enabled is set to FALSE I believe this may have been done to prevent WebRTC leaks?

I am running Ublock Origin, HTTPS Everywhere, and Windscribe VPN (which I understand may have an adblocker in it).

I will turn all this off and see what I get. But again, all this was on, in the previous version and I had no problems.

Media.peerconnection.enabled is set to FALSE I believe this may have been done to prevent WebRTC leaks? I am running Ublock Origin, HTTPS Everywhere, and Windscribe VPN (which I understand may have an adblocker in it). I will turn all this off and see what I get. But again, all this was on, in the previous version and I had no problems.
simrick 1 izisombululo 14 izimpendulo
Kuphostiwe

Well, changing Media.peerconnection.enabled to TRUE solved it before I did anything else.

Thank you for your help. Now I think I have to wonder about WebRTC leaks....

Well, changing Media.peerconnection.enabled to '''TRUE '''solved it before I did anything else. Thank you for your help. Now I think I have to wonder about WebRTC leaks....
jscher2000
  • Top 10 Contributor
8695 izisombululo 71066 izimpendulo
Kuphostiwe

simrick said

Well, changing Media.peerconnection.enabled to TRUE solved it before I did anything else. Thank you for your help. Now I think I have to wonder about WebRTC leaks....

Do you use a VPN? I think there's a concern that WebRTC may bypass your VPN tunnel, revealing your true IP address.

Now that you know what's going on, you could bookmark about:config and toggle this setting as needed.

''simrick [[#answer-1094733|said]]'' <blockquote> Well, changing Media.peerconnection.enabled to '''TRUE '''solved it before I did anything else. Thank you for your help. Now I think I have to wonder about WebRTC leaks.... </blockquote> Do you use a VPN? I think there's a concern that WebRTC may bypass your VPN tunnel, revealing your true IP address. Now that you know what's going on, you could bookmark about:config and toggle this setting as needed.
simrick 1 izisombululo 14 izimpendulo
Kuphostiwe

Yes, I do use a VPN, and yes, there is a concern that WebRTC could leak my IP address - that's why I had changed the setting. Toggling that setting all day long is really not an option.

Yes, I do use a VPN, and yes, there is a concern that WebRTC could leak my IP address - that's why I had changed the setting. Toggling that setting all day long is really not an option.
jscher2000
  • Top 10 Contributor
8695 izisombululo 71066 izimpendulo
Kuphostiwe

simrick said

Yes, I do use a VPN, and yes, there is a concern that WebRTC could leak my IP address - that's why I had changed the setting. Toggling that setting all day long is really not an option.

Can you use Google Voice without WebRTC?

''simrick [[#answer-1094740|said]]'' <blockquote> Yes, I do use a VPN, and yes, there is a concern that WebRTC could leak my IP address - that's why I had changed the setting. Toggling that setting all day long is really not an option. </blockquote> Can you use Google Voice without WebRTC?
simrick 1 izisombululo 14 izimpendulo
Kuphostiwe

jscher2000 said

simrick said
Yes, I do use a VPN, and yes, there is a concern that WebRTC could leak my IP address - that's why I had changed the setting. Toggling that setting all day long is really not an option.

Can you use Google Voice without WebRTC?

Apparently not; not in FF anyway. Sorry, I guess I don't know enough about it. I didn't think I used it at all, but looks like GV does in some way?

''jscher2000 [[#answer-1094752|said]]'' <blockquote> ''simrick [[#answer-1094740|said]]'' <blockquote> Yes, I do use a VPN, and yes, there is a concern that WebRTC could leak my IP address - that's why I had changed the setting. Toggling that setting all day long is really not an option. </blockquote> Can you use Google Voice without WebRTC? </blockquote> Apparently not; not in FF anyway. Sorry, I guess I don't know enough about it. I didn't think I used it at all, but looks like GV does in some way?
KenP1 0 izisombululo 9 izimpendulo
Kuphostiwe

Good discussion guys. I also use VPN and have media.peerconnection.enabled to true to prevent private ip leak.

A couple of points.

This configuration was working with Google Voice URL till FF ver 59.x.

I have WebRTC leak prevention enabled in both Google Chrome and Opera and they work fine with Google Voice.

The above shows something else has changed either at Google Voice end or with FF.

Leaking private IP is not an acceptable workaround.

Thanks.

Good discussion guys. I also use VPN and have media.peerconnection.enabled to true to prevent private ip leak. A couple of points. This configuration was working with Google Voice URL till FF ver 59.x. I have WebRTC leak prevention enabled in both Google Chrome and Opera and they work fine with Google Voice. The above shows something else has changed either at Google Voice end or with FF. Leaking private IP is not an acceptable workaround. Thanks.
jscher2000
  • Top 10 Contributor
8695 izisombululo 71066 izimpendulo
Kuphostiwe

KenP1 said

I have WebRTC leak prevention enabled in both Google Chrome and Opera and they work fine with Google Voice.

Do you mean one of these Chrome extensions, or is it a built-in setting now?

These Firefox extensions seem similar:

I haven't tested any of those myself, but since they turn WebRTC on and off, I don't think sites that require WebRTC will work when it is disabled by an extension, any more than they work when it is disabled by hand.

''KenP1 [[#answer-1094829|said]]'' <blockquote> I have WebRTC leak prevention enabled in both Google Chrome and Opera and they work fine with Google Voice. </blockquote> Do you mean one of these Chrome extensions, or is it a built-in setting now? * [https://chrome.google.com/webstore/detail/webrtc-leak-prevent/eiadekoaikejlgdbkbdfeijglgfdalml?hl=en WebRTC Leak Prevent] * [https://chrome.google.com/webstore/detail/webrtc-leak-prevent-toggl/kignegkkmknfpincglcjggfbgghpamim?hl=en WebRTC Leak Prevent Toggle] These Firefox extensions seem similar: * [https://addons.mozilla.org/firefox/addon/happy-bonobo-disable-webrtc/ Disable WebRTC] * [https://addons.mozilla.org/firefox/addon/webrtc-leak-shield/ WebRTC Leak Shield] I haven't tested any of those myself, but since they turn WebRTC on and off, I don't think sites that require WebRTC will work when it is disabled by an extension, any more than they work when it is disabled by hand.
simrick 1 izisombululo 14 izimpendulo
Kuphostiwe

KenP1 said

Good discussion guys. I also use VPN and have media.peerconnection.enabled to true to prevent private ip leak. A couple of points. This configuration was working with Google Voice URL till FF ver 59.x. I have WebRTC leak prevention enabled in both Google Chrome and Opera and they work fine with Google Voice. The above shows something else has changed either at Google Voice end or with FF. Leaking private IP is not an acceptable workaround. Thanks.

I believe you need it changed to FALSE, to prevent the leak. See here:

https://www.purevpn.com/blog/disable-webrtc-in-chrome-and-firefox/

This change prevents the Google Voice web page from loading in FF. I don't use PureVPN, that's why I made the change in about:config.

''KenP1 [[#answer-1094829|said]]'' <blockquote> Good discussion guys. I also use VPN and have '''media.peerconnection.enabled to true to prevent private ip leak.''' A couple of points. This configuration was working with Google Voice URL till FF ver 59.x. I have WebRTC leak prevention enabled in both Google Chrome and Opera and they work fine with Google Voice. The above shows something else has changed either at Google Voice end or with FF. Leaking private IP is not an acceptable workaround. Thanks. </blockquote> I believe you need it changed to '''FALSE''', to prevent the leak. See here: https://www.purevpn.com/blog/disable-webrtc-in-chrome-and-firefox/ This change prevents the Google Voice web page from loading in FF. I don't use PureVPN, that's why I made the change in about:config.

Okulungisiwe ngu simrick

ikefer 1 izisombululo 4 izimpendulo
Kuphostiwe

Thank you all. Changing Media.peerconnection.enabled to TRUE fixed it. Lucky for me I do not use a VPN.

Thank you all. Changing Media.peerconnection.enabled to TRUE fixed it. Lucky for me I do not use a VPN.
KenP1 0 izisombululo 9 izimpendulo
Kuphostiwe

simrick said

KenP1 said
Good discussion guys. I also use VPN and have media.peerconnection.enabled to true to prevent private ip leak. A couple of points. This configuration was working with Google Voice URL till FF ver 59.x. I have WebRTC leak prevention enabled in both Google Chrome and Opera and they work fine with Google Voice. The above shows something else has changed either at Google Voice end or with FF. Leaking private IP is not an acceptable workaround. Thanks.

I believe you need it changed to FALSE, to prevent the leak. See here:

https://www.purevpn.com/blog/disable-webrtc-in-chrome-and-firefox/

This change prevents the Google Voice web page from loading in FF. I don't use PureVPN, that's why I made the change in about:config.

I stand corrected. True means WebRTC leak. I have it set to false.

Still don't know what broke it in version 59.x

''simrick [[#answer-1094900|said]]'' <blockquote> ''KenP1 [[#answer-1094829|said]]'' <blockquote> Good discussion guys. I also use VPN and have '''media.peerconnection.enabled to true to prevent private ip leak.''' A couple of points. This configuration was working with Google Voice URL till FF ver 59.x. I have WebRTC leak prevention enabled in both Google Chrome and Opera and they work fine with Google Voice. The above shows something else has changed either at Google Voice end or with FF. Leaking private IP is not an acceptable workaround. Thanks. </blockquote> I believe you need it changed to '''FALSE''', to prevent the leak. See here: https://www.purevpn.com/blog/disable-webrtc-in-chrome-and-firefox/ This change prevents the Google Voice web page from loading in FF. I don't use PureVPN, that's why I made the change in about:config. </blockquote> I stand corrected. True means WebRTC leak. I have it set to false. Still don't know what broke it in version 59.x

Okulungisiwe ngu KenP1

KenP1 0 izisombululo 9 izimpendulo
Kuphostiwe

jscher2000 said

KenP1 said
I have WebRTC leak prevention enabled in both Google Chrome and Opera and they work fine with Google Voice.

Do you mean one of these Chrome extensions, or is it a built-in setting now?

These Firefox extensions seem similar:

I haven't tested any of those myself, but since they turn WebRTC on and off, I don't think sites that require WebRTC will work when it is disabled by an extension, any more than they work when it is disabled by hand.

For Google Chrome

https://chrome.google.com/webstore/detail/webrtc-network-limiter (WebRTC Network Limiter extension)

For Opera

"Settings". Select "Show advanced settings" and click on "Privacy & security". At "WebRTC" mark select "Disable non-proxied UDP".

''jscher2000 [[#answer-1094852|said]]'' <blockquote> ''KenP1 [[#answer-1094829|said]]'' <blockquote> I have WebRTC leak prevention enabled in both Google Chrome and Opera and they work fine with Google Voice. </blockquote> Do you mean one of these Chrome extensions, or is it a built-in setting now? * [https://chrome.google.com/webstore/detail/webrtc-leak-prevent/eiadekoaikejlgdbkbdfeijglgfdalml?hl=en WebRTC Leak Prevent] * [https://chrome.google.com/webstore/detail/webrtc-leak-prevent-toggl/kignegkkmknfpincglcjggfbgghpamim?hl=en WebRTC Leak Prevent Toggle] These Firefox extensions seem similar: * [https://addons.mozilla.org/firefox/addon/happy-bonobo-disable-webrtc/ Disable WebRTC] * [https://addons.mozilla.org/firefox/addon/webrtc-leak-shield/ WebRTC Leak Shield] I haven't tested any of those myself, but since they turn WebRTC on and off, I don't think sites that require WebRTC will work when it is disabled by an extension, any more than they work when it is disabled by hand. </blockquote> For Google Chrome https://chrome.google.com/webstore/detail/webrtc-network-limiter (WebRTC Network Limiter extension) For Opera "Settings". Select "Show advanced settings" and click on "Privacy & security". At "WebRTC" mark select "Disable non-proxied UDP".
jscher2000
  • Top 10 Contributor
8695 izisombululo 71066 izimpendulo
Kuphostiwe

KenP1 said

For Opera

"Settings". Select "Show advanced settings" and click on "Privacy & security". At "WebRTC" mark select "Disable non-proxied UDP".

Interesting! The Firefox equivalent of that "policy" is:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste peer and pause while the list is filtered

(3) Double-click the media.peerconnection.ice.proxy_only preference to switch the value from false to true

If you make only that change (leave the media.peerconnection.enabled preference on true), does Firefox pass a WebRTC leak test and does Google Voice work?


For reference, extensions can select among four different WebRTC IP handling policies, corresponding to these preferences in about:config. The "Expected Effect" is quoted from: https://github.com/aghorler/WebRTC-Leak-Prevent/blob/master/DOCUMENTATION.md, since I didn't see official documentation:

  • "disable_non_proxied_udp":
    • media.peerconnection.ice.default_address_only => false
    • media.peerconnection.ice.no_host => false
    • media.peerconnection.ice.proxy_only => true
    • Expected Effect: "Force the use of a proxy, and only allow WebRTC traffic over UDP proxies. This will effectively disable WebRTC communication for most users (depending on UDP proxy usage)."
  • "default_public_interface_only":
    • media.peerconnection.ice.default_address_only => true
    • media.peerconnection.ice.no_host => true
    • media.peerconnection.ice.proxy_only => false
    • Expected Effect: "Send WebRTC traffic via the default public network adapter to the Internet. This will be the VPN adapter for system-VPN users."
  • "default_public_and_private_interfaces":
    • media.peerconnection.ice.default_address_only => true
    • media.peerconnection.ice.no_host => false
    • media.peerconnection.ice.proxy_only => false
    • Expected Effect: "Same as above, except allow WebRTC traffic through the default private interface to your local network as well."
  • "default"
    • media.peerconnection.ice.default_address_only => false
    • media.peerconnection.ice.no_host => false
    • media.peerconnection.ice.proxy_only => false
''KenP1 [[#answer-1095204|said]]'' <blockquote> For Opera<br><br>"Settings". Select "Show advanced settings" and click on "Privacy & security". At "WebRTC" mark select "Disable non-proxied UDP". </blockquote> Interesting! The Firefox equivalent of that "policy" is: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''peer''' and pause while the list is filtered (3) Double-click the '''media.peerconnection.ice.<u>proxy_only</u>''' preference to switch the value from false to true If you make only that change (leave the '''media.peerconnection.enabled''' preference on true), does Firefox pass a WebRTC leak test and does Google Voice work? ---- For reference, extensions can select among four different WebRTC IP handling policies, corresponding to these preferences in about:config. The "Expected Effect" is quoted from: https://github.com/aghorler/WebRTC-Leak-Prevent/blob/master/DOCUMENTATION.md, since I didn't see official documentation: * "disable_non_proxied_udp": ** media.peerconnection.ice.default_address_only => false ** media.peerconnection.ice.no_host => false ** media.peerconnection.ice.proxy_only => '''true''' ** ''Expected Effect:'' "Force the use of a proxy, and only allow WebRTC traffic over UDP proxies. This will effectively disable WebRTC communication for most users (depending on UDP proxy usage)." * "default_public_interface_only": ** media.peerconnection.ice.default_address_only => '''true''' ** media.peerconnection.ice.no_host => '''true''' ** media.peerconnection.ice.proxy_only => false ** ''Expected Effect:'' "Send WebRTC traffic via the default public network adapter to the Internet. This will be the VPN adapter for system-VPN users." * "default_public_and_private_interfaces": ** media.peerconnection.ice.default_address_only => '''true''' ** media.peerconnection.ice.no_host => false ** media.peerconnection.ice.proxy_only => false ** ''Expected Effect:'' "Same as above, except allow WebRTC traffic through the default private interface to your local network as well." * "default" ** media.peerconnection.ice.default_address_only => false ** media.peerconnection.ice.no_host => false ** media.peerconnection.ice.proxy_only => false
jscher2000
  • Top 10 Contributor
8695 izisombululo 71066 izimpendulo
Kuphostiwe

It looks like there is work under way to "standardize" what WebRTC applications are supposed to do:

Perhaps not surprisingly its authors are affiliated with Google and Facebook...

It looks like there is work under way to "standardize" what WebRTC applications are supposed to do: * Doc: https://tools.ietf.org/id/draft-ietf-rtcweb-ip-handling-06.html * Status: https://datatracker.ietf.org/doc/draft-ietf-rtcweb-ip-handling/ Perhaps not surprisingly its authors are affiliated with Google and Facebook...