X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

mail merge fail

Kuphostiwe

I'm trying to mail merge a CSV file from Excel with TB. I've done this before but I'm using a different (newer) version of Excel and I keep getting an error message (see attachment)

thanks,

I'm trying to mail merge a CSV file from Excel with TB. I've done this before but I'm using a different (newer) version of Excel and I keep getting an error message (see attachment) thanks,
Ama-screenshot ananyekiwe

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0

Eminye Imininingwane

Zenos 2265 izisombululo 12258 izimpendulo
Kuphostiwe

ISTR there is an issue with Excel's CSV files not being written in utf-8/unicode compatible format.

If you have an editor such as Notepad++, you can open your CSV file and re-save it, forcing it to be saved as utf-8.

ISTR there is an issue with Excel's CSV files not being written in utf-8/unicode compatible format. If you have an editor such as Notepad++, you can open your CSV file and re-save it, forcing it to be saved as utf-8.

Umnikazi wombuzo

I tried what you suggested but got the same error. Excel has a couple of version of CSV files. There is the plain .csv, there's a csv file for ms-dos, and another that is a text .csv file I've tried all three with TB but no luck so far...

I tried what you suggested but got the same error. Excel has a couple of version of CSV files. There is the plain .csv, there's a csv file for ms-dos, and another that is a text .csv file I've tried all three with TB but no luck so far...
Matt
  • Top 10 Contributor
  • Moderator
3234 izisombululo 22202 izimpendulo
Kuphostiwe

Fajita_shorty said

I tried what you suggested but got the same error. Excel has a couple of version of CSV files. There is the plain .csv, there's a csv file for ms-dos, and another that is a text .csv file I've tried all three with TB but no luck so far...

And they are all ancient non Unicode formats. Basically desktop Excel is still in the 20th century in regard to text formats and handling. The Free libreoffice does the job without you needing a master in windows text handling.

However the error I see is at line 344 is it your CSV or the add-on, I have no idea. I would suggest you look in your CSV file for a row of empty commas. Perhaps at the end.

''Fajita_shorty [[#answer-1093664|said]]'' <blockquote> I tried what you suggested but got the same error. Excel has a couple of version of CSV files. There is the plain .csv, there's a csv file for ms-dos, and another that is a text .csv file I've tried all three with TB but no luck so far... </blockquote> And they are all ancient non Unicode formats. Basically desktop Excel is still in the 20th century in regard to text formats and handling. The Free libreoffice does the job without you needing a master in windows text handling. However the error I see is at line 344 is it your CSV or the add-on, I have no idea. I would suggest you look in your CSV file for a row of empty commas. Perhaps at the end.

Umnikazi wombuzo

I've downloaded Libreoffice but not sure how to use it in this context. I can open the excel spreadsheet in Libre but there seems no way to save the spreadsheet as a CSV file. Please see attachment.

thanks

I've downloaded Libreoffice but not sure how to use it in this context. I can open the excel spreadsheet in Libre but there seems no way to save the spreadsheet as a CSV file. Please see attachment. thanks
Zenos 2265 izisombululo 12258 izimpendulo
Kuphostiwe

Notepad++ might have been easier and quicker.

File|Save As then choose Text CSV (.csv) from the file type drop-down list.

As part of the save/export process, you will be shown a dialogue box that allows you to select the encoding.

Notepad++ might have been easier and quicker. '''File|Save As''' then choose '''Text CSV (.csv)''' from the ''file type'' drop-down list. As part of the save/export process, you will be shown a dialogue box that allows you to select the encoding.

Umnikazi wombuzo

So I've done as you suggested but the mail merge isn't working. No error message this time, TB looks like it's about to do the merge and then it suddenly shuts down...

So I've done as you suggested but the mail merge isn't working. No error message this time, TB looks like it's about to do the merge and then it suddenly shuts down...
Zenos 2265 izisombululo 12258 izimpendulo
Kuphostiwe

Following on from Matt's observation, did you find any empty lines in the CSV file? Or rows of commas?

For this task, I'd look at it in a text editor rather than a spreadsheet. Again, Notepad++ would be my choice.

https://notepad-plus-plus.org/download/v7.5.6.html

Following on from Matt's observation, did you find any empty lines in the CSV file? Or rows of commas? For this task, I'd look at it in a text editor rather than a spreadsheet. Again, Notepad++ would be my choice. https://notepad-plus-plus.org/download/v7.5.6.html
Toad-Hall
  • Top 10 Contributor
1739 izisombululo 11627 izimpendulo
Kuphostiwe

open in excel If there are no blank lines, even at the end, then please check to see if there is a blank field.

Maybe one of the entries is missing an email address or part of name.

open in excel If there are no blank lines, even at the end, then please check to see if there is a blank field. Maybe one of the entries is missing an email address or part of name.
Toad-Hall
  • Top 10 Contributor
1739 izisombululo 11627 izimpendulo
Kuphostiwe

senario: If you have three column headers: 'First Name', 'Last Name', 'Email'

These column headers must match those used in the template.

If you have four contacts, but number three is missing 'First Name' or number four is missing the email address then error will occur. Or even if you have copy pasted some email addresses and they have a hidden blank space at the start or end of the email address, this can also cause error.

senario: If you have three column headers: 'First Name', 'Last Name', 'Email' These column headers must match those used in the template. If you have four contacts, but number three is missing 'First Name' or number four is missing the email address then error will occur. Or even if you have copy pasted some email addresses and they have a hidden blank space at the start or end of the email address, this can also cause error.

Impendulo Ewusizo

Still not working. Do I have the settings right in Libreoffice? (See attachment.)

There are no blank spaces or cells in the excel spreadsheet. I've done this kind of merge before and am baffled why it isn't working now. I could send you a sample of the TB template and a piece of the excel sheet I'm working from.

Still not working. Do I have the settings right in Libreoffice? (See attachment.) There are no blank spaces or cells in the excel spreadsheet. I've done this kind of merge before and am baffled why it isn't working now. I could send you a sample of the TB template and a piece of the excel sheet I'm working from.

Umnikazi wombuzo

Still not working. Do I have the settings right in Libreoffice? (See attachment from my last email.)

There are no blank spaces or cells in the excel spreadsheet. I've done this kind of merge before and am baffled why it isn't working now. I could send you a sample of the TB template and a piece of the excel sheet I'm working from.

Still not working. Do I have the settings right in Libreoffice? (See attachment from my last email.) There are no blank spaces or cells in the excel spreadsheet. I've done this kind of merge before and am baffled why it isn't working now. I could send you a sample of the TB template and a piece of the excel sheet I'm working from.
Matt
  • Top 10 Contributor
  • Moderator
3234 izisombululo 22202 izimpendulo
Kuphostiwe

sure, send it to unicorn dot consulting at gmail dot com

Best if you send all the spreadsheet if you can.

sure, send it to unicorn dot consulting at gmail dot com Best if you send all the spreadsheet if you can.

Umnikazi wombuzo

Hi Matt, I sent you an email with my info but did not hear back. Did you get my email?

Meantime I created a small simple spread sheet with just two entries and tried to merge with that but no luck there either.

thanks,

Hi Matt, I sent you an email with my info but did not hear back. Did you get my email? Meantime I created a small simple spread sheet with just two entries and tried to merge with that but no luck there either. thanks,
Toad-Hall
  • Top 10 Contributor
1739 izisombululo 11627 izimpendulo
Kuphostiwe

When you set up the .csv file and use mail merge, do you use the settings as shown in image. Note the field and text delimiters.

Additional....Useful info: https://support.office.com/en-us/article/import-or-export-text-txt-or-csv-files-5250ac4c-663c-47ce-937b-339e391393ba

When you set up the .csv file and use mail merge, do you use the settings as shown in image. Note the field and text delimiters. Additional....Useful info: https://support.office.com/en-us/article/import-or-export-text-txt-or-csv-files-5250ac4c-663c-47ce-937b-339e391393ba

Okulungisiwe ngu Toad-Hall

Umnikazi wombuzo

Looks like your Mail merge menu has a "Format" field where none exists on mine. Apart from that they are the same.

Looks like your Mail merge menu has a "Format" field where none exists on mine. Apart from that they are the same.
Toad-Hall
  • Top 10 Contributor
1739 izisombululo 11627 izimpendulo
Kuphostiwe

If using Windows 10. This is where you can set up the default.

  • Control Panel > ‘Clock, Language, and Region’ link
  • Click on the ‘Region’ link
  • Click on the ‘Additional settings’ button
  • Under ‘List separator’ enter the character you want to use as a delimiter
  • By default it is usually a comma, so make sure the 'comma' is selected.
  • then click on all the 'OK' s


How did you create the .csv file ? Originally I presume you had opened Excel and inserted the data. Did you export an address book in Thunderbird in .csv format and then opened it using Excel? Did you copy and paste any eg: contacts details/email addresses into the Excel document from eg: Outlook, MSWord document or another source ? If you did copy/paste any email address/contact etc, then these are the contacts you need to check. Copy pasting can include hidden formatting and this maybe causing the issue.

If using Windows 10. This is where you can set up the default. * Control Panel > ‘Clock, Language, and Region’ link * Click on the ‘Region’ link * Click on the ‘Additional settings’ button * Under ‘List separator’ enter the character you want to use as a delimiter * By default it is usually a comma, so make sure the 'comma' is selected. * then click on all the 'OK' s How did you create the .csv file ? Originally I presume you had opened Excel and inserted the data. Did you export an address book in Thunderbird in .csv format and then opened it using Excel? Did you copy and paste any eg: contacts details/email addresses into the Excel document from eg: Outlook, MSWord document or another source ? If you did copy/paste any email address/contact etc, then these are the contacts you need to check. Copy pasting can include hidden formatting and this maybe causing the issue.

Umnikazi wombuzo

Hi

I did as you suggested, and in fact the comma was the item under 'list separator.'

'How did you create the .csv file ? '

I made it from an excel spreadsheet.

'Originally I presume you had opened Excel and inserted the data. Did you export an address book in Thunderbird in .csv format and then opened it using Excel?'

No, I didn't open excel and insert data, but rather I received the excel sheet from a friend.

Did you copy and paste any eg: contacts details/email addresses into the Excel document from eg: Outlook, MSWord document or another source ?

That is possible, I don't know as the spreadsheet didn't originate with me.

If you did copy/paste any email address/contact etc, then these are the contacts you need to check. Copy pasting can include hidden formatting and this maybe causing the issue.

Could be. Is there a way to 'cleanse' the data so it loses its hidden formatting?

thanks

Hi I did as you suggested, and in fact the comma was the item under 'list separator.' 'How did you create the .csv file ? ' I made it from an excel spreadsheet. 'Originally I presume you had opened Excel and inserted the data. Did you export an address book in Thunderbird in .csv format and then opened it using Excel?' No, I didn't open excel and insert data, but rather I received the excel sheet from a friend. Did you copy and paste any eg: contacts details/email addresses into the Excel document from eg: Outlook, MSWord document or another source ? That is possible, I don't know as the spreadsheet didn't originate with me. If you did copy/paste any email address/contact etc, then these are the contacts you need to check. Copy pasting can include hidden formatting and this maybe causing the issue. Could be. Is there a way to 'cleanse' the data so it loses its hidden formatting? thanks
Matt
  • Top 10 Contributor
  • Moderator
3234 izisombululo 22202 izimpendulo
Kuphostiwe

I see a lot of talk about this excel sheet. A CSV file is not an excel sheet, and opening one in excel can change the text encoding used. This is an issue folk commonly encounter when importing CSV contacts into Thunderbird. Excel only writes ANSI and windows and Thunderbird and mail generally has used unicode for more than a decade now.

I have send you a couple of new revision of the file you sent. One that actually wraps text in quotes and one that removes the commas in the file data so the CSV parser in the add-on can not b confused about perhaps starting a new data item in the middle of a name with a comma.

Do either of them work?

I see a lot of talk about this excel sheet. A CSV file is not an excel sheet, and opening one in excel can change the text encoding used. This is an issue folk commonly encounter when importing CSV contacts into Thunderbird. Excel only writes ANSI and windows and Thunderbird and mail generally has used unicode for more than a decade now. I have send you a couple of new revision of the file you sent. One that actually wraps text in quotes and one that removes the commas in the file data so the CSV parser in the add-on can not b confused about perhaps starting a new data item in the middle of a name with a comma. Do either of them work?