Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Possibly Quantum? Issues with Discord Voice Chat and Viz streaming that disappear on other browsers... Anyone else experiencing this?

  • 21 uphendule
  • 1 inale nkinga
  • Igcine ukuphendulwa ngu ModernArt

more options

Hi all! I am experiencing some issues after I upgraded to Quantum, and I'm hoping that maybe you all have some idea of how to fix the issue because I don't want to have to switch browsers (so far the only fix I have).

First, I keep trying to stream episodes off Viz/Hulu, and it keeps giving me an error that tells me to turn off my Ad Block and refresh. I don't have Ad Block enabled, but when I refresh I get the same error. The error disappears in Google Chrome and Microsoft Edge, where I do have Ad Block or similar enabled.

The next issue I have encountered is with Discord. I tried to join a voice chat session, but could not hear anyone's voice, though they could hear mine fine. Again, this issue disappeared in Chrome and Edge.

I really don't want to have to switch browsers, because I love Firefox, but I just need to know if this is a Quantum problem and if I need to revert back to an older version of firefox.

All Replies (20)

more options

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

This half solves the problem - ie, with VIZ/Hulu, but not with Discord. Which is baffling, because I was operating that it might stem from the same issue.

more options

ModernArt2012 said

This half solves the problem - ie, with VIZ/Hulu,

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

but not with Discord

Please provide public link(s) (no password) that we can check out. No Personal Information Please !

more options

I've tried the hardware acceleration disabling, and that didn't work; similar with the add-ons/ extension (I only have the Ad Block Plus extension/addon added, and attempting to try Voice Chat without it didn't garner any results.)

I'm not sure there is any way to test the Discord issue without having a Discord account (it's not open source), and even then there's no way to demonstrate the issue without having me and another person attempting to voice chat in real time with me unable to hear and them getting all my sound without issue.

Thank you so much for your help, but I think I'm just going to chalk it up to Quantum and use an older version of Firefox.

more options
more options

Thank you for the suggestion, I tried that as well as attempting to get other troubleshooting help from the Discord team before coming here.

more options

If you decide to downgrade; First, Type about:preferences#advanced<enter> in the address bar. Under Advanced, Select Update.

[v56+] Type about:preferences#general<enter> in the address bar. Select Update.

Select Never Check For Updates.

Also turn off Use a background service to install updates <Windows Only>

Install Older Version Of Firefox {web link} Be sure to read everything here.

If you still want to downgrade, look under; I still want to downgrade. Click the Directory of other versions and languages link. Look for the directory of the version that you want. But, remember that old versions may have security issues.

You should also check out Firefox; Extended Support Release {web link} ESR Notes System Requirements

more options

'Just went over quite a few threads on the subject, and at one point I saw the advice (from Discord) to contact them and explain the problem via this email address :

But you probably already tried that ......

more options

I did try that already @Happy112, and unfortunately their fix is that "Well, I guess it doesn't work on Quantum ¯\_(ツ)_/¯".

And thanks @FredMcD, I'll look into that.

more options

Hi, you have Adblock Plus installed, go to Add-ons and disable it. as site said.

more options

Thank you, I know I have it installed, but I did disable it for all tests, and for all use of certain sites.

more options
more options

Load the web page. After the page is loaded, click the AdBlock icon. Now select Disable on <website>. Reload the page.

more options

Sir, with all due respect, I assure you I have tried that. Repeatedly. 9/10 most people's problems with streaming services might be solved by reminding them to disable Ad Block, but I have tried and failed on that route. I have even completely removed the extension and tried.

more options
more options

I made a new profile and tested it - there was no change. As it stands, I've given up on continuing to use the browser and merely downloaded the app to my phone in order to circumvent the issue. Is it more cumbersome? Yes. But it is a working fix.

Thank you for the suggestion though.

more options

Welcome. Sorry not able to come up with a answer for you.

more options

Thank you again for trying.

more options

I have same issue with Discord I cant hear anyone at all this is 59.0.2 already tried a clean profile aand that didnt fix it. yet all the discord sound work.

Im thinking it might be issue with firefox quantum? last time I use Discord webclient, was over 2 months ago I could hear people just fine. No audio driver has been change on my system or setting for that matter since i put this system together, only thing that change it Firefox.

I download the app to phone, and that works but that has it own issues, I despise Discord which why i didnt want it program and only use web client but now that dont even work.

IE/Edge dont work with Discord they both say browser not supported. I have opened ticket with discord support about this.

Okulungisiwe ngu tsunami2311

more options

this is what i the email from discord support told me

Gerard (Discord)

Apr 3, 12:10 PDT Hi ,

I'm so sorry for the inconvenience!

I checked with the team and currently, they are aware of this issue with FireFox v59, and they're working on a fix for this in a future update! I sadly don't have an exact ETA for when a solution will be available, so I'm so sorry for all the inconvenience and hassle.

Our engineers advised that you can rollback your FireFox browser to an earlier version (58) or use Google Chrome.

In the meantime though, please let me know if you have any questions or need anything else!

Sincerely, Gerard‍

Check out our Twitter for updates regarding Discord!

Okulungisiwe ngu tsunami2311

  1. 1
  2. 2