Search Support

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Why does Firefox not play the videos posted on the Comcast XFinity website?

  • 5 uphendule
  • 1 inale nkinga
  • 1 view
  • Igcine ukuphendulwa ngu Shadow110

more options

I am running Firefox 59.0.1 with Windows 10 Home Version 1709 (OS Build 16299.309), with the Windows Media Feature Pack, and Adobe Flash 29. When I go to https://my.Xfinity.com and try to play the videos they have posted there, Firefox will not play them at all. Internet Explorer and Google Chrome will play them; Firefox is the only browser that will not play them. The Microsoft support website is telling me that my version of Windows is up to date, and there are no updates available to correct my problem.

All Replies (5)

more options

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

Thank you for the quick response. I started Firefox in Safe Mode; the videos play, and Firefox is telling me to disable the add-ons to continue troubleshooting; I do not have any add-ons running. I have Norton Safe Search and Norton Safe Web installed (they are currently disabled); I also have installed Open H264 Video Codec provided by Cisco, Adobe Shockwave Flash, and Widevine Content Decryption Module provided by Google. These 5 are currently disabled, but the videos still do not play.

more options

Please see if this is your issue : there appears to be an issue that only affects users who have turned off Cleartype Font rendering within their Windows Settings. So a workaround for the moment would either be to turn Cleartype back on or disabling hardware acceleration in Firefox: https://support.mozilla.org/en-US/kb/performance-settings

You need the H264 and Wildevine enabled.

Please let us know if this solved your issue or if need further assistance.

more options

Thank you for the quick response. I enabled the H264 Codec and Wildvine; then, I unchecked the recommended performance settings box, and also the hardware acceleration box. None of those changes have helped. I have never done anything with Cleartype Font rendering; I have no idea where to go to find it, or what to do if I do find it. One thing I did discover: the ads and videos on NBC, CNBC, etc., play correctly.

more options

Please re-enable the Performance settings as that has nothing to do with the issue you are having. It would be best to turn on Hardware Acceleration as that is for your Video Card and movies will like that.

https://www.howtogeek.com/howto/28790/tweak-cleartype-in-windows-7/ Open Settings in Win 10 then type in the Search Bar Cleartype and before you are finished the link is there. Go and run it. The Quick Brown Fox Jumped..........

https://www.xfinity.com/search#q=Firefox Do you run with a Proxy ? Switch back as not compatible. If you are not having a issue with NBC, CNBC then it is a Xinfinty issue only and probably not a Firefox issue at all.

Try to trouble shoot this with them.