X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How do I stop FF updating? FF 58 works on this machine, FF 59 doesn't.

Kuphostiwe

FF 59 doesn't display some pages properly and is unusable. It has been the subject of other questions. As far as I can tell, this has not been fixed yest. I have tried FF 60 beta and this doesn't work either. I've turned off updating but it still downloads and updates when I restart.

As an aside to the FF 59 problem, this machine (a very basic 64-bit Acer netbook that is supposed to run Win10) has problems, but an older 32-bit Tosh (that isn't supposed to support Win10at all, but does) works fine with FF59.

As another aside to updates, I have an even older Compaq that cannot run greater than FF 48 (don't ask!) and it never tries to update, so I know that it is possible to fix. What do I need to do?

FF 59 doesn't display some pages properly and is unusable. It has been the subject of other questions. As far as I can tell, this has not been fixed yest. I have tried FF 60 beta and this doesn't work either. I've turned off updating but it still downloads and updates when I restart. As an aside to the FF 59 problem, this machine (a very basic 64-bit Acer netbook that is supposed to run Win10) has problems, but an older 32-bit Tosh (that isn't supposed to support Win10at all, but does) works fine with FF59. As another aside to updates, I have an even older Compaq that cannot run greater than FF 48 (don't ask!) and it never tries to update, so I know that it is possible to fix. What do I need to do?

Isisombululo esikhethiwe

Yep. Changing the zoom works. Anything other than 100% displays fine. I'd read about disabling TTF but I didn't want to do this as sooner or later I'd bet that an MS update would re-enable them and then I'd have to remember what I did. It would also probably screw up something else.

I tried adjusting the performance settings. With both boxes unchecked it works fine. It also works if I just enable the "use h/w acceleration" box but if I set it to use the recommended settings, it doesn't display properly on 100% zoom.

I don't know if it helps but the machine I'm having trouble with is a cheap'n'cheerful Acer V3-112P. It claims to have an Intel Celeron N2840 @ 2.16GHz, 4GB of RAM, and an Intel HD Graphics device 8086-0F31. To add insult to injury I dragged out an ancient HP dv2000 which was having trouble running Win Vista. I loaded Win7, upped the RAM to 2G and it runs FF 59 perfectly.

Thanks for your help. I'll look forwards to the update to 59.0.2.

Funda le mpendulo ngokuhambisana nalesi sihloko 0

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 28.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0

Eminye Imininingwane

FredMcD
  • Top 10 Contributor
4254 izisombululo 59584 izimpendulo
Kuphostiwe

Please explain the problem in detail. What happens? Error messages?


First, Type about:preferences#advanced<enter> in the address bar. Under Advanced, Select Update.

[v56+] Type about:preferences#general<enter> in the address bar. Select Update.

Select Never Check For Updates.

Also turn off Use a background service to install updates <Windows Only>


Install Older Version Of Firefox {web link} Be sure to read everything here.

If you still want to downgrade, look under; I still want to downgrade. Click the Directory of other versions and languages link. Look for the directory of the version that you want. But, remember that old versions may have security issues.

You should also check out Firefox; Extended Support Release {web link} ESR Notes System Requirements

Please explain the problem in detail. What happens? Error messages? --------------------- First, Type '''about:preferences#advanced'''<enter> in the address bar. Under '''Advanced, ''' Select '''Update. ''' [v56+] Type '''about:preferences#general'''<enter> in the address bar. Select '''Update. ''' Select '''Never Check For Updates.''' Also turn off '''Use a background service to install updates''' <Windows Only> --------------- [https://support.mozilla.org/en-US/kb/install-older-version-of-firefox?cache=no Install Older Version Of Firefox] {web link} Be sure to read everything here. If you still want to downgrade, look under; '''I still want to downgrade. ''' Click the '''Directory of other versions and languages''' link. Look for the directory of the version that you want. But, remember that '''old versions may have security issues. ''' You should also check out [https://www.mozilla.org/en-US/firefox/organizations/ Firefox; Extended Support Release] {web link} [https://www.mozilla.org/en-US/firefox/organizations/notes/ ESR Notes] [https://www.mozilla.org/en-US/firefox/organizations/system-requirements/ System Requirements]

Umnikazi wombuzo

It does seem to have worked this time and not updated so I'll Mark it as "solved" even though I didn't actually change any settings, but it is still an unsatisfactory situation. I have no options for "Use a background service to install update" but maybe that's because I used custom settings when I installed and opted not to install the Mozilla Maintenance Service because I'm fed up with stuff hogging my processor. (Firefox is the major culprit for this.)

But that doesn't solve the question as to why FF 59 doesn't work on this computer when it's ok on others. I've attached a couple of screenshots, the first using FF 59, abd the second FF 58. With FF 59 on the Google.co.uk home page the "Google search" and "I'm feeling lucky" buttons either don't appear or are just grey boxes. If I search, I get an essentially blank screen except that the text appears if I run the mouse over it, or when I scroll. As soon as I stop it disappears.

For now I've installed FF 58 but that isn't very satisfactory because it won't get security updates. I'll try the ESR version and see if that works.

Thanks for your help.

BTW, if you use the "Preview Reply" button then open one of the attachments, then return to this page, the attachments disappear and have to be uploaded again...<<sigh>>

It does seem to have worked this time and not updated so I'll Mark it as "solved" even though I didn't actually change any settings, but it is still an unsatisfactory situation. I have no options for "Use a background service to install update" but maybe that's because I used custom settings when I installed and opted not to install the Mozilla Maintenance Service because I'm fed up with stuff hogging my processor. (Firefox is the major culprit for this.) But that doesn't solve the question as to why FF 59 doesn't work on this computer when it's ok on others. I've attached a couple of screenshots, the first using FF 59, abd the second FF 58. With FF 59 on the Google.co.uk home page the "Google search" and "I'm feeling lucky" buttons either don't appear or are just grey boxes. If I search, I get an essentially blank screen except that the text appears if I run the mouse over it, or when I scroll. As soon as I stop it disappears. For now I've installed FF 58 but that isn't very satisfactory because it won't get security updates. I'll try the ESR version and see if that works. Thanks for your help. BTW, if you use the "Preview Reply" button then open one of the attachments, then return to this page, the attachments disappear and have to be uploaded again...<<sigh>>

Umnikazi wombuzo

Take back the last comment; images stay uploaded but weren't visible til I posted. Never mind, they're there twice now for posterity.

Take back the last comment; images stay uploaded but weren't visible til I posted. Never mind, they're there twice now for posterity.
FredMcD
  • Top 10 Contributor
4254 izisombululo 59584 izimpendulo
Kuphostiwe

OldGuyDan said

FF 59 doesn't display some pages properly and is unusable

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

''OldGuyDan [[#question-1210442|said]]'' <blockquote> FF 59 doesn't display some pages properly and is unusable </blockquote> Make sure you are not blocking content. [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?

Umnikazi wombuzo

It's just getting more and more bizarre.

I had installed the ESR version, so I had to re-install FF 59. When I did, it all worked fine with the defaults. So I re-enabled the two add-ons I use, which are the F-Secure virus and Rapport, and Google search still worked ok. I then worked through the options resetting it to block pop-ups, then turn off tracking, etc. one at a time and it all worked. I set it to not store searches or history, delete cookies on exit, still no effect. Then I set it for private browsing and bingo! Google wouldn't display properly.

So then I turned off private browsing (forces a restart of FF) but Google still didn't display properly. So I re-started in Safe Mode, and all worked again. Started back in normal mode, and it still worked. Did a search and all results displayed properly.

Now the really odd bit. I went back to the options and re-enabled Private Browsing, but instead of closing the tab, I went to the home page (Google.co.uk) and it didn't display properly. Did the same search as before and the results didn't display.

So now I have two tabs open, both with the same Google search, but one displays fine and the other doesn't. On the first tab I can go back to the home page, enter a new search, and it displays. On the other tab neither the home page nor the search results display properly.

Any ideas? FF 58 works. ESR version works. FF 59 plays mind games.

It's just getting more and more bizarre. I had installed the ESR version, so I had to re-install FF 59. When I did, it all worked fine with the defaults. So I re-enabled the two add-ons I use, which are the F-Secure virus and Rapport, and Google search still worked ok. I then worked through the options resetting it to block pop-ups, then turn off tracking, etc. one at a time and it all worked. I set it to not store searches or history, delete cookies on exit, still no effect. Then I set it for private browsing and bingo! Google wouldn't display properly. So then I turned off private browsing (forces a restart of FF) but Google still didn't display properly. So I re-started in Safe Mode, and all worked again. Started back in normal mode, and it still worked. Did a search and all results displayed properly. Now the really odd bit. I went back to the options and re-enabled Private Browsing, but instead of closing the tab, I went to the home page (Google.co.uk) and it didn't display properly. Did the same search as before and the results didn't display. So now I have two tabs open, both with the same Google search, but one displays fine and the other doesn't. On the first tab I can go back to the home page, enter a new search, and it displays. On the other tab neither the home page nor the search results display properly. Any ideas? FF 58 works. ESR version works. FF 59 plays mind games.
FredMcD
  • Top 10 Contributor
4254 izisombululo 59584 izimpendulo
Kuphostiwe

I called for more help.

I called for more help.
jscher2000
  • Top 10 Contributor
8758 izisombululo 71658 izimpendulo
Kuphostiwe

As a diagnostic, could you check this:

Zoom Test: If you adjust the zoom one tick -- hold down the Ctrl key and tap either the + or - key -- does the missing content appear?

Missing content that shows after adjusting zoom (or while using Firefox's Safe Mode) is characteristic of a new bug in Firefox 59-60 affecting users who disabled ClearType font smoothing in their Windows settings. Some users disable ClearType because it can make text look a bit blurry on some displays.

This is scheduled to be fixed in Firefox 59.0.2, but the release date may not be for a while.

If you don't want to re-enable ClearType, then the workaround is to temporarily disable Firefox from using hardware acceleration. The following article has the steps for that, and the change takes effect the next time you exit Firefox and start it up again:

Firefox's performance settings

Any improvement?

As a diagnostic, could you check this: '''Zoom Test:''' If you adjust the zoom one tick -- hold down the Ctrl key and tap either the + or - key -- does the missing content appear? Missing content that shows after adjusting zoom (or while using Firefox's Safe Mode) is characteristic of a new bug in Firefox 59-60 affecting users who disabled '''ClearType font smoothing''' in their Windows settings. Some users disable ClearType because it can make text look a bit blurry on some displays. ''This is scheduled to be fixed in Firefox 59.0.2, but the release date may not be for a while.'' If you don't want to re-enable ClearType, then the workaround is to temporarily ''disable'' Firefox from using hardware acceleration. The following article has the steps for that, and the change takes effect the next time you exit Firefox and start it up again: [[Firefox's performance settings]] <img src="https://prod-cdn.sumo.mozilla.net/uploads/images/2018-03-20-09-16-11-31f681.png"> Any improvement?

Isisombululo Esikhethiwe

Yep. Changing the zoom works. Anything other than 100% displays fine. I'd read about disabling TTF but I didn't want to do this as sooner or later I'd bet that an MS update would re-enable them and then I'd have to remember what I did. It would also probably screw up something else.

I tried adjusting the performance settings. With both boxes unchecked it works fine. It also works if I just enable the "use h/w acceleration" box but if I set it to use the recommended settings, it doesn't display properly on 100% zoom.

I don't know if it helps but the machine I'm having trouble with is a cheap'n'cheerful Acer V3-112P. It claims to have an Intel Celeron N2840 @ 2.16GHz, 4GB of RAM, and an Intel HD Graphics device 8086-0F31. To add insult to injury I dragged out an ancient HP dv2000 which was having trouble running Win Vista. I loaded Win7, upped the RAM to 2G and it runs FF 59 perfectly.

Thanks for your help. I'll look forwards to the update to 59.0.2.

Yep. Changing the zoom works. Anything other than 100% displays fine. I'd read about disabling TTF but I didn't want to do this as sooner or later I'd bet that an MS update would re-enable them and then I'd have to remember what I did. It would also probably screw up something else. I tried adjusting the performance settings. With both boxes unchecked it works fine. It also works if I just enable the "use h/w acceleration" box but if I set it to use the recommended settings, it doesn't display properly on 100% zoom. I don't know if it helps but the machine I'm having trouble with is a cheap'n'cheerful Acer V3-112P. It claims to have an Intel Celeron N2840 @ 2.16GHz, 4GB of RAM, and an Intel HD Graphics device 8086-0F31. To add insult to injury I dragged out an ancient HP dv2000 which was having trouble running Win Vista. I loaded Win7, upped the RAM to 2G and it runs FF 59 perfectly. Thanks for your help. I'll look forwards to the update to 59.0.2.