X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox seems to cause high CPU usage of windowserver process

Kuphostiwe

Last week I switched back to Firefox after a couple of years, but what I noticed is that once opened the interface seems to be very slow. When checking my CPU usage, once Firefox gets opened, the "windowserver" macOS process spikes to 80-100%. I also see other processes like "mds_stores" and "mdworker" consume a lot of CPU.

If I open Chrome besides Firefox, without actually loading any website. I can see my mouse movement lagging when hovering over the Firefox browser. I do not have this when hovering over Chrome.

Currently, I only have one extension installed + already tried to run in safe mode, but the experience is the same.

Any idea what could cause this?

Last week I switched back to Firefox after a couple of years, but what I noticed is that once opened the interface seems to be very slow. When checking my CPU usage, once Firefox gets opened, the "windowserver" macOS process spikes to 80-100%. I also see other processes like "mds_stores" and "mdworker" consume a lot of CPU. If I open Chrome besides Firefox, without actually loading any website. I can see my mouse movement lagging when hovering over the Firefox browser. I do not have this when hovering over Chrome. Currently, I only have one extension installed + already tried to run in safe mode, but the experience is the same. Any idea what could cause this?
Ama-screenshot ananyekiwe

Okulungisiwe ngu estruyf

Eminye Imininingwane Yohlelo

Fakela amapulagi

1Password

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/65.0.3325.181 Safari/537.36

Eminye Imininingwane

FredMcD
  • Top 10 Contributor
4314 izisombululo 60551 izimpendulo
Kuphostiwe
[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? https://support.mozilla.org/kb/Firefox+is+already+running+but+is+not+responding https://support.mozilla.org/en-US/kb/firefox-slow-how-make-it-faster https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix https://support.mozilla.org/en-US/kb/firefox-uses-too-much-memory-ram https://support.mozilla.org/en-US/kb/firefox-hangs-or-not-responding