X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox makes no sound

Kuphostiwe

I asked this question 2 years ago. It's closed so I have to ask again. Firefox makes no sound. I have a YouTube video playing, for example, and I can see the video, but there's no sound. YouTube's unmuted, the volume is all the way up. If I download the video I can play it with mplayer and hear the sound. I can watch a DVD with xine and hear the sound. I can play an audio file at the same time and hear the sound. I've encountered some videos I can't download so I can't hear them - I have to go to the library to use their computers.

I see 'failed to init cubeb... AudioStream.cpp line 387' and 'OnMediaSinkAudioError... MediaDecoderStateMachine.cpp, line 3755'

if those mean anything.

I asked this question 2 years ago. It's closed so I have to ask again. Firefox makes no sound. I have a YouTube video playing, for example, and I can see the video, but there's no sound. YouTube's unmuted, the volume is all the way up. If I download the video I can play it with mplayer and hear the sound. I can watch a DVD with xine and hear the sound. I can play an audio file at the same time and hear the sound. I've encountered some videos I can't download so I can't hear them - I have to go to the library to use their computers. I see 'failed to init cubeb... AudioStream.cpp line 387' and 'OnMediaSinkAudioError... MediaDecoderStateMachine.cpp, line 3755' if those mean anything.

Isisombululo esikhethiwe

pulseaudio is running. Removing '--disallow-module-loading ' solves my problem. This security measure is in Slackware's rc.pulseaudio. I'll tell them about it.

Funda le mpendulo ngokuhambisana nalesi sihloko 0

Eminye Imininingwane Yohlelo

Isisebenziso

  • Firefox 59.0.1
  • Umsebenzisi oyi-ejenti: Mozilla/5.0 (X11; Linux i686; rv:59.0) Gecko/20100101 Firefox/59.0
  • I-URL Yokweseka: https://support.mozilla.org/1/firefox/59.0.1/Linux/en-US/

Izandiso

  • Easy Youtube Video Downloader Express 10.6 ({b9acf540-acba-11e1-8ccb-001fd0e08bd4}) (Akusebenzi)
  • Image Video Block 2.4.1 ({dabe08f4-8ec2-4dc5-a4dd-fda31fb8b38c}) (Akusebenzi)
  • No-Script Suite Lite 0.2.7 ({86d73a1c-2ec5-4b7a-b249-60cec805dc99}) (Akusebenzi)
  • Print Edit WE 21.6 (printedit-we@DW-dev) (Akusebenzi)
  • Video DownloadHelper 7.2.2 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d}) (Akusebenzi)

I-Javascript

  • incrementalGCEnabled: True

Imidwebo

  • adapterDescription: Intel Open Source Technology Center -- Mesa DRI Mobile Intel® GM45 Express Chipset x86/MMX/SSE2
  • adapterDeviceID: Mesa DRI Mobile Intel® GM45 Express Chipset x86/MMX/SSE2
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: Intel Open Source Technology Center
  • crashGuards: []
  • driverDate:
  • driverVersion: 2.1 Mesa 17.3.6
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'blocked', u'description': u'Compositing', u'log': [{u'status': u'blocked', u'message': u'Acceleration blocked by platform', u'type': u'default'}, {u'status': u'blocked', u'message': u'Acceleration blocked by safe-mode', u'type': u'runtime'}], u'name': u'HW_COMPOSITING'}, {u'status': u'unavailable', u'description': u'OpenGL Compositing', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}], u'name': u'OPENGL_COMPOSITING'}, {u'status': u'unavailable', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}, {u'status': u'unavailable', u'message': u"Build doesn't include WebRender", u'type': u'runtime'}], u'name': u'WEBRENDER'}, {u'status': u'blocked', u'description': u'Off Main Thread Painting', u'log': [{u'status': u'disabled', u'message': u'Disabled by default', u'type': u'default'}, {u'status': u'blocked', u'message': u'OMTP blocked by safe-mode', u'type': u'runtime'}], u'name': u'OMTP'}]}
  • info: {u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'CairoUseXRender': 0, u'ApzAutoscrollInput': 1, u'AzureFallbackCanvasBackend': u'none', u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • offMainThreadPaintEnabled: False
  • webgl1DriverExtensions: -
  • webgl1Extensions: -
  • webgl1Renderer: WebGL is currently disabled.
  • webgl1Version: -
  • webgl1WSIInfo: -
  • webgl2DriverExtensions: -
  • webgl2Extensions: -
  • webgl2Renderer: WebGL is currently disabled.
  • webgl2Version: -
  • webgl2WSIInfo: -
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic
  • windowUsingAdvancedLayers: False

Okuthandwayo Okulungisiwe

Misc

  • Umsebenzisi JS: Cha
  • Ukufinyeleleka: Cha
Shadow110 1072 izisombululo 14836 izimpendulo
Kuphostiwe

Hi, sorry not able to hear.

Can try in Safe Mode

In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected

TEST REFRESH INSTRUCTIONS

Please Refresh but do this 1st: Delete your Cookies and Cache and TEST.

then

TEST....... If no issues then Extensions which need to be added back in 1 at a time and tested ..... Or it is your Profile : Make a new one and test ...:

If is your Profile :

Note: Any customization will revert back to default, you will also need to reinstall Extensions. Please let us know if this solved your issue or if need further assistance.

Hi, sorry not able to hear. *https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues *https://support.mozilla.org/en-US/kb/fix-video-audio-problems-firefox-windows *https://support.mozilla.org/en-US/kb/html5-audio-and-video-firefox Can try in Safe Mode *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes In Firefox Safe mode these changes are effective: *all extensions are disabled (about:addons) *default theme is used (no persona) *userChrome.css and userContent.css are ignored (chrome folder) *default toolbar layout is used (file: localstore-safe.rdf) *Javascript JIT compilers are disabled (prefs: javascript.options.*jit) *hardware acceleration is disabled (Options > Advanced > General) *plugins are not affected *preferences are not affected TEST REFRESH INSTRUCTIONS Please Refresh but do this 1st: Delete your Cookies and Cache and TEST. *https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer *https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles then *https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings TEST....... If no issues then Extensions which need to be added back in 1 at a time and tested ..... Or it is your Profile : Make a new one and test ...: *https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles If is your Profile : *https://support.mozilla.org/en-US/kb/recovering-important-data-from-an-old-profile *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox Note: Any customization will revert back to default, you will also need to reinstall Extensions. Please let us know if this solved your issue or if need further assistance.

Umnikazi wombuzo

I tried all of this BEFORE I asked here. I've had this problem for more than 2 years.

I tried all of this BEFORE I asked here. I've had this problem for more than 2 years.
TyDraniu
  • Top 25 Contributor
316 izisombululo 1782 izimpendulo
Kuphostiwe

Do you have PulseAudio installed?

https://bugzilla.mozilla.org/show_bug.cgi?id=1247056

Do you have PulseAudio installed? https://bugzilla.mozilla.org/show_bug.cgi?id=1247056

Umnikazi wombuzo

I have tried both with and without pulseaudio. When I have pulseaudio running I have run pavucontrol, turned the volume all the way up, made sure speakers were unmuted.

I have tried both with and without pulseaudio. When I have pulseaudio running I have run pavucontrol, turned the volume all the way up, made sure speakers were unmuted.
TyDraniu
  • Top 25 Contributor
316 izisombululo 1782 izimpendulo
Kuphostiwe
You can check this article: [[No sound in Firefox 59 on Linux in some configurations]]

Isisombululo Esikhethiwe

pulseaudio is running. Removing '--disallow-module-loading ' solves my problem. This security measure is in Slackware's rc.pulseaudio. I'll tell them about it.

pulseaudio is running. Removing '--disallow-module-loading ' solves my problem. This security measure is in Slackware's rc.pulseaudio. I'll tell them about it.

Umnikazi wombuzo

Hmmmm... I was running as root when this fix worked; when I run as myself it doesn't. (Yes I tried it as root before) so I have a permissions problem too; would anyone know what? I've looked at lsof's output but that hasn't helped.

Hmmmm... I was running as root when this fix worked; when I run as myself it doesn't. (Yes I tried it as root before) so I have a permissions problem too; would anyone know what? I've looked at lsof's output but that hasn't helped.