Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox makes no sound

  • 7 uphendule
  • 1 inale nkinga
  • 4056 views
  • Igcine ukuphendulwa ngu RandomTroll

more options

I asked this question 2 years ago. It's closed so I have to ask again. Firefox makes no sound. I have a YouTube video playing, for example, and I can see the video, but there's no sound. YouTube's unmuted, the volume is all the way up. If I download the video I can play it with mplayer and hear the sound. I can watch a DVD with xine and hear the sound. I can play an audio file at the same time and hear the sound. I've encountered some videos I can't download so I can't hear them - I have to go to the library to use their computers.

I see 'failed to init cubeb... AudioStream.cpp line 387' and 'OnMediaSinkAudioError... MediaDecoderStateMachine.cpp, line 3755'

if those mean anything.

Isisombululo esikhethiwe

pulseaudio is running. Removing '--disallow-module-loading ' solves my problem. This security measure is in Slackware's rc.pulseaudio. I'll tell them about it.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (7)

more options

Hi, sorry not able to hear.

Can try in Safe Mode

In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected

TEST REFRESH INSTRUCTIONS

Please Refresh but do this 1st: Delete your Cookies and Cache and TEST.

then

TEST....... If no issues then Extensions which need to be added back in 1 at a time and tested ..... Or it is your Profile : Make a new one and test ...:

If is your Profile :

Note: Any customization will revert back to default, you will also need to reinstall Extensions. Please let us know if this solved your issue or if need further assistance.

more options

I tried all of this BEFORE I asked here. I've had this problem for more than 2 years.

more options

Do you have PulseAudio installed?

https://bugzilla.mozilla.org/show_bug.cgi?id=1247056

more options

I have tried both with and without pulseaudio. When I have pulseaudio running I have run pavucontrol, turned the volume all the way up, made sure speakers were unmuted.

more options
more options

Isisombululo Esikhethiwe

pulseaudio is running. Removing '--disallow-module-loading ' solves my problem. This security measure is in Slackware's rc.pulseaudio. I'll tell them about it.

more options

Hmmmm... I was running as root when this fix worked; when I run as myself it doesn't. (Yes I tried it as root before) so I have a permissions problem too; would anyone know what? I've looked at lsof's output but that hasn't helped.