Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

In Firefox Quantum 59.0 I can't delete bookmarks

  • 8 uphendule
  • 3 zinale nkinga
  • 50 views
  • Igcine ukuphendulwa ngu FredMcD

more options

Hello,

I was forced to Refresh my Firefox, because it was "forgetting" all my passwords after closing Firefox and opening it again. Now passwords are OK, but I'm not able to delete any bookmarks: I can only add them, move on the toolbar or manage by changing names and adresses. But I want to delete some of them.

I do not sync my bookmarks.

I tried to verify integrity (described in that thread: https://support.mozilla.org/pl/questions/1207605#question-reply) and got this:

> Task: checkIntegrity - Unable to check database integrity > Task: invalidateCaches - The task queue was cleared by an error in another task. > Task: checkCoherence - The task queue was cleared by an error in another task. > Task: expire - The task queue was cleared by an error in another task. > Task: vacuum - The task queue was cleared by an error in another task. > Task: stats - The task queue was cleared by an error in another task. > Task: _refreshUI - The task queue was cleared by an error in another task.

Please help :-)

Okulungisiwe ngu R3TZ3V

Isisombululo esikhethiwe

I made it. It was so simple: 1. Close Firefox 2. Go to profile and find places.sqlite file/files (when Firefox is open there are more than 1, but I did it when it was closed) 3. Delete (or move to another folder) that file/files. 4. Run Firefox, it should restore bookmarks from backup stored in bookmarkbackups folder in the profile (I suppose it did that). 5. Now I'm able to delete bookmarks :-)

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (8)

more options

Please try : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do :

Reinstall with Current Release Firefox 59.0 with a Full Version Installer

Please let us know if this solved your issue or if need further assistance.

more options

Pkshadow said

Please try : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do : Reinstall with Current Release Firefox 59.0 with a Full Version Installer Please let us know if this solved your issue or if need further assistance.

It didn't help. What's more, now I can't open any links in my Outlook 2013 :-)

Okulungisiwe ngu R3TZ3V

more options

R3TZ3V said

Pkshadow said
Please try : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do : Reinstall with Current Release Firefox 59.0 with a Full Version Installer Please let us know if this solved your issue or if need further assistance.

It didn't help. What's more, now I can't open any links in my Outlook 2013 :-)

Please go to Options --> General --> Applications and reset the Mail to at the bottom of the list to Outlook. Restart browser.

Please try this : SAFE MODE

In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected

TEST

more options

If running Firefox in Safe mode does not help,

Start your Computer in safe mode with network support. Then start Firefox. Try Safe websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

more options

FredMcD said

If running Firefox in Safe mode does not help, Start your Computer in safe mode with network support. Then start Firefox. Try Safe websites. Is the problem still there? http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

I run Windows in Safe Mode, then Firefox in Safe Mode - it didn't help. In Windows Safe Mode and Firefox without Safe Mode also no effect. Eventually I'll create "Trash" folder for unwanted bookmarks, but it's temporarily/provisionally...

P.S. I repaired those hiperlinks from Outlook that didn't open in any browser - I made some registry changes.

Okulungisiwe ngu R3TZ3V

more options

I called for more help.

more options

Isisombululo Esikhethiwe

I made it. It was so simple: 1. Close Firefox 2. Go to profile and find places.sqlite file/files (when Firefox is open there are more than 1, but I did it when it was closed) 3. Delete (or move to another folder) that file/files. 4. Run Firefox, it should restore bookmarks from backup stored in bookmarkbackups folder in the profile (I suppose it did that). 5. Now I'm able to delete bookmarks :-)

more options

That was very good work. Well done.