Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Webpage disappears after a few seconds under certain browser width

  • 6 uphendule
  • 1 inale nkinga
  • 7 views
  • Igcine ukuphendulwa ngu jscher2000

more options

Hi, I'm an eng trying to do cross-browser debugging. Firefox is giving me a weird bug. To start:

- No plugins installed - No ad blockers installed - Cleared cache, cookies, history, everything - version 58.0.2 (64-bit) on Mac OS 10.12.6

Having trouble repro'ing this bug but here's my best shot.

Navigate to https://www.joinhonor.com/care-network

Shrink the browser width to about 500px.

Scroll a bit, wait a bit. Maybe do something else for a few seconds.

Page goes blank except for header, footer and maybe a few other components.

Doesn't happen in Chrome or Safari.

I've been able to repro on a few pages but not consistently.

Any ideas? Thanks!

All Replies (6)

more options

Hello,

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

more options

The problem occurs when the display is narrow enough for the photo in the top section to move below the yellow button.

Any time I change something in the Page Inspector, e.g., click off display:flex for a div or assign display:block to a span, everything is good for 5-10 seconds, and then away it goes. There is a constantly running script that is doing something odd, but I have no idea what it is.

This page is very complex. You probably should seek support on a site where experts on this framework hang out.

more options

screenshot attached

more options

@jscher2000

Thanks for the quick response. Can you provide more color about this "constantly running script"? I don't see it but if you could tell me the name, I could dive deeper.

I'm not sure why this issue is happening only on Firefox.

more options

This is what the picture looks like.

more options

benjamin88 said

Can you provide more color about this "constantly running script"? I don't see it but if you could tell me the name, I could dive deeper.

This framework is waaaaay too complicated for me to find anything. What I can tell you with certainty is: if JavaScript is disabled, the problem goes away.

There are other issues with scripts disabled, such as the quote carousel overlaying body text. I wonder if the carousel could be an issue? It would make sense to be something running on a timer.