Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

FF slow on initial start up loading home or startpage, see screenshot.

  • 1 baphendule
  • 2 zinale nkinga
  • 5 views
  • Igcine ukuphendulwa ngu FredMcD

more options

This has been an ongoing issue for a long time now, as long as I can remember. I click to open FF from my desktop, it opens fast, but hangs for anywhere from 4 to 8 seconds upon initial load before it even attempts to connect to my set homepage, which is www.google.com (I've tried other variations too, google.ca, google.com/ncr etc etc).

I've tried clearing my cache, completely reinstalling FF, safemode, disabling themes, disabling addons and re-enabling addons, with no luck, the same HANG persists.

Shouldn't FF load just fine and then immediately try connecting to my homepage? What's with this "Connecting..." every time I initially load the program?

I'm completely stumped here, I've tried everything,,,,, Something is causing firefox to delay at startup or it's hanging for no reason too long because it thinks the program hasn't loaded fully yet, but it has. Some sort of timing issue or something.

Please view the attached screenshot jpg file I've included with this post to see exactly what I see everytime I load FF for the first 4 to 8 seconds. I know computers and the inner workings of things and how to use about:config etc etc, so I'll be able to follow even the most difficult of directions if you have a solution. Thankyou ahead of time for reading this post, I look forward to your reply!

D.

Ama-screenshot ananyekiwe

Okulungisiwe ngu PenTech Services

All Replies (1)

more options

As a test, change your homepage to about:blank Is the problem there?

Now try about:home

Then try something other than Google.