X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Since latest update, keyboard not working, fixed, then not working again.

Kuphostiwe

Hi All fine until the latest Firefox update. Straight afterwards the keyboard wasn't functioning - weird characters and symbols instead of letters. I closed it down, opened in safe mode, closed down, opened normally and the keyboard working normally. Unfortunately I have to keep doing this. I can get Firefox to work by going into safe mode but it doesn't last. Keep getting keyboard problems. Is there a long-term solution please?

Hi All fine until the latest Firefox update. Straight afterwards the keyboard wasn't functioning - weird characters and symbols instead of letters. I closed it down, opened in safe mode, closed down, opened normally and the keyboard working normally. Unfortunately I have to keep doing this. I can get Firefox to work by going into safe mode but it doesn't last. Keep getting keyboard problems. Is there a long-term solution please?

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0

Eminye Imininingwane

Mkll 314 izisombululo 1978 izimpendulo
Kuphostiwe

Impendulo Ewusizo

If it works in Safe Mode, the Refresh feature should solve it for good!

The Refresh feature (called "Reset" in older Firefox versions) can fix many issues by restoring Firefox to its factory default state while saving your bookmarks, history, passwords, cookies, and other essential information.

Note: When you use this feature, you will lose any extensions, toolbar customizations, and some preferences. See the Refresh Firefox - reset add-ons and settings article for more information.

To Refresh Firefox:

  1. Open the Troubleshooting Information page using one of these methods:
    • Click the menu button New Fx Menu , click help Help-29 and select Troubleshooting Information. A new tab containing your troubleshooting information should open.
    • If you're unable to access the Help menu, type about:support in your address bar to bring up the Troubleshooting Information page.
  2. At the top right corner of the page, you should see a button that says "Refresh Firefox" ("Reset Firefox" in older Firefox versions). Click on it.
  3. Firefox will close. After the refresh process is completed, Firefox will show a window with the information that is imported.
  4. Click Finish and Firefox will reopen.

Did this fix the problem? Please report back to us!

Thank you.

If it works in Safe Mode, the Refresh feature should solve it for good! The Refresh feature (called "Reset" in older Firefox versions) can fix many issues by restoring Firefox to its factory default state while saving your bookmarks, history, passwords, cookies, and other essential information. '''''Note:''' When you use this feature, you will lose any extensions, toolbar customizations, and some preferences.'' See the [[Refresh Firefox - reset add-ons and settings]] article for more information. To Refresh Firefox: # Open the Troubleshooting Information page using one of these methods: #*Click the menu button [[Image:New Fx Menu]], click help [[Image:Help-29]] and select ''Troubleshooting Information''. A new tab containing your troubleshooting information should open. #*If you're unable to access the Help menu, type '''about:support''' in your address bar to bring up the Troubleshooting Information page. #At the top right corner of the page, you should see a button that says "Refresh Firefox" ("Reset Firefox" in older Firefox versions). Click on it. #Firefox will close. After the refresh process is completed, Firefox will show a window with the information that is imported. #Click Finish and Firefox will reopen. Did this fix the problem? Please report back to us! Thank you.

Impendulo Ewusizo

Hi Mkll

Many thanks for replying so promptly to my question. I haven't tried your suggestion yet as it seems as though it will be a major job to get all my extensions etc back again afterwards. I will have to pluck up the courage to do it......

Hi Mkll Many thanks for replying so promptly to my question. I haven't tried your suggestion yet as it seems as though it will be a major job to get all my extensions etc back again afterwards. I will have to pluck up the courage to do it......
Mkll 314 izisombululo 1978 izimpendulo
Kuphostiwe

Not to worry, your information will be saved on the Desktop in a folder called 'Old Firefox Data'

Not to worry, your information will be saved on the Desktop in a folder called 'Old Firefox Data'
cor-el
  • Top 10 Contributor
  • Moderator
17525 izisombululo 158458 izimpendulo
Kuphostiwe

Do you have multiple keyboard layouts installed in Windows?

If that is the case then you may accidentally trigger a layout switch because Windows uses by default some modifiers (e.g. Ctrl+Shift) to rotate layouts that are used in Firefox for menu items. You would have to disable this rotate feature in Windows Control Panel.

Do you have multiple keyboard layouts installed in Windows? If that is the case then you may accidentally trigger a layout switch because Windows uses by default some modifiers (e.g. Ctrl+Shift) to rotate layouts that are used in Firefox for menu items. You would have to disable this rotate feature in Windows Control Panel.

Umnikazi wombuzo

Mkll - if my settings and info are still available then that would save a lot of hassle. Thanks for your help.

cor-el - I do have French English and Spanish keyboards which I toggle between as and when. I am doubtful whether that has anything to do with it though because when I typed in "Mozilla support" I just got a load of the same letter repeated ééééééé in the search bar. Seemed too random to be my French keyboard working instead of the English. I have never had this problem before with any other Firefox update. If I go into control panel and disable the rotate feature will I still be able to access my foreign keyboard layouts? Thanks

Mkll - if my settings and info are still available then that would save a lot of hassle. Thanks for your help. cor-el - I do have French English and Spanish keyboards which I toggle between as and when. I am doubtful whether that has anything to do with it though because when I typed in "Mozilla support" I just got a load of the same letter repeated ééééééé in the search bar. Seemed too random to be my French keyboard working instead of the English. I have never had this problem before with any other Firefox update. If I go into control panel and disable the rotate feature will I still be able to access my foreign keyboard layouts? Thanks
cor-el
  • Top 10 Contributor
  • Moderator
17525 izisombululo 158458 izimpendulo
Kuphostiwe

In older Windows versions there is the Language Bar (right-click Windows Taskbar) to show what layout is active for the current application. I assume that this still works in Windows 10.

In your other thread you wrote that you got the window system menu.

All I get is a box which opens and invites me to Restore Move Size Maximise or Close.

This menu normally opens if you press Alt+Space, so you may have a sticky Alt key. It is possible that some of the status keys have the wrong state and Firefox sees them as still pressed.

Try to press all the status keys (Shift, Ctrl, Alt, Win) a few times to see if that helps to recover from this. If this doesn't help then close and restart Firefox or reboot the computer.


https://answers.microsoft.com/en-us/windows/forum/windows_10-start/re-arrangement-of-keys-in-keyboard/31532aff-4334-41ed-91fc-67af61d1d231?msgId=037d8bd1-31d9-4b58-aecb-01d3036407a4

In older Windows versions there is the Language Bar (right-click Windows Taskbar) to show what layout is active for the current application. I assume that this still works in Windows 10. In your other thread you wrote that you got the window system menu. <blockquote>'' All I get is a box which opens and invites me to Restore Move Size Maximise or Close.''</blockquote> This menu normally opens if you press Alt+Space, so you may have a sticky Alt key. It is possible that some of the status keys have the wrong state and Firefox sees them as still pressed. Try to press all the status keys (Shift, Ctrl, Alt, Win) a few times to see if that helps to recover from this. If this doesn't help then close and restart Firefox or reboot the computer. ---- https://answers.microsoft.com/en-us/windows/forum/windows_10-start/re-arrangement-of-keys-in-keyboard/31532aff-4334-41ed-91fc-67af61d1d231?msgId=037d8bd1-31d9-4b58-aecb-01d3036407a4

Okulungisiwe ngu cor-el