X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox does not use all available resources.

Kuphostiwe

DISCLAIMER: I found many articles about this issue, but none of them solved this problem.


DESCRIPTION: I have a problem with Firefox on my backup PCs that makes it freeze/slow down everytime i try to • play more gifs at once • play HTML5/Flash video on high quality/bitrate or loading more post on facebook. • Simmilar action that require system resources.

I believe that firefox won't use all available system resources. This issue always occur on "load" and system resources are always around 30-50% of use based on Windows 10 task manager (near usual load on my backup PC without running services/programs s it still uses only around 10% of resources).

NOTE: This issue is notable mostly on my backup PC with limited performance, but i found simmilar issues on main PC. The difference is that on main PC it uses enough resources to run without notable performance drop.

This problem is on firefox only (tested on chrome and edge).

END-USER OPINION: I believe that there is problem in firefox settings that prevents it to use all system resources.

TRIED SOLUTIONS: • Reinstall flash = Without effect • Tries Firefox stable build = Without effect. • Disable/Enable hardware acceleration = Without effect.

• Reinstall Firefox using iobit uninstaller to remove all registry and perform clean installation of firefox. > Without effect.

• Installing different firefox versions. > Without effect.

• Running firefox without extensions. > Without effect with ads and white stuff that prints stuff into my retina.

• Messing up with about:config. > Mostly more harm then good done and even then when i try to change one at a time and verify its effect on system i cant seem to find anything that could affect firefox performance to solve this problem.

• Forcing videos to use HTML5 instead of flash and conversely. > It won't play HTML5 on youtube and flash is lagging on higger bitrate. I believe that it won't play HTML5 due my youtube settings HTML5 worked fine on other sources.


Thanks for help! - DK

DxDiag: https://pastebin.com/Aa35SQJR

DISCLAIMER: I found many articles about this issue, but none of them solved this problem. DESCRIPTION: I have a problem with Firefox on my backup PCs that makes it freeze/slow down everytime i try to • play more gifs at once • play HTML5/Flash video on high quality/bitrate or loading more post on facebook. • Simmilar action that require system resources. I believe that firefox won't use all available system resources. This issue always occur on "load" and system resources are always around 30-50% of use based on Windows 10 task manager (near usual load on my backup PC without running services/programs s it still uses only around 10% of resources). NOTE: This issue is notable mostly on my backup PC with limited performance, but i found simmilar issues on main PC. The difference is that on main PC it uses enough resources to run without notable performance drop. This problem is on firefox only (tested on chrome and edge). END-USER OPINION: I believe that there is problem in firefox settings that prevents it to use all system resources. TRIED SOLUTIONS: • Reinstall flash = Without effect • Tries Firefox stable build = Without effect. • Disable/Enable hardware acceleration = Without effect. • Reinstall Firefox using iobit uninstaller to remove all registry and perform clean installation of firefox. > Without effect. • Installing different firefox versions. > Without effect. • Running firefox without extensions. > Without effect with ads and white stuff that prints stuff into my retina. • Messing up with about:config. > Mostly more harm then good done and even then when i try to change one at a time and verify its effect on system i cant seem to find anything that could affect firefox performance to solve this problem. • Forcing videos to use HTML5 instead of flash and conversely. > It won't play HTML5 on youtube and flash is lagging on higger bitrate. I believe that it won't play HTML5 due my youtube settings HTML5 worked fine on other sources. Thanks for help! - DK DxDiag: https://pastebin.com/Aa35SQJR

Okulungisiwe ngu David M. Košecký

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 28.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0

Eminye Imininingwane

WestEnd 60 izisombululo 5387 izimpendulo
Kuphostiwe

Impendulo Ewusizo

So do you have a screen shot of the actual error message?

So do you have a screen shot of the actual error message?
FredMcD
  • Top 10 Contributor
4311 izisombululo 60542 izimpendulo
Kuphostiwe

Impendulo Ewusizo

What's your backup computer system and Firefox version?

What's your backup computer system and Firefox version?

Umnikazi wombuzo

WestEnd said

So do you have a screen shot of the actual error message?

There is none error message it just slow down/freeze based on workload without use of system resources.

FredMcD said

What's your backup computer system and Firefox version?

It's in original post (view question details) with dxdiag

   Windows 10
   Firefox 60.0
''WestEnd [[#answer-1080397|said]]'' <blockquote> So do you have a screen shot of the actual error message? </blockquote> There is none error message it just slow down/freeze based on workload without use of system resources. ''FredMcD [[#answer-1080502|said]]'' <blockquote> What's your backup computer system and Firefox version? </blockquote> It's in original post (view question details) with dxdiag Windows 10 Firefox 60.0

Okulungisiwe ngu David M. Košecký

FredMcD
  • Top 10 Contributor
4311 izisombululo 60542 izimpendulo
Kuphostiwe

I called for more help.

I called for more help.

Umnikazi wombuzo

FredMcD said

I called for more help.

Any news?

''FredMcD [[#answer-1080627|said]]'' <blockquote> I called for more help. </blockquote> Any news?
FredMcD
  • Top 10 Contributor
4311 izisombululo 60542 izimpendulo
Kuphostiwe

I called again.

I called again.

Umnikazi wombuzo

None knows none cares.. -_-

Reported in Bugzilla.mozilla.org.

None knows none cares.. -_- Reported in Bugzilla.mozilla.org.

Okulungisiwe ngu David M. Košecký

WestEnd 60 izisombululo 5387 izimpendulo
Kuphostiwe

David M. Košecký said

WestEnd said
So do you have a screen shot of the actual error message?

There is none error message it just slow down/freeze based on workload without use of system resources.

FredMcD said

What's your backup computer system and Firefox version?

It's in original post (view question details) with dxdiag

   Windows 10
   Firefox 60.0

One thing is clear FF release public is 58.0.2 using beta isn't advised so install the Public release to insure the problem is not related to beta problems.

''David M. Košecký [[#answer-1080510|said]]'' <blockquote> ''WestEnd [[#answer-1080397|said]]'' <blockquote> So do you have a screen shot of the actual error message? </blockquote> There is none error message it just slow down/freeze based on workload without use of system resources. ''FredMcD [[#answer-1080502|said]]'' <blockquote> What's your backup computer system and Firefox version? </blockquote> It's in original post (view question details) with dxdiag Windows 10 Firefox 60.0 </blockquote> One thing is clear FF release public is 58.0.2 using beta isn't advised so install the Public release to insure the problem is not related to beta problems.

Umnikazi wombuzo

WestEnd said

David M. Košecký said
WestEnd said
So do you have a screen shot of the actual error message?

There is none error message it just slow down/freeze based on workload without use of system resources.

FredMcD said

What's your backup computer system and Firefox version?

It's in original post (view question details) with dxdiag

   Windows 10
   Firefox 60.0

One thing is clear FF release public is 58.0.2 using beta isn't advised so install the Public release to insure the problem is not related to beta problems.

Already tested it in Firefox 58.X before i wrote this question. Seems like same problem to me (tested now just to make sure).

I believe that its a problem with firefox optimization for YouTube 60fps/high bitrate videos.

''WestEnd [[#answer-1084586|said]]'' <blockquote> ''David M. Košecký [[#answer-1080510|said]]'' <blockquote> ''WestEnd [[#answer-1080397|said]]'' <blockquote> So do you have a screen shot of the actual error message? </blockquote> There is none error message it just slow down/freeze based on workload without use of system resources. ''FredMcD [[#answer-1080502|said]]'' <blockquote> What's your backup computer system and Firefox version? </blockquote> It's in original post (view question details) with dxdiag Windows 10 Firefox 60.0 </blockquote> One thing is clear FF release public is 58.0.2 using beta isn't advised so install the Public release to insure the problem is not related to beta problems. </blockquote> Already tested it in Firefox 58.X before i wrote this question. Seems like same problem to me (tested now just to make sure). I believe that its a problem with firefox optimization for YouTube 60fps/high bitrate videos.
cor-el
  • Top 10 Contributor
  • Moderator
17691 izisombululo 160067 izimpendulo
Kuphostiwe

You can try to disable hardware acceleration in Firefox.

Close and restart Firefox after modifying the setting to make the change effective.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

You can try to disable hardware acceleration in Firefox. *Options/Preferences -> General: Performance<br>remove checkmark: [ ] "Use recommended performance settings"<br>remove checkmark: [ ] "Use hardware acceleration when available" *https://support.mozilla.org/en-US/kb/performance-settings Close and restart Firefox after modifying the setting to make the change effective. *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems You can check if there is an update for your graphics display driver and check for hardware acceleration related issues. *https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

Okulungisiwe ngu cor-el

Umnikazi wombuzo

cor-el said

You can try to disable hardware acceleration in Firefox. Close and restart Firefox after modifying the setting to make the change effective. You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

Tried, no effect except that firefox seems slower (loading takes longer) on CPU. :/

''cor-el [[#answer-1084634|said]]'' <blockquote> You can try to disable hardware acceleration in Firefox. *Options/Preferences -> General: Performance<br>remove checkmark: [ ] "Use recommended performance settings"<br>remove checkmark: [ ] "Use hardware acceleration when available" *https://support.mozilla.org/en-US/kb/performance-settings Close and restart Firefox after modifying the setting to make the change effective. *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems You can check if there is an update for your graphics display driver and check for hardware acceleration related issues. *https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration </blockquote> Tried, no effect except that firefox seems slower (loading takes longer) on CPU. :/

Okulungisiwe ngu David M. Košecký