X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

After Feb ~12th, Firefox freezes until a page fully loads

Kuphostiwe

Sometime after around Feb 13th, I think I might have rebooted for a Windows update and now Firefox pages completely lock up until the entire page loads.

To be more specific, I can still switch tabs, open menus, etc... but I cannot interact with anything on the page itself like click links, type in text fields, right click to get the context menu... but if I switch to another tab, I can interact with that page just fine. In addition, while the page is frozen like that, I can't use the back button either, but clicking it (or using the back button on my mouse) will make the browser go back only after the page fully loads.

Why is this bad? Some pages can take 10 to 20 seconds or even more to load! So even though I can see the link I want to go to almost immediately, I have to wait until every picture is done loading before I can click it.

In addition, things like the dropdown you get on google as you type in the search box will freeze the page when you select them. For example, I go to google, I type "Firef" then click the Firefox autocomplete. The entire page freezes for a couple of seconds before the screen is cleared and goes white and then it starts loading the next page.

Other things I've noticed, those google captcha things where you click the checkbox for "I am not a robot"; those can take over 15 seconds to load and freeze up the page PLUS clicking the checkbox ALSO freezes the page again for another 15 seconds.

This happens in safe mode too and with all addons disabled.

Sometime after around Feb 13th, I think I might have rebooted for a Windows update and now Firefox pages completely lock up until the entire page loads. To be more specific, I can still switch tabs, open menus, etc... but I cannot interact with anything on the page itself like click links, type in text fields, right click to get the context menu... but if I switch to another tab, I can interact with that page just fine. In addition, while the page is frozen like that, I can't use the back button either, but clicking it (or using the back button on my mouse) will make the browser go back only after the page fully loads. Why is this bad? Some pages can take 10 to 20 seconds or even more to load! So even though I can see the link I want to go to almost immediately, I have to wait until every picture is done loading before I can click it. In addition, things like the dropdown you get on google as you type in the search box will freeze the page when you select them. For example, I go to google, I type "Firef" then click the Firefox autocomplete. The entire page freezes for a couple of seconds before the screen is cleared and goes white and then it starts loading the next page. Other things I've noticed, those google captcha things where you click the checkbox for "I am not a robot"; those can take over 15 seconds to load and freeze up the page PLUS clicking the checkbox ALSO freezes the page again for another 15 seconds. This happens in safe mode too and with all addons disabled.

Isisombululo esikhethiwe

Whelp, as suspected, it is 58.0.2 that causes the problem. I installed 58.0.1 and it's fine now. Guess I'll keep using this version until Mozilla can fix the problem.

Funda le mpendulo ngokuhambisana nalesi sihloko 0

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 25.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0

Eminye Imininingwane

FredMcD
  • Top 10 Contributor
4270 izisombululo 59892 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Start your Computer in safe mode with network support. Then start Firefox. Try Safe websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia


Separate Security Issue: Update your Flash Player Note: Windows users should download the ActiveX for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX.

Flash Player Version: Version 28.0.0.161

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download. <Windows Only>

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

Start your '''Computer''' in safe mode with network support. Then start Firefox. Try '''Safe''' websites. Is the problem still there? http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia ----------------- Separate Security Issue: Update your Flash Player '''Note: Windows users''' should download the '''ActiveX''' for ''Internet Explorer.'' '''and''' the '''plugin''' for ''Plugin-based browsers'' (like Firefox). '''Note: Windows 8 and Windows 10''' have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX. Flash Player Version: '''Version 28.0.0.161 ''' https://get.adobe.com/flashplayer/ Direct link scans current system and browser '''Note: Other software''' is offered in the download. <Windows Only> https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) '''Note: Other software''' is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

Umnikazi wombuzo

I updated video drivers, but didn't seem to have any effect.

I tried running Firefox in safe mode and it's basically back to normal there. How can I find out what is causing the problem? I tried running with and without virus scanner, I've tried disabling all my extensions.

When I check the Programs and Features, I see that Firefox 58.0.2 was installed on Feb 14th which might have been the time this started (my original post said 13th, but I may have been mistaken because when I check windows update history, several dozen updates were installed on the 14th, not the 13th and I know I rebooted to install those).

I recorded the performance in the f12 developer tools window. I have attached some screenshots comparing safemode and normal mode page loading. The top image is from safe mode. Page is basically usable within a couple of seconds, and things continued to load asynchronously as I was looking at it. Second image is normal mode where you see it just does nothing while it is trying to load. When I look at the details below it seems to get stuck on a DOM event.

I updated video drivers, but didn't seem to have any effect. I tried running Firefox in safe mode and it's basically back to normal there. How can I find out what is causing the problem? I tried running with and without virus scanner, I've tried disabling all my extensions. When I check the Programs and Features, I see that Firefox 58.0.2 was installed on Feb 14th which might have been the time this started (my original post said 13th, but I may have been mistaken because when I check windows update history, several dozen updates were installed on the 14th, not the 13th and I know I rebooted to install those). I recorded the performance in the f12 developer tools window. I have attached some screenshots comparing safemode and normal mode page loading. The top image is from safe mode. Page is basically usable within a couple of seconds, and things continued to load asynchronously as I was looking at it. Second image is normal mode where you see it just does nothing while it is trying to load. When I look at the details below it seems to get stuck on a DOM event.

Isisombululo Esikhethiwe

Whelp, as suspected, it is 58.0.2 that causes the problem. I installed 58.0.1 and it's fine now. Guess I'll keep using this version until Mozilla can fix the problem.

Whelp, as suspected, it is 58.0.2 that causes the problem. I installed 58.0.1 and it's fine now. Guess I'll keep using this version until Mozilla can fix the problem.
FredMcD
  • Top 10 Contributor
4270 izisombululo 59892 izimpendulo
Kuphostiwe

uglycat said

I tried running Firefox in safe mode and it's basically back to normal

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

''uglycat [[#answer-1079099|said]]'' <blockquote> I tried running Firefox in safe mode and it's basically back to normal </blockquote> It could be the work of one of your add-ons, or it could be '''Hardware Acceleration. ''' ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link} Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control> ''(Mac=<Command>)'' <Shift> A) ''' In the Add-ons Manager, on the left, select '''Extensions. ''' Disable a few add-ons, then '''Restart Firefox. ''' Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All Of them. ''' If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group '''ONE AT A TIME''' (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

Umnikazi wombuzo

Thanks for the reply, but as I mentioned, I tried all those steps to no effect. After rolling back to v 58.0.1 (instead of 58.0.2) the issue has gone away. Something in the update caused the slowdown.

Unfortunately, at this point, the fact that this problem goes away when in safe mode is irrelevant since 58.0.1 works just fine without safe mode.

Thanks for the reply, but as I mentioned, I tried all those steps to no effect. After rolling back to v 58.0.1 (instead of 58.0.2) the issue has gone away. Something in the update caused the slowdown. Unfortunately, at this point, the fact that this problem goes away when in safe mode is irrelevant since 58.0.1 works just fine without safe mode.
philipp
  • Top 25 Contributor
  • Moderator
5324 izisombululo 23508 izimpendulo
Kuphostiwe

Impendulo Ewusizo

hi, do you happen to use avast or avg security software on the affected system? https://bugzilla.mozilla.org/show_bug.cgi?id=1438829

hi, do you happen to use avast or avg security software on the affected system? https://bugzilla.mozilla.org/show_bug.cgi?id=1438829

Umnikazi wombuzo

Yes, I use AVG. I had thought I tested with the scanner disabled, but maybe simply turning it off in the configuration panel isn't enough.

Yes, I use AVG. I had thought I tested with the scanner disabled, but maybe simply turning it off in the configuration panel isn't enough.