Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Adding Mail Account, so on Mail Acct Setup page I enter correct address & pw info, config finds provider (protonmail) but won't verify configuration.

  • 26 uphendule
  • 2 zinale nkinga
  • 475 views
  • Igcine ukuphendulwa ngu rbrown16

more options

I've tried the successful (for the other questioners) solutions offered in the articles that came up, but they didn't work. The one suggestion I couldn't try because the option didn't come up, was to press the "stop" button to keep TB from searching for the provider, then enter all the info manually BEFORE choosing the "Manual config" option. I couldn't do that because no "stop" button ever appeared.

In any case, I did try entering everything manually a number of times (including the IMAP and SMTP info), trying each and all of the "Authentication" options in that dropdown menu. But TB still insists that either my username (new email address) or password are invalid. I've done this many times now, carefully, and... same result no matter what, even after shutting TB down and starting fresh. By the way, TB does enter all of the IMAP and SMTP info correctly by itself, exactly as protonmail.com lays it out.

I don't want to start fresh by deleting my current Roadrunner account (which shows a POP server, if that makes any difference) and replacing it with the protonmail account, because then I'll lose all my folders and everything. I'd like to delete RR down the road, though.

Oh, and by the way I've followed Protonmail's instructions on how to set up Thunderbird.

Any ideas on this? I'm stymied. Thanks.

Isisombululo esikhethiwe

re :When I click on "Saved Passwords," a window comes up titled "Saved Logins" that says, "Logins for the following sites are stored on your computer", but there is nothing listed, just an empty square. (By the way, I do have a master password operating...)

If you have a master password operating then it will auto hide all the passwords... just in case the viewer is not you.

  • 'Menu icon' > 'Options' > 'Options' > 'Security' > 'Passwords' tab
  • click on 'Saved Passwords' button
  • click on 'Show Passwords' button

If Master Password is set, when you click on 'Show Passwords' button, you should be prompted to enter the master password when access to the stored passwords is needed. If you already know the currently stored passwords for twc account then you are ok, otherwise access and make a note of password.

All other info implies no account for Proton Mail has been created.

The profile name folder contains 'ImapMail' folder with an entry, so at some point you set up an imap mail account for road runner account as it uses the twc server settings.

The error message : "Incoming server already exists." Implies you have set up a mail account for that email address using those protonmail server settings. But there is no indication of this in the supplied info.

It is possible the issue lies with the password files.

So if you are ok with this, I'm going to advise you to delete a set of files to do with Passwords. This will mean the master password and other mail account passwords would get removed. So make sure you know what the Roadrunner account pasword is before deleting.


In Thunderbird

  • Help > Troubleshooting Information
  • click on 'Open Folder' button

a new window opens shwoing contents of profile name folder.

  • Close Thunderbird now - this is important.

scroll down and look for the following files and delete them.

  • cert8.db - (Security certificates. Works together with key3.db)
  • key3.db - (Key database. Works together with cert8.db,)
  • logins.json

Start Thunderbird

The Roadrunner account will probably ask for password if it is set to check for mail upon startup. Enter the password for Roadrunner account and select checkbox for password manager to remember password.

Then try again to set up the proton mail account as before... using the ProtonMail password (not the Proton email password).

Finally when all is set up and running, you can set a new master password if required.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (20)

more options

Regarding my above post, I meant to say that I've followed all of Protonmail's instructions on how to configure Thunderbird to work with their Mailbridge, which allows email downloads to TB.

more options

You mention new email address. Please confirm you have accessed this new email address via webmail. Confirm imap is selected - usually it is auto selected but I have some webmail accounts that required me to select it.

I presume you have already installed and added your account to the bridge as is specified by ProtonMail. I also presume you have accessed and made a careful note of the 'bridge password' from your bridge account settings screen. Double check you have got this correct as it may be complicated and case sensitive.


I'm presuming you are using 'Windows OS'

when adding mail account: 'Menu icon' > 'New Message' > 'Existing mail account' But TB still insists that either my username (new email address) or password are invalid. Username = full email address The password you use should be the 'bridge password' from your bridge account settings screen.

thunderbird will locate info. double check it is set up for imap. clicking on 'Manual Config' button gets you access to manually selecting server settings. Are you using your own domain or not? If yes, this is where you need to make adjustments. ProtonMail setup info says this: When you enter credentials for a custom domain, Thunderbird will give you an warning: Thunderbird failed to find the settings for your email account.. This is normal and expected. Enter your settings manually as shown above and click Done. https://protonmail.com/bridge/thunderbird#4

You will be asked to 'confirm security exception' for port 1143 on 127.0.0.1. https://protonmail.com/bridge/thunderbird#5

more options

Thanks, Toad-Hall. Yes, I can access this new email address online; I've tested it several times. Yes IMAP is selected.

Yes, I have installed the Bridge and my account is added (Proton identifies the account by what comes before the @ in the address, not by the entire address.)

It's likely that the Bridge password is the problem, if it's different from my Protonmail password, which I assumed it was not. When I go to the ProtonMail Bridge page and look under "settings," as you suggest, I see no password displayed, even when I click on "Advanced Settings." (To start, the Mail Bridge opened up when I clicked on the icon and asked for no ID or password.) Should I contact help at Protonmail to help me find this pw?

I am using Windows 7.

On the Thunderbird "Account Setup" page, I enter my own name under "Your Name", and under "Email address", Yes I do enter my entire xxx@protonmailcom address, and for "password" l enter my protonmail password (again, I can't find a separate Mail Bridge pw).

Clicking in the "Manual Config" button, everything looks in order. IMAP is selected. No, I don't have a custom domain name, just a regular xxx@protonmail.com address.

When I click on "Confirm security exception", I'm told again that the configuration can't be verified.

'WAIT: ' I just disabled my Ghostery and Privacy Badger, and now when I click on "Done", I'm no longer told that the config can't be verified and that my username or pw is invalid.... Instead an "error creating account" message comes up that says, "Incoming server already exists." This is a change and seems somehow promising, but I'm not savvy enough to know what to do next.

more options

'I finally found the ProtonMail password', indeed different from my Proton email password, and I entered that in its proper place, as you instructed. Now, everything goes through, "configuration found at email provider," but when I click on "Done" or try to finish up via Manual config , I get that "error creating account" message comes up that says, "Incoming server already exists." Any insight there?

more options

I meant the ProtonMail Bridge password...

more options

re: "Incoming server already exists." Any insight there?

This sounds like the first time you tried to set this up, something was actually setup, even if it did not work.

Start Thunderbird Is there any email address/mail account listed in the left Folder Pane?

more options

In Thunderbird Help > Troubleshooting Information Under 'Mail and News Accounts' section There should be a 'Local Folders' mail account. Is there any other Incoming server imap mail account listed ?

more options

The only email address listed in the left folder pane is my regular Roadrunner address at the very top, under which all the folders are subsumed.

Regading the "Troubleshooting Information" page that you directed me to, this is what I found sorry that all the formatting got destroyed, but I'm sure you can decipher it): Mail and News Accounts ID Incoming server Outgoing servers Name Connection security Authentication method Name Connection security Authentication method Default? account1 (pop3) mail.twc.com:110 None Normal password mail.twc.com:587 None Password, original method (insecure) true account2 (none) Local Folders None Normal password

Account 1 is my regular Pop3 acct... So it looks like an "account 2" is there, with nothing else filled in, so no IMAP there. Do I need to delete that?

more options

If you already have one pop mail account then all is correct. The second mail account belongs to 'Local Folders' a default mail account.

  • 'Menu icon' > 'Options' > 'Options' > 'Security' > 'Passwords' tab
  • click on 'Saved Passwords' button

There should be two lines for the one pop mail account:

  1. 'mailbox://pop mail account' line
  2. 'smtp://pop mail account' line

What do you see? Is there any other saved password lines?

Then make hidden files and folders visible:

In Thunderbird

  • Help > Troubleshooting Information
  • click on 'Open Folder' button
  • Is there an 'ImapMail' folder ?
  • If yes, click on ImapMail folder to open and tell me what you see in the contents.
more options

Dear Toad, thank you. I'll be away and out of internet reach from today until Feb. 25. I'll try what you suggest then, when I return, and will let you know. Take care for now.

more options

Another user of Proton Mail reported (at length!) that he needed to raise the minimum encryption level so as to inhibit SSL and force some particular level of TLS.

https://support.mozilla.org/en-US/questions/1203654

more options

Hello Toad, I'm back in town and am responding to your instructions and questions. These were your instructions: --- 'Menu icon' > 'Options' > 'Options' > 'Security' > 'Passwords' tab --- click on 'Saved Passwords' button When I click on "Saved Passwords," a window comes up titled "Saved Logins" that says, "Logins for the following sites are stored on your computer", but there is nothing listed, just an empty square. (By the way, I do have a master password operating...)

-- Continuing with your instructions, I followed the article you linked to show the 2 hidden files & folders indicated by changing those 2 settings. I did this via the "Control Panel" option.

-- Finally, under your heading, "In Thunderbird," I followed your 4 bullets. The only "Open file" button was for "Profile folder" under the "Application Basics" heading, so I opened that and yes there is an "IMAP Mail" folder. Opened that, and here are the 4 items displayed: 127.0.0.1 ................ (date) ........... file folder mail.twc.com ...........(date)............ file folder 127.0.0.1.msf ............(date) ........... MSF file mail.twc.com.msf .....(date)............ MSF file The first folder above contains one file: INBOX.msf; and the second folder contains 12 various MSF files.

Can you see a pathway in all of this?

more options

Isisombululo Esikhethiwe

re :When I click on "Saved Passwords," a window comes up titled "Saved Logins" that says, "Logins for the following sites are stored on your computer", but there is nothing listed, just an empty square. (By the way, I do have a master password operating...)

If you have a master password operating then it will auto hide all the passwords... just in case the viewer is not you.

  • 'Menu icon' > 'Options' > 'Options' > 'Security' > 'Passwords' tab
  • click on 'Saved Passwords' button
  • click on 'Show Passwords' button

If Master Password is set, when you click on 'Show Passwords' button, you should be prompted to enter the master password when access to the stored passwords is needed. If you already know the currently stored passwords for twc account then you are ok, otherwise access and make a note of password.

All other info implies no account for Proton Mail has been created.

The profile name folder contains 'ImapMail' folder with an entry, so at some point you set up an imap mail account for road runner account as it uses the twc server settings.

The error message : "Incoming server already exists." Implies you have set up a mail account for that email address using those protonmail server settings. But there is no indication of this in the supplied info.

It is possible the issue lies with the password files.

So if you are ok with this, I'm going to advise you to delete a set of files to do with Passwords. This will mean the master password and other mail account passwords would get removed. So make sure you know what the Roadrunner account pasword is before deleting.


In Thunderbird

  • Help > Troubleshooting Information
  • click on 'Open Folder' button

a new window opens shwoing contents of profile name folder.

  • Close Thunderbird now - this is important.

scroll down and look for the following files and delete them.

  • cert8.db - (Security certificates. Works together with key3.db)
  • key3.db - (Key database. Works together with cert8.db,)
  • logins.json

Start Thunderbird

The Roadrunner account will probably ask for password if it is set to check for mail upon startup. Enter the password for Roadrunner account and select checkbox for password manager to remember password.

Then try again to set up the proton mail account as before... using the ProtonMail password (not the Proton email password).

Finally when all is set up and running, you can set a new master password if required.

more options

Hello Toad, I'm just getting back to this after a few days. And I want to report partial success. In fact, I think the process would have gone through to the end successfully, following your latest instructions, had it not been for a seemingly unrelated glitch at the very end. Let me try explaining this simply:

First, what occurred when doing the installation: It went along fine, but a few seconds after I clicked on the final "done" button, a little popup appeared that said that protonmail couldn't complete the installation because it couldn't find the "drafts" folder. I went to my roadrunner mail page and saw that my protonmail address actually had been placed in the left panel with my roadrunner address and all the files, but when I clicked on it and the login window came up, it wouldn't log in.

A possible explanation for this: Some time ago I transferred all my email files in Thunderbird to Thunderbird on this computer by copying and transferring my Profile Folder as instructed. It worked fine, except that I wound up with not one set of the 5 standard folders (inbox, drafts, sent, trash, and outbox), but 1 or 2 other sets of these 5 folders, in addition to the set that my roadrunner address used. [Oops, I notice that the roadrunner email set doesn't have an "outbox" any longer...? I don't use it anyhow.] I can't recall whether there was 1 extra set or 2 of these (now I have 2), but in one of these sets the "drafts" and "outbox" folders were deleted somehow, maybe by my trying to get rid of an extra set. I recall that there were some incidental emails in a couple of these folders and I deleted the contents. In any case, apparently this is the set that protonmail tried to use, which explains why the message came up that proton couldn't find the "drafts" folder. In any case, I THINK this is how it happened.

It may be useful for you to know what that left panel looks like. (I'll bold the three main "headings" in the left panel.) As it is now, my roadrunner address appears at the top at the top with the standard folders under it (minus "outbox"); next is my protonmail address with the standard folders (minus "drafts" and "outbox"); next are "Local Folders" which contain first, the set of 5 standard folders, then all of my roadrunner folders & emails. My protonmail address with its sub-folders was plopped into the middle of what I had there before; I don't care about this as long as it works.

I'm sorry this is so long, but I wanted to give you the complete picture. So... can I delete that incomplete extra set (or both extra sets) and try the installation again? (I'll have to delete the new proton account probably via "remove account" on the Account Setting page...?)

Thanks much. I know this is going on longer than either of us would like, but if you see a do-able fix here, I'll be glad to hear it. -- Take care.

more options

In essence, you solved the problem I was having. I deleted the protonmail address from Firefox and proceeded again with your instructions. Now my protonmail address appears in the left margin along with my roadrunner address. I can download to my proton acct, but I can't send out from it. Seems that the problem resides with proton mail not recognizing my pw when entered from FF. I will take it up with proton mail.

Thank you for your help. All the best. BB

more options

Wondering if the the ProtonMail password has been stored in the outgoing smtp account. Worth checking...

'Menu icon' > 'Options' > 'Options' > 'Security' > 'Passwords' tab click on 'Saved Passwords' button click on 'Show Passwords' button Is the 'ProtonMail' password correctly stored for both incoming and outgoing ?

To edit: Right click on the smtp line for that account to select 'Edit Password'.


Located some info worth checking ...maybe the smtp port is not correct... Is the 'the bridge' using a port that is the same in Thunderbird and not used by something else?

The Bridge uses ports 1143 and 1025 by default but sometimes one or both of these are already in use. You can change these in the Bridge by going to: Help > Advanced settings > Change SMTP/IMAP Ports You can increment the port numbers (i.e. 1144 for IMAP / 1026 for SMTP) until you have ones that are not occupied by another application. Once you change the port make sure you also update the port settings in your email client. https://protonmail.com/bridge/faq

Okulungisiwe ngu Toad-Hall

more options

The Proton BRIDGE password is correctly stored. My protonmail pw is not there. Is that what you meant?

Yes, the port settings are correct: IMAP 1143 and SMTP 1025. Roadrunner doesn't use either of them.

I just want to return to the 'Drafts' folder/mailbox download failure for a minute. The configuration process (prton to TB) was almost complete when this message popped up: The current operation on 'Drafts' did not succeed. The email provider for [my proton email address] responded: No such mailbox. (This message still pops up continually every 30 seconds or so. Annoying.) Could this failure have anything to do with my inability to log in? If not, I can let this go, as I can live without a Drafts folder/mailbox if I have to. -- A curious fact: I newly installed Thunderbird on my other computer (a desktop) and configured it to Protonmail. And here, too, the 'Drafts' folder was NOT imported from my Proton account. And no 'failure' message ever came up about it. However, I'm able to log in just fine through TB on that computer. Why would TB have a problem with this on one computer and not the other? If there's a clue here, I don't see it.

-- But, as I said, if there's no likely connection between the failure to download 'Drafts' and the inability to log in, I can let it go.
more options

... Forgot to mention that on the desktop, I configured Thunderbird ONLY to Protonmail. No Roadrunner.

more options

Have you subscribed to see 'Drafts' folder? Right click on mail account in Folder Pane and select 'Subscribe'. select 'Drafts' and click on 'Subscribe', click on 'OK'

more options

I didn't know that existed. Okay, I just tried that, and 'Drafts' is not listed as one of the folders to subscribe to -- on both my laptop (the one with roadrunner) and the desktop (the one with only proton). Looks like it was just left out from the get-go.

If we can't resolve this login problem, I can still download mail from proton, but when I have to send out, I'll have to log into protonmail directly. It wouldn't be crippling, just inconvenient. I'm going to switch over from roadrunner to proton in the coming month or two (and cancel my account with rr), but I don't want to delete roadrunner from TB because I don't want to lose all my archived emails.

  1. 1
  2. 2