Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox won't ask to remember a password, on one site, on one PC

  • 30 uphendule
  • 2 zinale nkinga
  • 109 views
  • Igcine ukuphendulwa ngu fencer_gregj

more options

One site that I use regularly (https://studio.zenplanner.com) starts off with a login page. At one point I changed my password, and Firefox kept pre-filling with the wrong one. I went into Saved Logins and deleted the login. Since then, Firefox never asks to remember the password again. My email address does show as an autocomplete option in the email field on the form, but no password remembering.

Things I have checked:

- The site does not block saving logins like some banking sites do; Firefox will remember passwords for this site on other PCs. - The site is not listed under Exceptions. - Adding an Exception for this site and then removing it had no effect. - Unchecking and rechecking "Remember logins and passwords for websites" had no effect. - I am not running in Private Browsing mode. - I do not have a third-party password manager installed. - I do have Kaspersky Total Security installed, but I have it installed on other PCs as well and it does not interfere with password saving.

I'm trying Safe Mode next, but I can't find anything else to try in the support articles...

All Replies (10)

more options

fencer_gregj said

@Happy112 - yes, this is the only site showing this problem on this PC, and this is the only PC showing the problem with this site. It is also the only PC where I told FF to forget the saved login for this site.

Do you use Sync  ?

more options

Note that you do not need to remove a wrongly entered name or password because you can double-click name and password field or use the right-click context menu to edit these fields.

You say that the user name (email) appears as a login suggestion.

Can you remove this item from the drop-down list if you remove enough letters to open the list of autocomplete choices?

You can use these steps to remove saved items from an autocomplete drop-down list.

  1. click the (empty) input field on the web page to open the drop-down list
  2. highlight an entry in the drop-down list with cursor Down key
    do not click the mouse or press the Enter key
  3. press the Delete key (on Mac: Shift+Delete) to delete the highlighted entry

Note that hovering with the mouse no longer works.

Do all entries you see in the Password Manager have a user name and password or are there entries with an empty user name?

You can also try to compare the entries in logins.json with what you see in the Password Manager.

You can drag logins.json in a Firefox tab to use the builtin JSON viewer.

more options

OK, I tested it and I'm not seeing the key icon on the location/address bar when I enter some random email and password, so it looks that Firefox doesn't recognize this as a login form.

more options

@Happy112 - no, I don't use Sync.

@cor-el - the email address appears as an autocomplete suggestion, but only as an ordinary form autocomplete - just the string, no little padlock next to it. The password field doesn't show any autocomplete suggestions of any kind. Deleting the email address from the autocomplete as you suggest works as you describe, but has no effect on the password behavior. Yes, all the entries under Options->Privacy and Security->Forms & Passwords->Saved Logins have usernames attached. This particular site does not appear anywhere in the Saved Logins list, nor in logins.json.

more options

@cor-el - that's odd, it still seems to work on every other PC I have running FF. Maybe the site changed, but since the other PC's still have the login info saved, FF applies the saved data to the form in an ordinary autocomplete sense?

A test on one of those other PCs seems to confirm this. With the email address that has been used, the password will autocomplete (with the key next to the concealed password in the autocomplete list). Entering a different email address and its password does not offer to save the login.

So it looks like the site is responsible for removing the functionality. The Firefox issue is that the functionality can disappear in a confusing way with no indication of what changed. Should there maybe be some notification if Firefox uses a saved login to autocomplete a page which it does not recognize as a login page?

more options

Once you have saved the username and password then Firefox probably fills it because I see a fill login item in the right-click context menu. I don't know why Firefox doesn't offer to store the password, but I assume that saving worked in the past. Some websites design the login form in such a way that it doesn't trigger the Password Manager. Previously there was the Saved Password Editor extension for cases like this, but this is a Legacy extension and doesn't work in 58.

more options

You can also try a Form Filling add-on.

more options

If the Safe Password prompt was displayed before the site was removed from 'Saved Logins' - it can't be down to the site.

I posted this link earlier : https://support.mozilla.org/en-US/kb/usernames-and-passwords-are-not-saved and I'm thinking about what is says under 'Remember Password prompt is not displayed':

"Some graphics driver versions may have problems to display prompts. To see if this applies to you, follow the steps in :" https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems

Since it happens with this one PC only ......

more options

@Happy112 - from that article, "'If your problem persists in Safe Mode, it is not being caused by an extension, theme or hardware acceleration. Nice idea though.

more options

One more data point I notice that suggests that Firefox does recognize the form as a login: when I right-click in the email address field, the popup menu includes "Fill Login" (though there are no login suggestions in the submenu). Same for "Fill Password" on the context menu for the password field. FF doesn't include those menu items when I right-click other random text boxes on forms on other sites...

  1. 1
  2. 2