Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How do I clear out auto-fill fields in Firefox Quantum on Windows 10?

  • 11 uphendule
  • 2 zinale nkinga
  • 31 views
  • Igcine ukuphendulwa ngu TehNoob

more options

When I go to log in to my bank's web site, the field where I enter my name automatically shows up as blank rather than filling automatically. When I click on it to enter my username, the field shows a drop-down menu filled with random strings of numbers that I can't identify. They're not phone numbers or addresses.

I want to clear out the auto-fill fields like names and such in Firefox, but clearing the cache and using CCleaner don't work. Any suggestions how to clean this mess up?

When I go to log in to my bank's web site, the field where I enter my name automatically shows up as blank rather than filling automatically. When I click on it to enter my username, the field shows a drop-down menu filled with random strings of numbers that I can't identify. They're not phone numbers or addresses. I want to clear out the auto-fill fields like names and such in Firefox, but clearing the cache and using CCleaner don't work. Any suggestions how to clean this mess up?

All Replies (11)

more options

What happens if you select one of the random strings of numbers?

Normally, when Firefox has saved form data for a field, you can remove it by pressing the down arrow to highlight it and pressing the Delete key. Sometimes Shift+Delete works if Delete doesn't.

more options

More generally, you can completely purge Firefox's form and search history using the "Clear Recent History" dialog. You can call that up from the Library menu button, History panel, or by pressing Ctrl+Shift+Delete.

In the dialog, click the Details button to show the category check boxes. To avoid unintended consequences, uncheck everything else. ONLY check "Form & Search History".

Does that work?

more options

Thanks for getting back to me. If I select one of the fields, the site just says that I got my username wrong.

I tried clearing my recent history, but that got rid of everything else except those strings of numbers. I restarted Firefox, but I still see the numbers popping up. Maybe it's a messed up plugin or something.

I'll give your suggestions another shot after I finish banging my head into the wall. Thanks again!

more options

You can rename/remove logins.json and key4.db and key3.db (used previously) in the Firefox profile folder with Firefox closed not reset all stored passwords.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

more options

Make sure to make a note of all passwords that currently show in the Password Manager.

more options

Looks like deleting the logins.json and key4.db was the magic cure. Definitely need to remember that trick for later, just in case.

Thanks to both of you!

more options

TehNoob said

Looks like deleting the logins.json and key4.db was the magic cure. Definitely need to remember that trick for later, just in case. Thanks to both of you!

False alarm. The problem came back after following both cor-el's and jscher's advice. I have no idea why it respawned, but as soon as the login file started rebuilding itself, all the numbers came back. Even more interesting, after doing a search on my hard drive, I can't find any matches for those numbers anywhere.

Gremlins. Pretty sure it's gremlins.

more options

Since you've confirmed they are saved logins, is it possible to delete them from the dialog on the Options page?

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the left column, click Privacy & Security.

Then on the right side, find the "Saved Logins" button and click that to open a panel where you hopefully can remove those.

As for how they came back, do you use the Sync feature?

more options

I see I've been remiss in posting complete information. Sorry for that.

These aren't saved logins, but they do appear in the username field along with the saved username. One of the strings is 379693035734454, another is 342239506206499. No idea what they represent or where they came from, as I can't find them on my computer or in the .json or .db files themselves. (I used Notepad++ to open them and look.) None of them appeared in the Saved Logins screen and when I went to remove individual cookies, none of that showed up there, either.

I don't use Sync, though, so to my knowledge no other devices or operating systems have been in contact with mine.

more options

The new auto-fill feature likely uses local storage (IndexedDB) to store its data and that is probably in the storage folder in the Firefox profile folder.

Is that feature enabled in "Options/Preferences -> Privacy & Security"?

more options

cor-el said

The new auto-fill feature likely uses local storage (IndexedDB) to store its data and that is probably in the storage folder in the Firefox profile folder. Is that feature enabled in "Options/Preferences -> Privacy & Security"?

My apologies for the noob-ness, but I'm not sure which option covers that. I have checked: Forms and passwords Remember logins and passwords Autofill addresses Address bar Browsing history Bookmarks Open tabs Permissions Block pop-up windows Warn you when websites try to install add-ons Security Block dangerous and deceptive content

Everything else is unchecked. Which one should I be looking at?