Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox displays the error "Your Firefox profile cannot be loaded. It may be missing or inaccessible" and immediately quits.

  • 8 uphendule
  • 3 zinale nkinga
  • Igcine ukuphendulwa ngu Tonnes

more options

I've tried the instructions "How to run Firefox when your profile is missing or inaccessible" at

This doesn't help because it asks me to use the profile manager, but any attempt at launching Firefox or anything inside it produces the same result.

I've also tried replacing Firefox with a fresh copy.

The Profile folder is present in the usual place and I've verified that I have read-write permission on the folder and everything within it. 57.0.4 on MacOS 10.13.2.

Isisombululo esikhethiwe

Can you see if this question is of any help?

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (8)

more options

No responses. Perhaps I can perform an uninstall/reinstall. I tried deleting the folder in ~/Library/Application Support but I continued to get the same error.

more options

Isisombululo Esikhethiwe

Can you see if this question is of any help?

more options

The cache file was the problem. ~/Library/Caches/Firefox was an invalid link to nothing. Thanks. Notes:

1. The error displayed was exceptionally confusing. 2. Not clear how this happened. Perhaps an error in the update process.

In any event, thanks. Now I don't have to use @!$*(#&$ Chrome. :-)

more options

The problem just recurred. Deleting the cache file again fixed the problem. But there's clearly a problem somewhere.

more options

I have this problem as well. I didn't have a cache file, my profile is missing, reinstalling didn't fix the problem either. This article seemed promising: but trying to run the profile manager from the command line just feeds me the same warning. I didn't have the folder Library/Application Support/Firefox. Running Mac OS 10.13.3 Help!!

Okulungisiwe ngu Partisanpixel

more options

@ Partisanpixel

Did you make sure that Library/Application Support/Firefox folder does not reside in the Home folder (referred to by ~/ )? And did you check the ~/Library/Caches/Firefox/Profiles/ folder?

more options

Thanks for the reply @tonnes, but nothing in ~/ or in my user library, and I have no Firefox folder in ~/Library/Caches.

more options

I’m sorry but I don’t use a Mac myself, so someone who does may be able to answer this in a better way. If these are the proper paths though, they may simply be missing for some reason, possibly causing the error. That means you could try adding a path (or sym link when needed) manually, but it may be better to find both proper profile paths by searching for the associated profile folders by its name. There should be a cache folder at least.

You could also temporarily move the profiles.ini file as suggested in the support article referred to by the other question * and see if you can create a new profile / launch the profile manager afterwards. If that works, Firefox is likely not able to find a profile or parts (associated paths) for any of them. When doing so, back up the existing profile folder(s) first in order to be able to restore existing data when needed. See these articles for more info on profiles:

Profile Manager - Create, remove or switch Firefox profiles Profiles - Where Firefox stores your bookmarks, passwords and other user data How to run Firefox when your profile is missing or inaccessible *