X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox crashes every time after I close it

Kuphostiwe

Hello!

these days I noticed that firefox is using way too much RAM after 2-3 hours.

I enabled multiprocess and now I can see on the task manager that the process that handles the 20 tabs uses ~700mb and the other 1400mb!!! Firefox is lagging and I have to restart it.

And here is another problem. When I exit FF, it won't terminate, after 1-2 minutes the crash report pops up and informs me about the crashed FF.

here are the latest dumps.

https://crash-stats.mozilla.com/report/index/43d0de44-8db5-4360-80af-6148c1180110

https://crash-stats.mozilla.com/report/index/4fc378ad-9088-455d-9b58-ab29d1180110

https://crash-stats.mozilla.com/report/index/30685cfd-b3b9-4634-b545-2f5da1180110


thanks in advance for your help

Hello! these days I noticed that firefox is using way too much RAM after 2-3 hours. I enabled multiprocess and now I can see on the task manager that the process that handles the 20 tabs uses ~700mb and the other 1400mb!!! Firefox is lagging and I have to restart it. And here is another problem. When I exit FF, it won't terminate, after 1-2 minutes the crash report pops up and informs me about the crashed FF. here are the latest dumps. https://crash-stats.mozilla.com/report/index/43d0de44-8db5-4360-80af-6148c1180110 https://crash-stats.mozilla.com/report/index/4fc378ad-9088-455d-9b58-ab29d1180110 https://crash-stats.mozilla.com/report/index/30685cfd-b3b9-4634-b545-2f5da1180110 thanks in advance for your help

Okulungisiwe ngu sakis_the_fraud

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.132 Safari/537.36

Eminye Imininingwane

Shadow110 1072 izisombululo 14836 izimpendulo
Kuphostiwe

Those crash reports do not help as they must start with bp-

Update Video Card Drivers, is a must.

Depending on how much ram you have that is not bad considering that each Extension uses 20megs give or take.

Since you have hid all and turned off send info to Mozilla from within Firefox before submitting a question I have no information and you have supplied none that is useful to figure this out so I will be guessing : Please : go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser.

Monitor in Task Manager. Should stay below 2 gigs. If excessive then do below and monitor and change if need to...Test and go up again , go back down, it will eventually get a zone you and it can live with.

Go to the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please.

Note : Hardware Acceleration is for Video Card, Monitor to see if remain off or to turn back on.

Please let us know if this solved your issue or if need further assistance.

Those crash reports do not help as they must start with bp- Update Video Card Drivers, is a must. Depending on how much ram you have that is not bad considering that each Extension uses 20megs give or take. Since you have hid all and turned off send info to Mozilla from within Firefox before submitting a question I have no information and you have supplied none that is useful to figure this out so I will be guessing : Please : go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser. Monitor in Task Manager. Should stay below 2 gigs. If excessive then do below and monitor and change if need to...Test and go up again , go back down, it will eventually get a zone you and it can live with. Go to the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please. Note : Hardware Acceleration is for Video Card, Monitor to see if remain off or to turn back on. Please let us know if this solved your issue or if need further assistance.

Umnikazi wombuzo

Pkshadow said

Those crash reports do not help as they must start with bp-

what should i do to enable this type of crash reports?

Pkshadow said

Update Video Card Drivers, is a must. Depending on how much ram you have that is not bad considering that each Extension uses 20megs give or take.

I was using this exact setup 3 days ago with no problems. I know that FF can reach to these levels but after a day or after 50+ tabs not in some hours with 30 tabs.

So yes, there is definitely a problem somewhere.

Pkshadow said

Since you have hid all and turned off send info to Mozilla from within Firefox before submitting a question I have no information and you have supplied none that is useful to figure this out so I will be guessing : Please : go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser.

I am using FF 56 and I can't see that option.

''Pkshadow [[#answer-1063045|said]]'' <blockquote> Those crash reports do not help as they must start with bp- </blockquote> what should i do to enable this type of crash reports? ''Pkshadow [[#answer-1063045|said]]'' <blockquote> Update Video Card Drivers, is a must. Depending on how much ram you have that is not bad considering that each Extension uses 20megs give or take. </blockquote> I was using this exact setup 3 days ago with no problems. I know that FF can reach to these levels but after a day or after 50+ tabs not in some hours with 30 tabs. So yes, there is definitely a problem somewhere. ''Pkshadow [[#answer-1063045|said]]'' <blockquote> Since you have hid all and turned off send info to Mozilla from within Firefox before submitting a question I have no information and you have supplied none that is useful to figure this out so I will be guessing : Please : go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser. </blockquote> I am using FF 56 and I can't see that option.
FredMcD
  • Top 10 Contributor
4272 izisombululo 59923 izimpendulo
Kuphostiwe

Pkshadow said

Those crash reports do not help as they must start with bp-

Normally true, but the user posted the web address to the reports.


Product Firefox Release Channel release Version 56.0.2 Build ID 20171024165158 OS Windows 10 OS Version 10.0.15063

bp-43d0de44-8db5-4360-80af-6148c1180110 bp-4fc378ad-9088-455d-9b58-ab29d1180110 bp-30685cfd-b3b9-4634-b545-2f5da1180110

Signature: shutdownhang | mozilla::dom::workers::RuntimeService::Cleanup

atidxx32.dll = Advanced Micro Devices = Check this link; http://support.amd.com/en-us/download/desktop?os=Windows+7+-+64

This is for Sumo's Related Bugs 1405290 REOPENED --- Shutdownhang in mozilla::dom::workers::RuntimeService::Cleanup rising in Firefox 56

1267692 NEW --- crash in shutdownhang | WaitForSingleObjectEx | WaitForSingleObject | PR_WaitCondVar | nsThread::ProcessNextEvent | NS_ProcessNextEvent | mozilla::dom::workers::RuntimeService::Cleanup

''Pkshadow [[#answer-1063045|said]]'' <blockquote> Those crash reports do not help as they must start with bp- </blockquote> Normally true, but the user posted the web address to the reports. --------------------- Product Firefox Release Channel release Version 56.0.2 Build ID 20171024165158 OS Windows 10 OS Version 10.0.15063 bp-43d0de44-8db5-4360-80af-6148c1180110 bp-4fc378ad-9088-455d-9b58-ab29d1180110 bp-30685cfd-b3b9-4634-b545-2f5da1180110 Signature: shutdownhang | mozilla::dom::workers::RuntimeService::Cleanup atidxx32.dll = Advanced Micro Devices = '''Check this link; ''' http://support.amd.com/en-us/download/desktop?os=Windows+7+-+64 This is for Sumo's Related Bugs 1405290 REOPENED --- Shutdownhang in mozilla::dom::workers::RuntimeService::Cleanup rising in Firefox 56 1267692 NEW --- crash in shutdownhang | WaitForSingleObjectEx | WaitForSingleObject | PR_WaitCondVar | nsThread::ProcessNextEvent | NS_ProcessNextEvent | mozilla::dom::workers::RuntimeService::Cleanup
FredMcD
  • Top 10 Contributor
4272 izisombululo 59923 izimpendulo
Kuphostiwe

Is there a reason you are using v56? https://support.mozilla.org/en-US/kb/update-firefox-latest-version?cache=no Did you update Firefox to the latest version 57.0.4


Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


Start your Computer in safe mode with network support. Then start Firefox. Try Safe websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Is there a reason you are using v56? https://support.mozilla.org/en-US/kb/update-firefox-latest-version?cache=no Did you update Firefox to the latest version '''57.0.4''' -------------- [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? ------------------ Start your '''Computer''' in safe mode with network support. Then start Firefox. Try '''Safe''' websites. Is the problem still there? http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Umnikazi wombuzo

FredMcD said

Is there a reason you are using v56? https://support.mozilla.org/en-US/kb/update-firefox-latest-version?cache=no Did you update Firefox to the latest version 57.0.4

I haven't updated to Quantum because most of my extension won't work!

I really can't tell if you got something from the crash dumps or from the reported related bugs or if you were just informing me that there are others with the same problem, too.

''FredMcD [[#answer-1063210|said]]'' <blockquote> Is there a reason you are using v56? https://support.mozilla.org/en-US/kb/update-firefox-latest-version?cache=no Did you update Firefox to the latest version '''57.0.4''' </blockquote> I haven't updated to Quantum because most of my extension won't work! I really can't tell if you got something from the crash dumps or from the reported related bugs or if you were just informing me that there are others with the same problem, too.
FredMcD
  • Top 10 Contributor
4272 izisombululo 59923 izimpendulo
Kuphostiwe

sakis_the_fraud said

I haven't updated to Quantum because most of my extension won't work!

I am still on v54 for the same reason

I really can't tell if you got something from the crash dumps

I post the crash that way so that others like me can see the report without needing to open the report themselves unless there is something more they need.

I called for more help.

Did you try Firefox or the computer in Safe Mode?

''sakis_the_fraud [[#answer-1063487|said]]'' <blockquote> I haven't updated to Quantum because most of my extension won't work! </blockquote> I am still on v54 for the same reason <blockquote> I really can't tell if you got something from the crash dumps </blockquote> I post the crash that way so that others like me can see the report without needing to open the report themselves unless there is something more they need. I called for more help. Did you try Firefox or the computer in Safe Mode?

Umnikazi wombuzo

FredMcD said

I called for more help.

Any updates from the cavalry?

FredMcD said

Did you try Firefox or the computer in Safe Mode?

I tried FF with minimal extensions, this night i will try ff in safe mode without any of them.

Here are the latest crash dumps bp-3c30046e-bb6a-4a5d-8cb6-2cf261180116 bp-39fac720-beb0-42e8-a348-0dc341180116 bp-6f90abb1-a79c-47e3-bc87-065791180115

''FredMcD [[#answer-1063591|said]]'' <blockquote>I called for more help.</blockquote> Any updates from the cavalry? ''FredMcD [[#answer-1063591|said]]'' <blockquote> Did you try Firefox or the computer in Safe Mode? </blockquote> I tried FF with minimal extensions, this night i will try ff in safe mode without any of them. Here are the latest crash dumps [https://crash-stats.mozilla.com/report/index/3c30046e-bb6a-4a5d-8cb6-2cf261180116 bp-3c30046e-bb6a-4a5d-8cb6-2cf261180116] [https://crash-stats.mozilla.com/report/index/39fac720-beb0-42e8-a348-0dc341180116 bp-39fac720-beb0-42e8-a348-0dc341180116] [https://crash-stats.mozilla.com/report/index/6f90abb1-a79c-47e3-bc87-065791180115 bp-6f90abb1-a79c-47e3-bc87-065791180115]