Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

I am getting the missing profile error in the latest Firefox Quantum but can't fix it

more options

I suddenly started getting the error "Your Firefox profile cannot be loaded. It may be missing or inaccessible.". I followed the directions for removing the .ini file (I'm on Mac OS High Sierra). But the problem didn't go away.

I tried using the Firefox Profile Manager. It does launch the profile manager window where there were no profiles. I created a new profile. It then opened Firefox. I could use it ok. But then I closed Firefox and re-opened it and got the error again.

Here is what shows up in my console window when I run the profile manager:

MacBook-Pro-2:me$ sudo /Applications/ -P MacBook-Pro-2:me$ 2017-11-30 14:27:41.594 plugin-container[8508:15019641] *** CFMessagePort: bootstrap_register(): failed 1100 (0x44c) 'Permission denied', port = 0xb943, name = '' See /usr/include/servers/bootstrap_defs.h for the error codes. 2017-11-30 14:27:57.203 plugin-container[8524:15021634] *** CFMessagePort: bootstrap_register(): failed 1100 (0x44c) 'Permission denied', port = 0xae3f, name = '' See /usr/include/servers/bootstrap_defs.h for the error codes. 2017-11-30 14:28:11.580 plugin-container[8533:15023234] *** CFMessagePort: bootstrap_register(): failed 1100 (0x44c) 'Permission denied', port = 0xc23f, name = '' See /usr/include/servers/bootstrap_defs.h for the error codes.

I can't get this browser to work at all! Is there a way to completely uninstall and start over?

All Replies (20)

more options
more options

I tried all of these. I just did the refresh (which I could only do by launching it via the command line with the profile manager). After it closed and restarted it came up ok. But if I Quit the application completely and then re-open it, I get the same error message.

more options

Try to update to Firefox 57.0.1.

  • Firefox -> About Firefox

Did you find the profiles.ini file?

You can try these steps:

You can find the profiles.ini file in this hidden location:

  • Mac: ~/Library/Application Support/Firefox/

If deleting the profiles.ini file isn't working then check the location of the cache files.

  • Mac: ~/Library/Caches/Firefox/Profiles/

In Mac OS X v10.7 and later, the ~/Library folder in the Home directory is a hidden folder.

more options

1. I have the latest build of Firefox. I just re-downloaded it to be sure. I can't even open safe mode (doesn't seem to be possible on the Mac) to run the About.

2. Yes I found the profiles.ini file. I removed it and emptied my trash completely.

3. I tried all three of those directions. I can open FF if I use the profile manager from the command line but I won't continue to use this browser if I have to do that every time. I have deleted and recreated profiles numerous times now. Once I quite FF and try to re-open it, I get that error.

4. There isn't a Firefox or Firefox/Profiles folder in ~/Library/Caches. I'm aware that these are hidden folders. I know how to get to them both from the Finder->Go menu as well as the command line.

more options

As you probably know, Firefox is a "multiprocess" application. Firefox assess whether your current configuration is compatible with multiprocess during the first run -- first run after installation or first run after a Refresh -- and if it is, enables it going forward for future runs. Perhaps there is a problem there?

The preference to enable multiprocess is stored in the prefs.js file in each Firefox profile folder. If you are comfortable editing the file (just in a plain text editor), I'm curious whether it will help.

The preference would be:

user_pref("browser.tabs.remote.autostart.2", true);

and the edit would be to change true to false

Then at the next startup, Firefox should use single-process mode.

Any difference?

For reference: Profiles - Where Firefox stores your bookmarks, passwords and other user data

more options

Well I'd be happy to edit that file except I still have NO profile folders. I go to ~/Library/Application Support/Firefox/Profiles and the folder is empty. I've opened the profile manager using command line "/Applications/ -P" and I see the "Default User" profile I created. But it doesn't seem to save the profile anywhere.

more options

Where did you find the profiles.ini file? It shows the path to the profile folders. Typically it's a relative path into the Profiles folder, but it could be somewhere else -- which may be part of the problem.

more options

When this all started I found the profiles.ini file in the ~/Library/Application Support/Firefox/Profiles folder I believe (or just in ~/Library/Application Support/Firefox - I don't recall). I deleted it. When it didn't fix it I also deleted the folder in Profiles that I believed was the profile data.

What I can't figure out is why the profile manager won't put the new profile in where it belongs.

more options

Good question. When you create your next new profile, check whether it indicates the location it is going to use. If it's not the standard location, that may indicate some kind of privileges/permissions issue, or Firefox may be very, very confused. Either way, there is a button you can use to force the location to be the normal one.

After creating the profile and launching Firefox, you can:

  • Open the about:profiles page to see the full path of the current profile
  • Open the about:config page and switch off the browser.tabs.remote.autostart.2 preference (assuming Firefox has had time to set it)

To open those pages, please type or paste that internal address in the address bar and press Return to load it.

more options

Ah interesting. I hadn't noticed the location before. For some reason it put the Default User profile in the /private/var/root/Library/Application Support/Firefox/Profiles folder. I created a new profile and put it into my user account's Library/Application Support/Firefox folder. Firefox came up and I went to about:profiles and saw the Default User profile in private/ and removed that profile, leaving the new one as the default profile.

I went to about:config and changed that setting. I then quit FF and tried to start it normally and again go the profile error.

So I went to the ~/Library/Application Support/Firefox folder and realized maybe the profile should be in the Profiles folder. But it is set as locked with the little red circle with a - in it. I modified the properties and made it R&W for my user and then moved it to the Profiles folder. Still no dice. Same problem.

So restarted profile manager, deleted the new profile and once again created a new one, this time putting it into the ~/Library/Application Support/Firefox/Profiles folder. Interestingly when I did this I started getting the following errors in the terminal:

objc[17281]: Class FIFinderSyncExtensionHost is implemented in both /System/Library/PrivateFrameworks/FinderKit.framework/Versions/A/FinderKit (0x7fff9c808a70) and /System/Library/PrivateFrameworks/FileProvider.framework/OverrideBundles/FinderSyncCollaborationFileProviderOverride.bundle/Contents/MacOS/FinderSyncCollaborationFileProviderOverride (0x11d7bfcd8). One of the two will be used. Which one is undefined.

2017-12-01 16:21:02.768 plugin-container[17317:4669237] *** CFMessagePort: bootstrap_register(): failed 1100 (0x44c) 'Permission denied', port = 0xa73f, name = '' See /usr/include/servers/bootstrap_defs.h for the error codes.

Anyway, so now I'm stuck. Why does it want to default to /usr/var/private/root for the folder path for profiles?

more options

I am not familiar with using terminal. I wonder if there is some account associated with the terminal app that is pointing the Profile Manager to that folder. ???

more options

When you use the Profile Manager to start Firefox then the path to the profile folder might be kept in memory and at that time profiles.ini is not used and you might be able to start Firefox. When you exit and restart Firefox then profiles.ini will be used and that file still seems to link to an non existing profile folder. Maybe try to use the button on the about:profiles page to go to the profile folder when you have started Firefox via the Profile Manager to see where you end up and go up one level to see if that brings you to the profiles.ini file.

Also check the owner and the permissions of the profile folder location in both places and possibly rename/remove the Firefox folder.

  • ~/Library/Application Support/Firefox/
  • ~/Library/Caches/Firefox/
more options

Firefox is completely screwed for me now. I've tried everything on this thread. The only thing I can do is open terminal and type:

sudo /Applications/ -P

Firefox will work after this, but the moment I close Firefox the same error appears again :(

"Profile Missing Your Firefox profile cannot be loaded. It may be missing or inaccessible."

Okulungisiwe ngu andrewjohnstrong

more options

Hi andrewjohnstrong

This happens if the profiles.ini file doesn't get updated. The file is present, but the profile marked in profiles.ini doesn't exist on the hard drive. You will have to find profiles.ini and delete this file. You can also check its permissions (read/write/owner) to make sure that Firefox can modify the file.

There might be a problem with permissions/ownership of involved folders/files preventing access. You can check for problems with the profiles.ini file [1] that registers profiles.


You can try these steps:

You can find the profiles.ini file in this hidden location:

  • Mac: ~/Library/Application Support/Firefox/
  • Linux: ~/.mozilla/firefox/
  • Windows: %AppData%\Mozilla\Firefox\

You can find a button on the about:profiles page to go to the profile folder and go up one level (..).

If deleting the profiles.ini file isn't working then check the location of the cache files.

  • Mac: ~/Library/Caches/Firefox/Profiles/
  • Linux:~/.cache/mozilla/firefox/
  • Windows: C:\Users\<user>\AppData\Local\Mozilla\Firefox\Profiles\<profile>\

If this still didn't work then rename/delete the Firefox/ folder in both above mentioned locations (root:main, local:cache).

more options

@cor-el what does this mean?

If this still didn't work then rename/delete the Firefox/ folder in both above mentioned locations (root:main, local:cache).

I've tried everything else you mentioned and nothing has worked. I even used an app remover to wipe all existence of Firefox from my system and reinstalling it. Same exact problem. Honestly it seems like there's some kind of permission problem happening but I can't seem to figure out what.

Okulungisiwe ngu emergingdzns

more options

You will first have to find the profiles.ini file.

Did you try the button on the about:profiles page?

To what location brings you that (Root Directory)?

more options

I've tried all of those options thank you but no luck :(

Interestingly, when I go to create a new profile the default location is "private/var/root/Library/Application Support/Firefox/Profiles/cqltynqj.Default User (which I can browse to via finder but I can't see anything past "private/var/root/Library/Application Support/Firefox/" .

Instead, I create a profile on my desktop and change permissions to basically be 777.

When I re-run the terminal command sudo /Applications/ -P the profiles that I created (Andrew) still exists, and I can select it and successfully open Firefox, but the moment I close Firefox I'm back to the original error,.

more options

I guess this means goodbye firefox for me. Which absolutely sucks as I've used it for development for over 15 years.

more options

Hi andrewjohnstrong, in the screenshot, your Firefox folder has a red circle with a white dash on it, which I understand you mean that you (the current user) do not have permission to access it.

Can you think of any reason for that? Was the folder migrated from a different user account?

You could try using Get Info to fix the folder privileges. Here are two articles that discuss that:

more options

I see a mention of Parallels in the screenshot. Are you running Firefox via an emulator?

If the profile is created by default in a location owned by root then you are likely to run into issues.

  1. 1
  2. 2