X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Disable autoupdates in Firefox

Kuphostiwe

I don't want to use new firefox version. I need FF 56. I disable autoupdate in options but firefox updates itself anyway. How to fix it?

I don't want to use new firefox version. I need FF 56. I disable autoupdate in options but firefox updates itself anyway. How to fix it?

Isisombululo esikhethiwe

Next day it autoupdates again. I tried to monitor it by Procmon utility and finally I've figure out why it occurs. Accidentally I have found corporate protection system (Heimdal Security) which monitors all software installed on my PC and autoupdates it if necessary without any user confirmation. And there is no way to disable it because of group policy settings. So I found that its not Firefox issue but my environment issue.

Funda le mpendulo ngokuhambisana nalesi sihloko 0

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

Eminye Imininingwane

FredMcD
  • Top 10 Contributor
4272 izisombululo 59922 izimpendulo
Kuphostiwe

First, Type about:preferences#advanced<enter> in the address bar. Under Advanced, Select Update.

[v56+] Type about:preferences#general<enter> in the address bar. Select Update.

Select Never Check For Updates.

Also turn off Use a background service to install updates

First, Type '''about:preferences#advanced'''<enter> in the address bar. Under '''Advanced, ''' Select '''Update. ''' [v56+] Type '''about:preferences#general'''<enter> in the address bar. Select '''Update. ''' Select '''Never Check For Updates.''' Also turn off '''Use a background service to install updates'''

Umnikazi wombuzo

It doesn't work for me. Firefox updates itself despite selected options.

It doesn't work for me. Firefox updates itself despite selected options.
FredMcD
  • Top 10 Contributor
4272 izisombululo 59922 izimpendulo
Kuphostiwe

Do the options remain as you put them or change back?

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

Do the options remain as you put them or change back? https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save '''Note:''' Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

Umnikazi wombuzo

The options remain as I put them. "Reset" procedure doesn't help too.

The options remain as I put them. "Reset" procedure doesn't help too.

Umnikazi wombuzo

I have no any software which protects Firefox profile against changes.

I have no any software which protects Firefox profile against changes.
FredMcD
  • Top 10 Contributor
4272 izisombululo 59922 izimpendulo
Kuphostiwe

I called for more help.

I called for more help.

Umnikazi wombuzo

FredMcD said

I called for more help.

Noone helped you?

''FredMcD [[#answer-1040774|said]]'' <blockquote> I called for more help. </blockquote> Noone helped you?
FredMcD
  • Top 10 Contributor
4272 izisombululo 59922 izimpendulo
Kuphostiwe

I called again.

I called again.
Happy112 561 izisombululo 5694 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Maybe you have the Mozilla Maintenance Service installed on your system.

If that's the case :

To uninstall it, you'll need to scroll down to the section 'Uninstalling the Mozilla Maintenance Service' in this article  :

https://support.mozilla.org/en-US/kb/what-mozilla-maintenance-service

Maybe you have the Mozilla Maintenance Service installed on your system. If that's the case : To uninstall it, you'll need to scroll down to the section 'Uninstalling the Mozilla Maintenance Service' in this article : https://support.mozilla.org/en-US/kb/what-mozilla-maintenance-service

Umnikazi wombuzo

Thank you for your efforts, friends! It was helpful! Looks like it fixed the issue!

Here are all my steps that helped to fix the issue (I don't know clearly whether it affects or not but maybe someone find it helpful): 1. Uninstall Firefox (x86) 2. Restart PC 3. Uninstall Firefox (x64) yes, they were both installed on my PC 4. Restart PC 5. Uninstall Mozilla Maintenance Service (while uninstalling an error occured telling me that the service was already removed) 6. Install Firefox 55.0.2 and unselect checkbox to install "Mozilla Maintenance Service"! 7. During first Firefox startup go to Options imediately and verify that checkbox "Never Check For Updates" and "Automatically update search plugins" are unselected. 8. As you unselect Background update service during Firefox installation earlier there is no option "Use a background service to install updates". It's OK.

After all these steps performed it looks like it really doesn't updates itself. But I need more time to prove it.

Thank you for your efforts, friends! It was helpful! Looks like it fixed the issue! Here are all my steps that helped to fix the issue (I don't know clearly whether it affects or not but maybe someone find it helpful): 1. Uninstall Firefox (x86) 2. Restart PC 3. Uninstall Firefox (x64) yes, they were both installed on my PC 4. Restart PC 5. Uninstall Mozilla Maintenance Service (while uninstalling an error occured telling me that the service was already removed) 6. Install Firefox 55.0.2 and unselect checkbox to install "Mozilla Maintenance Service"! 7. During first Firefox startup go to Options imediately and verify that checkbox "Never Check For Updates" and "Automatically update search plugins" are unselected. 8. As you unselect Background update service during Firefox installation earlier there is no option "Use a background service to install updates". It's OK. After all these steps performed it looks like it really doesn't updates itself. But I need more time to prove it.
Happy112 561 izisombululo 5694 izimpendulo
Kuphostiwe

Round of applause for you, Alexei  !

Keep us informed, will you please  ?

Round of applause for you, Alexei ! Keep us informed, will you please ?

Isisombululo Esikhethiwe

Next day it autoupdates again. I tried to monitor it by Procmon utility and finally I've figure out why it occurs. Accidentally I have found corporate protection system (Heimdal Security) which monitors all software installed on my PC and autoupdates it if necessary without any user confirmation. And there is no way to disable it because of group policy settings. So I found that its not Firefox issue but my environment issue.

Next day it autoupdates again. I tried to monitor it by Procmon utility and finally I've figure out why it occurs. Accidentally I have found corporate protection system (Heimdal Security) which monitors all software installed on my PC and autoupdates it if necessary without any user confirmation. And there is no way to disable it because of group policy settings. So I found that its not Firefox issue but my environment issue.
FredMcD
  • Top 10 Contributor
4272 izisombululo 59922 izimpendulo
Kuphostiwe

Well done. Contact its support.

Well done. Contact its support.